您尚未登录。

#1 2016-11-27 20:48:21

juanxincai
会员
注册时间: 2016-11-01
帖子: 4

安装社区福昕阅读器时发生错误

执行 yaourt -S foxitreader时发生错误:

正在解决依赖关系...
:: 有 4 个软件包可提供 libgl :
:: 软件库 extra
   1) mesa-libgl  2) nvidia-304xx-libgl  3) nvidia-340xx-libgl  4) nvidia-libgl
正在查找软件包冲突...

软件包 (126) acl-2.2.52-3  atk-2.22+1+gd57f97d-1  attr-2.4.47-2  avahi-0.6.32-2  bash-4.4.005-1  bzip2-1.0.6-5  cairo-1.14.6-2  compositeproto-0.4.2-3  coreutils-8.25-2  cracklib-2.9.6-1  damageproto-1.2.1-3  db-5.3.28-3  dbus-1.10.12-1  desktop-file-utils-0.23-1  e2fsprogs-1.43.3-1  expat-2.2.0-2  filesystem-2015.09-1  fixesproto-5.0-3  fontconfig-2.12.1-3  freetype2-2.7-2  gcc-libs-6.2.1-1  gdbm-1.12-2  gdk-pixbuf2-2.36.0+2+ga7c869a-1  glib2-2.50.2-1  glibc-2.24-2  gmp-6.1.1-1  .......
全部安装大小:  508.73 MiB

正在检查密钥环......
正在检查软件包完整性...
正在加载软件包文件...
正在检查文件冲突...
libjpeg-turbo: 文件系统中已存在 /usr/bin/cjpeg
libjpeg-turbo: 文件系统中已存在 /usr/bin/djpeg
libjpeg-turbo: 文件系统中已存在 /usr/bin/jpegtran
libjpeg-turbo: 文件系统中已存在 /usr/bin/rdjpgcom
libjpeg-turbo: 文件系统中已存在 /usr/bin/tjbench
libjpeg-turbo: 文件系统中已存在 /usr/bin/wrjpgcom
libjpeg-turbo: 文件系统中已存在 /usr/include/jconfig.h
libjpeg-turbo: 文件系统中已存在 /usr/include/jerror.h
libjpeg-turbo: 文件系统中已存在 /usr/include/jmorecfg.h
libjpeg-turbo: 文件系统中已存在 /usr/include/jpegint.h
libjpeg-turbo: 文件系统中已存在 /usr/include/jpeglib.h
libjpeg-turbo: 文件系统中已存在 /usr/include/turbojpeg.h
libjpeg-turbo: 文件系统中已存在 /usr/lib/libjpeg.so
libjpeg-turbo: 文件系统中已存在 /usr/lib/libjpeg.so.8
libjpeg-turbo: 文件系统中已存在 /usr/lib/libjpeg.so.8.1.2
.
.
.
省略一大长串LOG
.
.
.
gtk2: 文件系统中已存在 /usr/share/locale/zh_HK/LC_MESSAGES/gtk20-properties.mo
gtk2: 文件系统中已存在 /usr/share/locale/zh_HK/LC_MESSAGES/gtk20.mo
gtk2: 文件系统中已存在 /usr/share/locale/zh_TW/LC_MESSAGES/gtk20-properties.mo
gtk2: 文件系统中已存在 /usr/share/locale/zh_TW/LC_MESSAGES/gtk20.mo
gtk2: 文件系统中已存在 /usr/share/themes/Default/gtk-2.0-key/gtkrc
gtk2: 文件系统中已存在 /usr/share/themes/Emacs/gtk-2.0-key/gtkrc
gtk2: 文件系统中已存在 /usr/share/themes/Raleigh/gtk-2.0/gtkrc
发生错误,没有软件包被更新。

请问这种情况怎么解决?

最近编辑记录 juanxincai (2016-11-27 21:01:15)

离线

#2 2016-11-27 20:55:41

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,384
个人网站

Re: 安装社区福昕阅读器时发生错误

pacman -Qo  /usr/lib/libjpeg.so.8.1.2  /usr/share/locale/zh_TW/LC_MESSAGES/gtk20.mo

离线

#3 2016-11-27 20:59:26

juanxincai
会员
注册时间: 2016-11-01
帖子: 4

Re: 安装社区福昕阅读器时发生错误

出现了这个:
错误:没有软件包拥有 /usr/lib/libjpeg.so.8.1.2
错误:没有软件包拥有 /usr/share/locale/zh_TW/LC_MESSAGES/gtk20.mo
上面中间的省略号省略了一大长串log

依云 说:

pacman -Qo  /usr/lib/libjpeg.so.8.1.2  /usr/share/locale/zh_TW/LC_MESSAGES/gtk20.mo

离线

#4 2016-11-27 21:18:19

juanxincai
会员
注册时间: 2016-11-01
帖子: 4

Re: 安装社区福昕阅读器时发生错误

现在不管装什么软件都会出现这个错误...

依云 说:

pacman -Qo  /usr/lib/libjpeg.so.8.1.2  /usr/share/locale/zh_TW/LC_MESSAGES/gtk20.mo

离线

#5 2016-11-27 22:05:06

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,384
个人网站

Re: 安装社区福昕阅读器时发生错误

你的 /var/lib/pacman/local 被删掉了么?ls 一下看看?

离线

#6 2016-11-27 22:26:11

juanxincai
会员
注册时间: 2016-11-01
帖子: 4

Re: 安装社区福昕阅读器时发生错误

是被删掉了,具体什么原因被删掉的不清楚,/var/log/pacman还在,试过了https://wiki.archlinux.org/index.php/Pacman/Restore_local_database_(%E7%AE%80%E4%BD%93%E4%B8%AD%E6%96%87)
这个wiki给的脚本,问题是输出的pkglist.orig文件内容是空的

依云 说:

pacman -Qo  /usr/lib/libjpeg.so.8.1.2  /usr/share/locale/zh_TW/LC_MESSAGES/gtk20.mo

离线

#7 2016-11-27 22:40:52

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,384
个人网站

Re: 安装社区福昕阅读器时发生错误

我试了一下,脚本没问题啊。你的 /var/log/pacman.log 不会也是空的吧……

哦哦,知道了,那个脚本过时了。

离线

#8 2016-11-27 22:50:25

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,384
个人网站

Re: 安装社区福昕阅读器时发生错误

修好了~

离线

页脚