您尚未登录。

#16 2017-09-09 16:53:18

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

maokewu 说:

大体意思是说命令执行失败,命令格式错误。

你的 Arch ISO 是32位的?还是那个命令的文件坏掉了呢(pacman -Qkk 可以检查)。

离线

#17 2017-09-09 20:09:11

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

我的 Arch ISO 是32位的,这次如果挽救不回来,打算安装成64位的。


种瓜得瓜,种豆得豆。

离线

#18 2017-09-09 21:44:23

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

maokewu 说:

我的 Arch ISO 是32位的,这次如果挽救不回来,打算安装成64位的。

那你直接装64位的吧。32位的官方支持快没了。

离线

#19 2017-09-10 15:36:01

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

用Archlinux x86_64的安装盘启动,可以执行Arch-chroot命令进入原来安装的系统目录下。现在的问题是:不格式化原来的系统分区,是否可以直接覆盖安装?我想问题肯定会有,如肯定会留下一些垃圾文件。


种瓜得瓜,种豆得豆。

离线

#20 2017-09-10 16:05:03

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

maokewu 说:

用Archlinux x86_64的安装盘启动,可以执行Arch-chroot命令进入原来安装的系统目录下。现在的问题是:不格式化原来的系统分区,是否可以直接覆盖安装?我想问题肯定会有,如肯定会留下一些垃圾文件。

不建议。有什么你想保留的备份一下就好了。

离线

#21 2017-09-10 22:11:02

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

/home中只有我的用户文件,并且是单独的分区,可以不用格式化吗?


种瓜得瓜,种豆得豆。

离线

#22 2017-09-10 22:14:07

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

maokewu 说:

/home中只有我的用户文件,并且是单独的分区,可以不用格式化吗?

当然可以啦。

离线

#23 2017-09-10 22:26:02

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

谢谢!我的电脑于2007年购买至今,/home目录下积累了太多的文件资料、教学视频等,若要备份就太麻烦了。


种瓜得瓜,种豆得豆。

离线

#24 2017-09-16 10:10:08

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

这次安装Archlinux很不顺利。格式化了原来的安装盘依然出错,不过这种出错有点奇怪?如下所示:==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: There are 50 members in group base:
:: Repository core
   1) bash  2) bzip2  3) coreutils  4) cryptsetup  5) device-mapper  6) dhcpcd  7) diffutils  8) e2fsprogs  9) file  10) filesystem  11) findutils  12) gawk  13) gcc-libs  14) gettext  15) glibc  16) grep  17) gzip  18) inetutils  19) iproute2  20) iputils  21) jfsutils  22) less  23) licenses  24) linux  25) logrotate  26) lvm2  27) man-db  28) man-pages  29) mdadm  30) nano  31) netctl  32) pacman  33) pciutils  34) pcmciautils  35) perl  36) procps-ng  37) psmisc  38) reiserfsprogs  39) s-nail  40) sed  41) shadow  42) sysfsutils  43) systemd-sysvcompat  44) tar  45) texinfo  46) usbutils  47) util-linux  48) vi  49) which  50) xfsprogs
Enter a selection (default=all):
resolving dependencies...
looking for conflicting packages...
Packages (131) acl-2.2.52-4  archlinux-keyring-20170823-1  attr-2.4.47-3  ca-certificates-20170307-1  ca-certificates-cacert-20140824-4  ca-certificates-mozilla-3.32-1  ca-certificates-utils-20170307-1  cracklib-2.9.6-1  curl-7.55.1-2  db-5.3.28-3  dbus-1.10.22-1  expat-2.2.4-1  gdbm-1.13-1  glib2-2.52.3-1  gmp-6.1.2-1  gnupg-2.2.0-1  gnutls-3.5.15-1  gpgme-1.9.0-3  groff-1.22.3-7  hwids-20170715-1  iana-etc-20170824-1  icu-59.1-2  iptables-1.6.1-1  kbd-2.0.4-1  keyutils-1.5.10-1  kmod-24-1  krb5-1.15.1-1  libaio-0.3.110-1  libarchive-3.3.2-1  libassuan-2.4.3-1  libcap-2.25-1  libcap-ng-0.7.8-1  libelf-0.169-2  libffi-3.2.1-2  libgcrypt-1.8.1-1  libgpg-error-1.27-1  libidn-1.33-2  libksba-1.3.4-2  libldap-2.4.45-4  libmnl-1.0.4-1  libnftnl-1.0.7-1  libnghttp2-1.23.1-1  libnl-3.3.0-1  libpcap-1.8.1-2  libpipeline-1.4.2-1  libpsl-0.18.0-1  libsasl-2.1.26-11  libseccomp-2.3.2-1  libsecret-0.18.5+14+g9980655-1  libssh2-1.8.0-2  libsystemd-234.11-8  libtasn1-4.12-2  libtirpc-1.0.2-1  libunistring-0.9.7-1  libusb-1.0.21-2  libutil-linux-2.30.1-2  linux-api-headers-4.12.7-1  linux-firmware-20170907.a61ac5c-1  lz4-1:1.8.0-1  mkinitcpio-23-2  mkinitcpio-busybox-1.26.1-1  mpfr-3.1.5.p2-1  ncurses-6.0+20170902-1  nettle-3.3-1  npth-1.5-1  openresolv-3.9.0-1  openssl-1.1.0.f-2  p11-kit-0.23.8-1  pacman-mirrorlist-20170907-1  pam-1.3.0-1  pambase-20130928-1  pcre-8.41-1  pinentry-1.0.0-1  popt-1.16-9  readline-7.0.003-1  sqlite-3.20.1-1  systemd-234.11-8  thin-provisioning-tools-0.7.1-1  tzdata-2017b-1  xz-5.2.3-1  zlib-1:1.2.11-2  bash-4.4.012-2  bzip2-1.0.6-6  coreutils-8.28-1  cryptsetup-1.7.5-1  device-mapper-2.02.173-1  dhcpcd-6.11.5-1  diffutils-3.6-1  e2fsprogs-1.43.6-1  file-5.32-1  filesystem-2017.03-2  findutils-4.6.0-2  gawk-4.1.4-2  gcc-libs-7.2.0-2  gettext-0.19.8.1-2  glibc-2.26-4  grep-3.1-1  gzip-1.8-2  inetutils-1.9.4-5  iproute2-4.13.0-1  iputils-20161105.1f2bb12-2  jfsutils-1.1.15-4  less-487-1  licenses-20140629-2  linux-4.12.12-1  logrotate-3.12.3-1  lvm2-2.02.173-1  man-db-2.7.6.1-2  man-pages-4.12-1  mdadm-4.0-1  nano-2.8.7-1  netctl-1.13-2  pacman-5.0.2-2  pciutils-3.5.4-1  pcmciautils-018-7  perl-5.26.0-4  procps-ng-3.3.12-1  psmisc-23.1-1  reiserfsprogs-3.6.25-1  s-nail-14.9.3-1  sed-4.4-1  shadow-4.5-2  sysfsutils-2.1.0-9  systemd-sysvcompat-234.11-8  tar-1.29-2  texinfo-6.4-1  usbutils-008-1  util-linux-2.30.1-2  vi-1:070224-2  which-2.21-2  xfsprogs-4.12.0-1
Total Download Size:     0.08 MiB
Total Installed Size:  767.64 MiB
:: Proceed with installation? [Y/n]
:: Retrieving packages...
downloading libcap-2.25-1-x86_64.pkg.tar.xz...
downloading libaio-0.3.110-1-x86_64.pkg.tar.xz...
downloading libcap-ng-0.7.8-1-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
:: File /mnt/var/cache/pacman/pkg/libcap-2.25-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
:: File /mnt/var/cache/pacman/pkg/libcap-ng-0.7.8-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
:: File /mnt/var/cache/pacman/pkg/libaio-0.3.110-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
Errors occurred, no packages were upgraded.
难道是安装镜像有问题?


种瓜得瓜,种豆得豆。

离线

#25 2017-09-16 10:24:12

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

包文件损坏。换 HTTPS 源试试?

离线

#26 2017-09-16 15:52:27

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

按下列方法寻找https源,也找到少许https源,但安装依然出错,报告的信息意思是相关模块得不到信任。看来暂时没法安装Archlinux了。好在我的电脑是双系统的,原来安装的老掉牙的Windows XP还能凑合。过一段时间看看问题会否得到解决。在此非常感谢“依云”网友持续关注,并尽力帮助!

第一步安装arch的时候,在执行pacstrap命令之前,先安装reflector:
# pacman -S reflector
第二步,用reflector实时测试和选择国内有效https源:
# reflector --verbose -c CN -p https --sort rate --save /etc/pacman.d/mirrorlist
命令运行一会儿,会在屏幕上输出按速度排序的国内https有效源,并将结果写入到/etc/pacman.d/mirrorlist文件;
其中:
-c CN  是指定国内;
-p https  是指定https;
--sort rate  是指定按速度排序;
--save /etc/pacman.d/mirrorlist   是结果写入mirrorlist文件;
第三步,运行命令:
# pacman -Syy
更新数据库。
这时再运行pacstrap命令,就能保证arch的安装过程是使用https源了。
=====
PS:
如果担心国内找不到合适的有效https源,可以把上面第二步的命令修改如下,多加几个国家:
# reflector --verbose -c CN -c HK -c RU -p https --sort rate --save /etc/pacman.d/mirrorlist
或者可以自己参考 Mirror Status page来选择增加哪个国家。


种瓜得瓜,种豆得豆。

离线

#27 2017-09-17 17:27:27

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

下载最新的archlinux-x86_64安装镜像,基本系统安装成功,也安装了grub,重启后仅有linux启动项,丢失了windows启动选项,在linux下如何补救?


种瓜得瓜,种豆得豆。

离线

#28 2017-09-17 18:53:21

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

你生成 grub.cfg 的时候没装 os-prober?

离线

#29 2017-09-17 19:03:34

maokewu
会员
所在地: 云南省楚雄州大姚县
注册时间: 2015-02-03
帖子: 41

Re: 用了多年的Archlinux更新后崩溃了

装了,但执行grub-mkconfig -o /boot/grub/grub.cfg命令时,没报告找到windows xp。


种瓜得瓜,种豆得豆。

离线

#30 2017-09-17 20:16:53

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: 用了多年的Archlinux更新后崩溃了

那是没装 ntfs-3g?

离线

页脚