您尚未登录。

#1 2018-10-19 10:26:11

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

新版本如何配置802.1x安全性

公司的网络需要在以太网连接里配置802.1x安全性,通过一个CA证书来认证连接.
以前的版本在"联网属性"里有一个标签页"802.1X安全性".

但更新了系统后,这个页面没有了这个标签页.我可以通过什么方法来配置使用"802.1X安全性"呢?

离线

#2 2018-10-20 07:42:06

xtricman
喵了个咪
注册时间: 2012-12-26
帖子: 522

Re: 新版本如何配置802.1x安全性

啥都不说

离线

#3 2018-10-20 09:55:32

yw662
大会员
注册时间: 2018-10-10
帖子: 41

Re: 新版本如何配置802.1x安全性


javascript是世界上最好的语言

离线

#4 2018-10-23 09:13:05

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

我尽量想说得详细一点,但是论坛不能插入图片,找了好久没找到插入图片的方法.

离线

#5 2018-10-23 09:14:03

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

@yw662,谢谢,但是我需要设置的是有线网络的802.1x的证书.

看起来很像这一段描述的.但这篇文章写的是针对无线网络的.但是我们要配置的是有线网络.不知是否通用.
之前一直是通过NetworkManager来配置的.


WPA2 企业模式
WPA2 企业模式是 WPA(Wi-Fi Protected Access)的工作模式之一。It provides better security and key management than WPA2 Personal, and supports other enterprise-type functionality, such as VLANs and NAP. However, it requires an external authentication server, called RADIUS server to handle the authentication of users. This is in contrast to Personal mode which does not require anything beyond the wireless router or access points (APs), and uses a single passphrase or password for all users.

WPA2 企业模式 是 WPA(Wi-Fi Protected Access)的工作模式之一。相比 WPA2 Personal 而言,它提供了更好的安全性和密钥管理功能,同时也提供了 VLANS 和 NAP 之类的企业功能。当然,它需要额外的 RADIUS 认证服务器来为用户提供认证服务,这就和只需要无线路由器或者接入点,所有用户都使用同一个密码的个人模式不同。

The Enterprise mode enables users to log onto the Wi-Fi network with a username and password and/or a digital certificate. Since each user has a dynamic and unique encryption key, it also helps to prevent user-to-user snooping on the wireless network, and improves encryption strength.

企业模式允许用户使用用户名和密码或者数字证书来登陆 Wi-Fi。因为每个用户都拥有一个动态唯一的加密密码,因此企业模式可以防止通过无限网络的用户探听,并提高加密强度。

This section describes the configuration of network clients to connect to a wireless access point with WPA2 Enterprise mode. See Software access point#RADIUS for information on setting up an access point itself.

本章节讲解 network clients 使用WPA2企业模式来连接无线接入点的配置。查看 Software access point#RADIUS 来获得如何设置接入点自身的相关信息。

注意: Enterprise mode requires a more complex client configuration, whereas Personal mode only requires entering a passphrase when prompted. Clients likely need to install the server’s CA certificate (plus per-user certificates if using EAP-TLS), and then manually configure the wireless security and 802.1X authentication settings.

最近编辑记录 justin_wu (2018-10-23 09:28:12)

离线

#6 2018-10-23 10:44:48

yw662
大会员
注册时间: 2018-10-10
帖子: 41

Re: 新版本如何配置802.1x安全性

wpa_supplicant也被用来配置有线网络的。。。其实nm也是用的这个。
不过既然你之前用的是nm,那么接着用不就好了么,还是说虽然用的是nm,但是因为某些原因没找到那个标签页呢。

如果是GUI前端的问题的话,那么换一个试试大概。。。
如果不是的话,那么大概是缺失某些可选依赖了吧。


javascript是世界上最好的语言

离线

#7 2018-10-23 15:34:49

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,859
个人网站

Re: 新版本如何配置802.1x安全性

justin_wu 说:

我尽量想说得详细一点,但是论坛不能插入图片,找了好久没找到插入图片的方法.

下方有链接的,使用 img 引用图片。图片要事先上传到图床上,比如 https://sm.ms/ 或者 https://img.vim-cn.com/

离线

#8 2018-10-23 17:36:37

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

yw662 说:

wpa_supplicant也被用来配置有线网络的。。。其实nm也是用的这个。
不过既然你之前用的是nm,那么接着用不就好了么,还是说虽然用的是nm,但是因为某些原因没找到那个标签页呢。

如果是GUI前端的问题的话,那么换一个试试大概。。。
如果不是的话,那么大概是缺失某些可选依赖了吧。


现在是没找到设置的标签页了.
因为使用了pacman -syu命令升级了一下系统.然后新版本的NetworkManager就找不到设置的标签页了.
还有其他前端的应用可以设置这个吗?我要装哪一个?

最近编辑记录 justin_wu (2018-10-23 17:57:18)

离线

#9 2018-10-23 17:38:46

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

依云 说:
justin_wu 说:

我尽量想说得详细一点,但是论坛不能插入图片,找了好久没找到插入图片的方法.

下方有链接的,使用 img 引用图片。图片要事先上传到图床上,比如 https://sm.ms/ 或者 https://img.vim-cn.com/

谢谢!
我把同事的系统截了一个图,我的系统也截一个图.
可以看到,没有那一页了.

old

new

离线

#10 2018-10-24 10:38:10

Kurobac
小白
注册时间: 2018-05-12
帖子: 73

Re: 新版本如何配置802.1x安全性

https://gitlab.gnome.org/GNOME/network- … /issues/25
建议暂时将nm-connection-editor降级到1.8.16


# pacman -Syu

离线

#11 2018-10-24 14:20:41

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

Kurobac 说:

https://gitlab.gnome.org/GNOME/network- … /issues/25
建议暂时将nm-connection-editor降级到1.8.16

谢谢!看起来应该是同一个问题.
我降级试试.

离线

#12 2018-10-24 14:31:45

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

按照着https://wiki.archlinux.org/index.php/Downgrading_packages_(%E7%AE%80%E4%BD%93%E4%B8%AD%E6%96%87) 的方法来降级,出现错误.

/var/cache/pacman/pkg$ sudo pacman -U nm-connection-editor-1.8.16-1-x86_64.pkg.tar.xz
正在加载软件包...
警告:正在降级软件包 nm-connection-editor (1.8.18-2 => 1.8.16-1)
正在解决依赖关系...
正在查找软件包冲突...
:: nm-connection-editor 与 libnm-gtk 有冲突。删除 libnm-gtk 吗? [y/N] y

软件包 (2) libnm-gtk-1.8.18-2 [删除]  nm-connection-editor-1.8.16-1

全部安装大小:  5.90 MiB
净更新大小:  0.67 MiB

:: 进行安装吗? [Y/n] 
(1/1) 正在检查密钥环里的密钥                       [######################] 100%
(1/1) 正在检查软件包完整性                         [######################] 100%
(1/1) 正在加载软件包文件                           [######################] 100%
(1/1) 正在检查文件冲突                             [######################] 100%
错误:无法提交处理 (有冲突的文件)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-cert-chooser.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-mobile-providers.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-mobile-wizard.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-ui-utils.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-version.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-vpn-password-dialog.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/include/libnma/nma-wifi-dialog.h (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/lib/girepository-1.0/NMA-1.0.typelib (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/lib/libnma.so (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/lib/libnma.so.0 (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/lib/libnma.so.0.0.0 (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/lib/pkgconfig/libnma.pc (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gir-1.0/NMA-1.0.gir (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/NMACertChooser.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/NMAMobileProvidersDatabase.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/NMAVpnPasswordDialog.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/NMAWifiDialog.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/annotation-glossary.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/api-index-1.8.0.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/api-index-full.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/api-reference.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/home.png (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/index.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/left-insensitive.png (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/left.png (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/libnma-nma-mobile-wizard.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/libnma-nma-ui-utils.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/libnma.devhelp2 (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/object-tree.html (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/right-insensitive.png (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/right.png (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/style.css (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/up-insensitive.png (由 libnma 所有)
nm-connection-editor: 文件系统中存在 /usr/share/gtk-doc/html/libnma/up.png (由 libnma 所有)
发生错误,没有软件包被更新。

请问这个降级错误要怎么处理??

最近编辑记录 justin_wu (2018-10-24 14:38:41)

离线

#13 2018-10-24 14:40:22

yw662
大会员
注册时间: 2018-10-10
帖子: 41

Re: 新版本如何配置802.1x安全性

不如。。。有没有可能先Rns nm-connection-editor,或者Rcs这个libnma再重新安装nm-connection-editor啊?
不然就把libnma Rdd了吧。。。看起来没什么别的办法。。。

最近编辑记录 yw662 (2018-10-24 14:40:57)


javascript是世界上最好的语言

离线

#14 2018-10-24 15:45:14

justin_wu
会员
注册时间: 2018-10-19
帖子: 9

Re: 新版本如何配置802.1x安全性

sudo pacman -Rcs libnma
正在检查依赖关系...
:: firefox可选依赖pulseaudio: Audio support
:: gtk2可选依赖gnome-themes-standard: Default widget theme
:: kodi可选依赖bluez: Blutooth support
:: kodi可选依赖pulseaudio: PulseAudio support
:: libcanberra可选依赖libcanberra-pulse: PulseAudio driver
:: libxcursor可选依赖gnome-themes-standard: fallback icon theme
:: lxde-common可选依赖gnome-themes-standard: default GTK+ theme
:: lxdm可选依赖gnome-themes-standard: default GTK+ theme
:: networkmanager可选依赖bluez: Bluetooth support
:: phonon-qt4可选依赖pulseaudio: PulseAudio support
:: phonon-qt4-gstreamer可选依赖pulseaudio: PulseAudio support
:: phonon-qt5可选依赖pulseaudio: PulseAudio support
:: phonon-qt5-gstreamer可选依赖pulseaudio: PulseAudio support
:: speech-dispatcher可选依赖pulseaudio: PulseAudio support
:: xmms2可选依赖pulseaudio: PulseAudio output
:: xscreensaver可选依赖gdm: for login manager support

软件包 (28) accountsservice-0.6.54+2+g204a4ab-1  alsa-plugins-1.1.7-1  bluez-5.50-3  gdm-3.30.1-1
            gjs-2:1.54.2-1  gnome-bluetooth-3.28.2-1  gnome-session-3.30.1-1
            gnome-settings-daemon-3.30.1.2-1  gnome-shell-1:3.30.1-1  gnome-shell-extensions-3.30.1-1
            gnome-themes-extra-3.28-1  js60-60.2.2-1  libcanberra-pulse-0.30+2+gc0620e4-1  libgdm-3.30.1-1
            libnm-gtk-1.8.18-2  mobile-broadband-provider-info-20170310-1  mutter-3.30.1-1
            network-manager-applet-1.8.18-2  nm-connection-editor-1.8.18-2  pipewire-0.2.3-1
            pulseaudio-12.2-2  pulseaudio-alsa-2-4  pulseaudio-bluetooth-12.2-2  rtkit-0.11+8+ge0a51fe-1
            xorg-server-xwayland-1.20.2-1  xorg-xhost-1.0.7-2  zenity-3.30.0-1  libnma-1.8.18-2

全部移去体积:  130.86 MiB

移除这些软件包会不会导致图形界面出错?

离线

#15 2018-10-24 15:57:39

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,859
个人网站

Re: 新版本如何配置802.1x安全性

justin_wu 说:

移除这些软件包会不会导致图形界面出错?

会啊。

离线

页脚