您尚未登录。

#1 2013-04-22 13:46:05

chunfai
会员
注册时间: 2013-04-22
帖子: 4

AUR安装python2-unittest2出权限错误,求帮忙.

装openerp需要依赖python2-unittest2,但是却安装不起来.

==> 正在释放源码......
  -> 正在解压缩 unittest2-0.5.1.tar.gz,使用 bsdtar
==> 正在删除现存的 pkg/ 目录...
==> 正在开始 build()...
running install
running build
running build_py
running build_scripts
running install_lib
creating /tmp/yaourt-tmp-yssd/aur-python2-unittest2/pkg/python2-unittest2
error: could not create '/tmp/yaourt-tmp-yssd/aur-python2-unittest2/pkg/python2-unittest2': Permission denied
==> 错误: 在 build() 中发生一个错误。
    正在放弃...
==> ERROR: Makepkg was unable to build python2-unittest2.


$ ls -dn /tmp/yaourt-tmp-yssd/aur-python2-unittest2/pkg
d--------- 2 1000 100 4096 4月 22 11:15 /tmp/yaourt-tmp-yssd/aur-python2-unittest2/pkg


求高手帮忙看看.

最近编辑记录 chunfai (2013-04-22 15:38:55)

离线

#2 2013-04-22 16:03:45

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,384
个人网站

Re: AUR安装python2-unittest2出权限错误,求帮忙.

我这里很正常的啊。你 umask 命令的结果是?

离线

#3 2013-04-22 16:33:13

chunfai
会员
注册时间: 2013-04-22
帖子: 4

Re: AUR安装python2-unittest2出权限错误,求帮忙.

百合仙子 说:

我这里很正常的啊。你 umask 命令的结果是?

$ umask
0022


没事啊.
我是前两天硬盘物理损毁,所以重装了系统.安装OPENERP时就卡在了unittest2哪里了.把它从depend里取消安装了OpenERP后,发现出现问题,需要unittest2(这里)

离线

#4 2013-04-22 16:56:17

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,384
个人网站

Re: AUR安装python2-unittest2出权限错误,求帮忙.

你下载 PKGBUILD 手工 makepkg 呢?

离线

#5 2013-04-22 19:32:29

chunfai
会员
注册时间: 2013-04-22
帖子: 4

Re: AUR安装python2-unittest2出权限错误,求帮忙.

百合仙子 说:

你下载 PKGBUILD 手工 makepkg 呢?

没有啦,直接yaourt的啊,只不过在终端拷贝了些错误的信息出来.
因为估计unittest是运行时的depend所以可以通过安装.但是运行起来就不行了.

说回到unittest的安装,估计我是新装的系统的关系,systemV的东西都没有了.systemd里面缺少了unittest的编译时depend.抑或是建立pkg目录时那里出了毛病.

离线

#6 2013-04-22 19:43:55

chunfai
会员
注册时间: 2013-04-22
帖子: 4

Re: AUR安装python2-unittest2出权限错误,求帮忙.

问题解决了.谢谢pingveno大哥.

pingveno在AUR上 说:

Comment by pingveno
2013-04-22 08:30
Fixed. The PKGBUILD was working before, so there must have been a change in pacman 4.1.

离线

页脚