您尚未登录。

#1 2017-02-05 12:19:01

dsl1784
会员
注册时间: 2017-02-05
帖子: 1

fcitx输入法在某些软件中无法切换问题

各位大牛,这个问题我已按照网上查到的资料各种尝试了最终都没有解决。

问题:Fcitx输入法,在WPS、gedit、启动器等软件里不能切换,只能是哟你默认的英文输入法。

我已经尝试的解决办法:

1、编辑配置文件:sudo gedit ~/.profile
添加:
export XMODIFIERS=@im=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx

2、Lib依赖项:sudo apt-get install fcitx-frontend-qt4 fcitx-frontend-qt5 fcitx-libs-qt fcitx-libs-qt5 libfcitx-qt0 libfcitx-qt5-1 

3、快捷键占用

4、WPS中输入法无法切换尝试解决:
#!/usr/bin/sh
export XMODIFIERS="@im=fcitx"
export GTK_IM_MODULE="fcitx"
export QT_IM_MODULE="fcitx"
/usr/bin/wpp "$1"

以上方法都没有解决效果,各位大牛有思路没。Fcitx诊断结果如下:


系统信息 说:

# 系统信息:
1.  `uname -a`:

        Linux djc-laptop 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

2.  `lsb_release -a`:

        No LSB modules are available.
        Distributor ID:    Ubuntu
        Description:    Ubuntu 16.04.1 LTS
        Release:    16.04
        Codename:    xenial

3.  `lsb_release -d`:

        Description:    Ubuntu 16.04.1 LTS

4.  `/etc/lsb-release`:

        DISTRIB_ID=Ubuntu
        DISTRIB_RELEASE=16.04
        DISTRIB_CODENAME=xenial
        DISTRIB_DESCRIPTION="Ubuntu 16.04.1 LTS"

5.  `/etc/os-release`:

        NAME="Ubuntu"
        VERSION="16.04.1 LTS (Xenial Xerus)"
        ID=ubuntu
        ID_LIKE=debian
        PRETTY_NAME="Ubuntu 16.04.1 LTS"
        VERSION_ID="16.04"
        HOME_URL="http://www.ubuntu.com/"
        SUPPORT_URL="http://help.ubuntu.com/"
        BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
        VERSION_CODENAME=xenial
        UBUNTU_CODENAME=xenial

6.  桌面环境:

    桌面环境为 `gnome3`。

7.  Bash 版本:

        BASH_VERSION='4.3.46(1)-release'

# 环境:
1.  DISPLAY:

        DISPLAY=':0'

2.  键盘布局:

    1.  `setxkbmap`:

            xkb_keymap {
                xkb_keycodes  { include "evdev+aliases(qwerty)"    };
                xkb_types     { include "complete"    };
                xkb_compat    { include "complete"    };
                xkb_symbols   { include "pc+us+cn:2+inet(evdev)"    };
                xkb_geometry  { include "pc(pc105)"    };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us,cn", "", ""

3.  Locale:

    1.  全部可用 locale:

            C
            C.UTF-8
            en_AG
            en_AG.utf8
            en_AU.utf8
            en_BW.utf8
            en_CA.utf8
            en_DK.utf8
            en_GB.utf8
            en_HK.utf8
            en_IE.utf8
            en_IN
            en_IN.utf8
            en_NG
            en_NG.utf8
            en_NZ.utf8
            en_PH.utf8
            en_SG.utf8
            en_US.utf8
            en_ZA.utf8
            en_ZM
            en_ZM.utf8
            en_ZW.utf8
            POSIX
            zh_CN.utf8
            zh_SG.utf8

    2.  当前 locale:

            LANG=zh_CN.UTF-8
            LANGUAGE=zh_CN:zh:en_US:en
            LC_CTYPE="zh_CN.UTF-8"
            LC_NUMERIC=zh_CN.UTF-8
            LC_TIME=zh_CN.UTF-8
            LC_COLLATE="zh_CN.UTF-8"
            LC_MONETARY=zh_CN.UTF-8
            LC_MESSAGES="zh_CN.UTF-8"
            LC_PAPER=zh_CN.UTF-8
            LC_NAME=zh_CN.UTF-8
            LC_ADDRESS=zh_CN.UTF-8
            LC_TELEPHONE=zh_CN.UTF-8
            LC_MEASUREMENT=zh_CN.UTF-8
            LC_IDENTIFICATION=zh_CN.UTF-8
            LC_ALL=

4.  目录:

    1.  主目录:

            /home/djc

    2.  `${XDG_CONFIG_HOME}`:

        环境变量 `XDG_CONFIG_HOME` 没有设定。

        `XDG_CONFIG_HOME` 的当前值是 `~/.config` (`/home/djc/.config`)。

    3.  Fcitx 设置目录:

        当前 fcitx 设置目录是 `~/.config/fcitx` (`/home/djc/.config/fcitx`)。

5.  当前用户:

    脚本作为 djc (1000) 运行。

# Fcitx 状态:
1.  可执行文件:

    在 `/usr/bin/fcitx` 找到了 fcitx.

2.  版本:

    Fcitx 版本: `4.2.9.1`

3.  进程:

    找到了 2 个 fcitx 进程:

         2203 fcitx
         2277 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` 工作正常.

# Fcitx 配置界面:
1.  配置工具封装:

    在 `/usr/bin/fcitx-configtool` 找到了 fcitx-configtool。

2.  用于 GTK+-2.0 的配置界面:

    **未找到 gtk2 的配置界面.**

3.  用于 GTK+-3.0 的配置界面:

    在 `/usr/bin/fcitx-config-gtk3` 找到了 `fcitx-config-gtk3`。

4.  KDE 的配置界面:

    **`kcmshell4` 未找到.**

# 前端设置:
## Xim:
1.  `${XMODIFIERS}`:

    环境变量 XMODIFIERS 已经正确地设为了 "@im=fcitx".
    从环境变量中获取的 Xim 服务名称为 fcitx.

2.  根窗口上的 XIM_SERVERS:

    **无法在根窗口找到 xim_server.**

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    环境变量 QT4_IM_MODULE 已经正确地设为了 "fcitx".

2.  qt5 - `${QT_IM_MODULE}`:

    环境变量 QT_IM_MODULE 已经正确地设为了 "fcitx".

3.  Qt 输入法模块文件:
    找到了 Qt5 的输入法模块: `/usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.
    找到了 Qt4 的输入法模块: `/usr/lib/x86_64-linux-gnu/qt4/plugins/inputmethods/qtim-fcitx.so`.

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    环境变量 GTK_IM_MODULE 已经正确地设为了 "fcitx".

2.  `gtk-query-immodules`:

    1.  gtk 2:

        **无法找到 gtk 2 的 `gtk-query-immodules`.**

        **无法找到 gtk 2 的 fcitx 输入法模块.**

    2.  gtk 3:

        **无法找到 gtk 3 的 `gtk-query-immodules`.**

        **无法找到 gtk 3 的 fcitx 输入法模块.**

3.  Gtk 输入法模块缓存:

    1.  gtk 2:

        在 `/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache` 找到了 gtk `2.24.30` 的输入法模块缓存.
        版本行:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0 from gtk+-2.24.30

        已找到 gtk `2.24.30` 的 fcitx 输入法模块.

            "/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so"
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*"

    2.  gtk 3:

        在 `/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache` 找到了 gtk `3.18.9` 的输入法模块缓存.
        版本行:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.18.9

        已找到 gtk `3.18.9` 的 fcitx 输入法模块.

            "/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-fcitx.so"
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*"

4.  Gtk 输入法模块文件:

    1.  gtk 2:

        找到的全部 Gtk 2 输入法模块文件均存在.

    2.  gtk 3:

        找到的全部 Gtk 3 输入法模块文件均存在.

# 配置:
## Fcitx 插件:
1.  插件配置文件目录:

    找到了 fcitx 插件配置目录: `/usr/share/fcitx/addon`.

2.  插件列表:

    1.  找到了 30 个已启用的插件:

            fcitx-autoeng
            fcitx-autoeng-ng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-cloudpinyin
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-fullwidth-char-enhance
            fcitx-googlepinyin
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-lua
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-punc-ng
            fcitx-quickphrase
            fcitx-sogoupinyin
            fcitx-spell
            fcitx-sunpinyin
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xkb
            fcitx-xkbdbus

    2.  找到了 4 个被禁用的插件:

            fcitx-kimpanel-ui
            fcitx-remote
            fcitx-sogoucloudpinyin
            fcitx-xim

3.  插件库:

    所有插件所需的库都被找到。

4.  用户界面:

    找到了 1 个已启用的用户界面插件:

        fcitx-classic-ui

## 输入法:
1.  找到了 2 个启用的输入法:

        fcitx-keyboard-us
        googlepinyin

2.  默认输入法:

    您已经正确的将一个键盘输入法 "fcitx-keyboard-us" 设为默认.

# 日志:
1.  `date`:

        2017年 02月 05日 星期日 12:10:20 CST

2.  `~/.config/fcitx/log/`:

        总用量 4
        -rw-rw-r-- 1 djc djc 1030 2月   2 10:48 crash.log

3.  `~/.config/fcitx/log/crash.log`:

        =========================
        FCITX 4.2.9.1 -- Get Signal No.: 6
        Date: try "date -d @1486003694" if you are using GNU date ***
        ProcessID: 2178
        fcitx(+0x162f)[0x5558c542f62f]
        /lib/x86_64-linux-gnu/libc.so.6(+0x354b0)[0x7f5e7c2c34b0]
        /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x38)[0x7f5e7c2c3428]
        /lib/x86_64-linux-gnu/libc.so.6(abort+0x16a)[0x7f5e7c2c502a]
        /lib/x86_64-linux-gnu/libc.so.6(+0x777ea)[0x7f5e7c3057ea]
        /lib/x86_64-linux-gnu/libc.so.6(__fortify_fail+0x5c)[0x7f5e7c3a656c]
        /lib/x86_64-linux-gnu/libc.so.6(+0x116570)[0x7f5e7c3a4570]
        /lib/x86_64-linux-gnu/libc.so.6(+0x1184b7)[0x7f5e7c3a64b7]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-dbus.so(+0x1f96)[0x7f5e7b9fbf96]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-dbus.so(+0x2151)[0x7f5e7b9fc151]
        /usr/lib/x86_64-linux-gnu/libfcitx-core.so.0(+0x878e)[0x7f5e7cca778e]
        /usr/lib/x86_64-linux-gnu/libfcitx-core.so.0(FcitxInstanceRun+0x210)[0x7f5e7cca8170]
        fcitx(+0xfec)[0x5558c542efec]
        /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7f5e7c2ae830]
        fcitx(_start+0x29)[0x5558c542f069]


无善无恶心之体,有善有恶意之动。知善知恶是良知,为善去恶是格物。

离线

#2 2017-02-05 14:38:27

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,167
个人网站

Re: fcitx输入法在某些软件中无法切换问题

本论坛有个针对 GNOME 3 的 gsettings 命令,你找来试试。
WPS 应该是自带的 Qt 库,所以只能使用 XIM 而不能使用 Qt 模块。

另外非 Arch 请发到对应的板块。

离线

页脚