您尚未登录。

#1 2017-12-18 08:43:29

ovenyang
会员
注册时间: 2016-09-24
帖子: 1

更新到qt5-base 5.10.0-1后很多依赖与它的程序都出错

gwenview, okular, goldendict, konsole这些运行都出现segment fault错误,下面是okular的跟踪结果,其他的也类似。

#0  0x00007f87f938340f in QXcbConnection::internAtom(char const*) () at /usr/lib/libQt5XcbQpa.so.5
#1  0x00007f87f9397ba4 in QXcbScreen::getEdid() const () at /usr/lib/libQt5XcbQpa.so.5
#2  0x00007f87f93994b7 in QXcbScreen::QXcbScreen(QXcbConnection*, QXcbVirtualDesktop*, unsigned int, xcb_randr_get_output_info_reply_t*, xcb_xinerama_screen_info_t const*, int) () at /usr/lib/libQt5XcbQpa.so.5
#3  0x00007f87f9387df9 in QXcbConnection::initializeScreens() () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f87f9388775 in QXcbConnection::QXcbConnection(QXcbNativeInterface*, bool, unsigned int, char const*) ()
    at /usr/lib/libQt5XcbQpa.so.5
#5  0x00007f87f938c590 in QXcbIntegration::QXcbIntegration(QStringList const&, int&, char**) () at /usr/lib/libQt5XcbQpa.so.5
#6  0x00007f87f96ad19e in  () at /usr/lib/qt/plugins/platforms/libqxcb.so
#7  0x00007f880e50fa30 in QPlatformIntegrationFactory::create(QString const&, QStringList const&, int&, char**, QString const&) ()
    at /usr/lib/libQt5Gui.so.5
#8  0x00007f880e520810 in QGuiApplicationPrivate::createPlatformIntegration() () at /usr/lib/libQt5Gui.so.5
#9  0x00007f880e52134e in QGuiApplicationPrivate::createEventDispatcher() () at /usr/lib/libQt5Gui.so.5
#10 0x00007f880d9f68d5 in QCoreApplicationPrivate::init() () at /usr/lib/libQt5Core.so.5
#11 0x00007f880e522e20 in QGuiApplicationPrivate::init() () at /usr/lib/libQt5Gui.so.5
#12 0x00007f8811f4fc6a in QApplicationPrivate::init() () at /usr/lib/libQt5Widgets.so.5
#13 0x000000000065dd0c in QtSingleApplication::QtSingleApplication(QString const&, int&, char**) ()
#14 0x00000000005b49f9 in QHotkeyApplication::QHotkeyApplication(QString const&, int&, char**) ()
#15 0x0000000000490ad6 in main ()

是qt的bug还是其他问题?求解

最近编辑记录 ovenyang (2017-12-18 08:45:28)

离线

#2 2017-12-20 18:12:51

xtricman
神秘德里克
注册时间: 2012-12-26
帖子: 570

Re: 更新到qt5-base 5.10.0-1后很多依赖与它的程序都出错

请通过pacman更新所有软件包,使用官方仓库,不使用testing


5萬人民幣買個老婆,要國產的,賣的私聊

离线

页脚