您尚未登录。

#1 2018-06-13 18:32:55

renyuneyun
会员
所在地: 河南省新鄉市
注册时间: 2011-09-30
帖子: 123
个人网站

[已解決] 更新後警告perl包will NOT be used by the installed perl interpreter

(好奇怪,這個問題找不到合適的板塊。。。)

更新後,pacman的輸出中包含如下內容:

running 'detect-old-perl-modules.hook'...

WARNING: '/usr/lib/perl5/vendor_perl' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
-> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/vendor_perl'

執行命令後得到的只有perl-rpc-xml,這是apparmor的依賴。以前也有過這個警告,但我當時沒去檢查,所以不知道(歷史上)是不是只有perl-rpc-xml。

所以是否有人遇到過類似的問題?是怎麼解決的?

最近编辑记录 renyuneyun (2018-07-10 16:41:41)


知識很重要,而相當的運用能力更重要。

离线

#2 2018-06-13 19:13:35

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,859
个人网站

Re: [已解決] 更新後警告perl包will NOT be used by the installed perl interpreter

离线

#3 2018-06-14 01:03:44

renyuneyun
会员
所在地: 河南省新鄉市
注册时间: 2011-09-30
帖子: 123
个人网站

Re: [已解決] 更新後警告perl包will NOT be used by the installed perl interpreter

誒?是這個的影響麼?
怪了,我記得當時檢查過,沒有相關包的……

裝了社區源裏那個新打包的倒是的確沒再報錯了。


蟹蟹仙子 tongue

最近编辑记录 renyuneyun (2018-06-14 01:04:13)


知識很重要,而相當的運用能力更重要。

离线

页脚