您尚未登录。

#1 2012-07-10 21:20:25

xiaolongfdwq
会员
注册时间: 2012-06-19
帖子: 49

[算解决了吧]thunar无法自动挂载U盘

问题是这样的:插入U盘后,U盘上的灯闪了闪,但 thunar 侧边栏没有出现相应表示,df 发现U盘就没有被挂载。
系统是前天才装好的,现在系统里就装了slim, openbox(& obmenu), thunar(&thunar-volman), chromium, fcitx。查了一天的Wiki没成功,google也没找到解决办法,最后寄希望于此贴,希望能招得各位高手看一眼,指点一二。
下面是今天查Wiki和google时做过的:
按照slim的中文wiki在 .xinitrc里的 openbox-session 前加入了 ck-launch-session,未解决问题;
按照Thunar的wiki安装了hal,并按照hal的wiki编辑了/etc/dbus-1/system.d/hal.conf文件,未能解决,然后又把它给卸载了(因为有看到说没用它就能自动挂载的帖子,只不过那位朋友是Xfde环境);
按照Xfde的wiki安装了gamin, gvfs, gvfs-vfg,未解决;
按照xinitrc的wiki,编辑了.xinitrc最开始的一段代码,未解决;
又在某个帖子看到slim支持consolekit会话,不需要在openbox-session前加入ck-launch-session(xinitrc中也提到过),又把ck-launch-session去掉了。
后来又看到有个帖子里完全把 .xinitrc 最上面的代码注释掉了,就跟着做了,然后在 openbox-session 前加了dbus-launch,这是我现在的 .xinitrc:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

#if [ -d /etc/X11/xinit/xinitrc.d ]; then
#  for f in /etc/X11/xinit/xinitrc.d/*; do
#    # Do not launch dbus before ConsoleKit (FS#25031)
#    #[ -x "$f" ] && . "$f"
#    [ "$f" -ne "/etc/X11/xinit/xinitrc.d/30-dbus" ] && [ -x "$f" ] && . "$f"
#  done
#  unset f
#fi

exec dbus-launch openbox-session

对了,还有一个跟thunar有关的日志:
grep thunar /var/log/slim.log

thunar-volman: 不支持的 USB 设备类型.
thunar-volman: 不支持的 USB 设备类型.
thunar-volman: 未能检测此卷的对应设备.
thunar-volman: 未能检测此卷的对应设备.



编辑:把xfce装上了,又装了个python2-udiskie,在~/.xinitrc中添加了"udiskie &",使用 exec startxfce4,解决了在xfce中自动挂载的问题,但进入openbox中仍然未解决。

最近编辑记录 xiaolongfdwq (2012-07-11 19:28:16)

离线

#2 2012-07-10 21:30:19

phoenixlzx
晩ご飯だよー
注册时间: 2011-08-19
帖子: 1,789
个人网站

Re: [算解决了吧]thunar无法自动挂载U盘

我之前有一次错误是提示 Not Authorized

修改了policykit修复。

你这个,貌似闪存盘有问题?

离线

#3 2012-07-10 22:00:50

cuihao
所在地: USTC, Hefei
注册时间: 2011-08-19
帖子: 1,221
个人网站

Re: [算解决了吧]thunar无法自动挂载U盘

手动挂载呢?


Site: I-YU.ME   Twitter: @cuihaoleo   Org: LUG@USTC
AD:  ~欢迎参与志愿计算~

离线

#4 2012-07-10 22:07:07

xiaolongfdwq
会员
注册时间: 2012-06-19
帖子: 49

Re: [算解决了吧]thunar无法自动挂载U盘

你的thunar侧边栏能看到闪存盘是吧,我这看都看不到,就算我用mount命令手动挂载上之后也看不到侧边栏有跟U盘相关的东西,但能看到属于win7的分区,点击win7的分区时也遇到了“Not Authorized”,然后上网找到了解决办法(好像是按照了个udisks2,也新建了一个跟policykit有关的文件)
U盘应该没问题,系统就是用这个U盘安装的,现在里面的数据也还是安装盘的数据。
是我还有什么东西没装上吗?如果是的话,还请各位指出来一下,我实在不知道还要安装什么东西了(我就想openbox+thunar,还不想装Xfce)

离线

页脚