您尚未登录。

#1 2019-09-19 10:42:39

vkill
会员
注册时间: 2019-09-19
帖子: 5

vmware-workstation-macos 15.1.0-1 不支持 kernel 5.3.arch1-1

现在的问题是 vmmon vmnet 无法加载

modprobe -a vmw_vmci vmmon vmnet
modprobe: WARNING: Module vmmon not found in directory /lib/modules/5.3.0-arch1-1-ARCH
modprobe: WARNING: Module vmnet not found in directory /lib/modules/5.3.0-arch1-1-ARCH

可采用间接的方式启动

pacman -U ~/vmware-workstation-15.1.0-5-x86_64.pkg.tar.xz

modprobe -a vmw_vmci vmmon vmnet
systemctl restart vmware-networks.service

pacman -U ~/vmware-workstation-macos-15.1.0-1-x86_64.pkg.tar.xz

需要管理员升级 repo.archlinuxcn.org 中的 vmware-workstation-macos 到 15.1.0-5

离线

#2 2019-09-20 09:26:10

farseerfc
会员
注册时间: 2013-07-30
帖子: 205
个人网站

Re: vmware-workstation-macos 15.1.0-1 不支持 kernel 5.3.arch1-1

更新了,升級到 vmware-workstation-macos 15.1.0-5.2 試試?


computerは神様だと信じていて
だからVIMの上でずっと指が舞って
自ら恋愛相手を作り出して

离线

#3 2019-09-20 09:48:31

vkill
会员
注册时间: 2019-09-19
帖子: 5

Re: vmware-workstation-macos 15.1.0-1 不支持 kernel 5.3.arch1-1

可以了,这速度真是快啊,牛
顺便问下,vmware-workstation-macos 的 PKGBUILD 在哪里呢?

离线

#4 2019-09-20 17:19:27

farseerfc
会员
注册时间: 2013-07-30
帖子: 205
个人网站

Re: vmware-workstation-macos 15.1.0-1 不支持 kernel 5.3.arch1-1

是在 https://github.com/archlinuxcn/repo/blo … n/PKGBUILD ,這是一個 PKGBUILD 拆出 3 個包。 AUR 上面那個 vmware-workstation 是可以編輯 PKGBUILD 改一行打包出一樣內容的, archlinuxcn 裏面搞成拆包的方式了。


computerは神様だと信じていて
だからVIMの上でずっと指が舞って
自ら恋愛相手を作り出して

离线

#5 2019-09-21 11:36:17

vkill
会员
注册时间: 2019-09-19
帖子: 5

Re: vmware-workstation-macos 15.1.0-1 不支持 kernel 5.3.arch1-1

原来在 github 上,非常感谢。

离线

页脚