您尚未登录。

#1 2019-11-12 19:11:04

αlpha0x00
会员
注册时间: 2018-06-04
帖子: 17

[已解决] zathura 无法打开链接

用 zathura 打开 pdf 文件之后,点击文件里的链接不会打开浏览器打开链接。通过查看zathura输出发现是xdg-open失败错误如下:

/usr/bin/xdg-open: line 756: 26524 Trace/breakpoint trap   (core dumped) "$command_exec" "$@"
/usr/bin/xdg-open: line 868: 26554 Trace/breakpoint trap   (core dumped) $browser "$1"
/usr/bin/xdg-open: line 868: 26582 Trace/breakpoint trap   (core dumped) $browser "$1"
xdg-open: no method available for opening 'https://github.com/clerkma/fandol-fonts'

尝试过直接通过

xdg-open https://github.com/clerkma/fandol-fonts 

能正确打开链接。

尝试通过 htop 查看 zathura 环境变量信息,失败 sad

相关信息:
* zathura 0.4.4-1 是最新版本,插件为 local/zathura-pdf-mupdf 0.3.5-2
* ~/.config/zathura/zathurarc 内容如下

set selection-clipboard clipboard
set statusbar-home-tilde

* 在 ~/.xprofile 里设置了 BROWSER=chromium
* chromium 为来自 archlinuxcn 源的 chromium-vaapi 78.0.3904.97-1包

最近编辑记录 αlpha0x00 (2019-11-13 08:55:49)


hmm

离线

#2 2019-11-12 23:21:06

αlpha0x00
会员
注册时间: 2018-06-04
帖子: 17

Re: [已解决] zathura 无法打开链接

我又尝试调查了一下,发现锅应该不是 zathura 和 xdg-open,毕竟 xdg-open 确确实实已经调用了 chromium,但是 chromium 崩溃了……
这是崩溃后的 coredump 信息,尝试吧 ~/.config/chromium-flags.conf 中关于硬件加速部分关闭了,仍然是同样的问题。

           PID: 9319 (chromium)
           UID: 1000 (xxx)
           GID: 1000 (xxx)
        Signal: 5 (TRAP)
     Timestamp: Tue 2019-11-12 22:46:29 CST (32min ago)
  Command Line: /usr/lib/chromium/chromium --ignore-gpu-blacklist --enable-gpu-rasterization --enable-native-gpu-memory-buffers --enable-zero-copy --enable-accelerated-mjpeg-decode --enable-accelerated-video https://github.com/clerkma/fandol-fonts
    Executable: /usr/lib/chromium/chromium
 Control Group: /user.slice/user-1000.slice/session-4.scope
          Unit: session-4.scope
         Slice: user-1000.slice
       Session: 4
     Owner UID: 1000 (xxx)
       Boot ID: 36bfc65221e040b188f85ec4495f88c0
    Machine ID: 77fe10c9f5324580948b398d67efa09f
      Hostname: Y430P
       Storage: /var/lib/systemd/coredump/core.chromium.1000.36bfc65221e040b188f85ec4495f88c0.9319.1573569989000000000000.lz4 (truncated)
       Message: Process 9319 (chromium) of user 1000 dumped core.
                
                Stack trace of thread 9319:
                #0  0x000055c3d247d1cd n/a (/usr/lib/chromium/chromium)

最近编辑记录 αlpha0x00 (2019-11-12 23:27:05)


hmm

离线

#3 2019-11-13 00:08:59

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,384
个人网站

Re: [已解决] zathura 无法打开链接

哦,那看到是你的 chromium 使用那些参数的时候会出问题。

离线

#4 2019-11-13 00:13:13

αlpha0x00
会员
注册时间: 2018-06-04
帖子: 17

Re: [已解决] zathura 无法打开链接

依云 说:

哦,那看到是你的 chromium 使用那些参数的时候会出问题。

命令行启动参数吗?这部分我没给参数时也是同样的问题


hmm

离线

#5 2019-11-13 08:51:47

αlpha0x00
会员
注册时间: 2018-06-04
帖子: 17

Re: [已解决] zathura 无法打开链接

经昨天 #archlinux-cn 群里菊苣的指点,通过如下脚本查看了调用 chromium 的环境变量,发现没什么异常。
后来注意到 zathura 默认是运行于 sandox 模式下[0],这个可能导致崩溃。于是设置 set sandbox none,关闭 sandbox 后就没有出现崩溃了 smile

[0] https://www.mankier.com/5/zathurarc#Options-sandbox


hmm

离线

#6 2019-11-13 12:08:29

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,384
个人网站

Re: [已解决] zathura 无法打开链接

原来还有这种东西。zathura 不是应该在 sandbox 外调用子进程吗……

离线

页脚