您尚未登录。

#1 2019-11-23 15:32:54

kurumi-scarlet
会员
注册时间: 2019-11-11
帖子: 9

求助:安装nvidia闭源驱动后不能进入gnome环境。

刚重装好Arch,在装完的时候就就把nouveau加进了黑名单。然后重启,用pacman安装了 xf86-video-intel gnome gnome-extra xorg nvidia,编辑/etc/gdm/custom.conf,禁用了wayland,执行

systemctl enable gdm

后重启,左上角出现一条下划线,然后屏幕就全黑没反应了。按ctrl+alt+F2~6也不能切换终端。
我用U盘启动,arch-chroot之后执行

nvidia-xconfig

退出重启,这次屏幕左上角出现下划线就没反应了,但我能切换终端用字符登录。
然后我执行

pacman -R nvidia

之后重启,能正常进入gnome环境。
请问是我的操作有错误还是我需要额外的配置来使用nvidia驱动?

离线

#2 2019-11-23 16:02:35

hounh
会员
注册时间: 2015-03-15
帖子: 29

Re: 求助:安装nvidia闭源驱动后不能进入gnome环境。

具体什么型号的显卡

离线

#3 2019-11-23 16:07:42

kurumi-scarlet
会员
注册时间: 2019-11-11
帖子: 9

Re: 求助:安装nvidia闭源驱动后不能进入gnome环境。

hounh 说:

具体什么型号的显卡

GTX1070移动版,还有intel530,不好意思信息没提供好。

离线

#4 2019-11-23 16:28:06

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,384
个人网站

Re: 求助:安装nvidia闭源驱动后不能进入gnome环境。

nvidia-xconfig 这个我没用过。
是双显卡吗?那么你有几种用法。见: https://wiki.archlinux.org/index.php/NVIDIA_Optimus

从你提供的信息,我看不出来你想怎么用。

离线

#5 2019-11-23 17:27:58

kurumi-scarlet
会员
注册时间: 2019-11-11
帖子: 9

Re: 求助:安装nvidia闭源驱动后不能进入gnome环境。

依云 说:

nvidia-xconfig 这个我没用过。
是双显卡吗?那么你有几种用法。见: https://wiki.archlinux.org/index.php/NVIDIA_Optimus

从你提供的信息,我看不出来你想怎么用。

nvidia-xconfig是自动生成/etc/X11/xorg.conf文件的命令,我已经尝试了https://wiki.archlinux.org/index.php/NVIDIA_Optimus里单独使用Nvidia显卡的方法,但是我只得到这些信息。 https://img.vim-cn.com/ea/9a017f2d6cc80 … 0df74c.jpg

最近编辑记录 kurumi-scarlet (2019-11-23 17:28:29)

离线

#6 2019-11-23 18:10:27

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,384
个人网站

Re: 求助:安装nvidia闭源驱动后不能进入gnome环境。

日志呢?一般是在 /var/log/Xorg.0.log。

离线

#7 2019-11-23 19:39:29

kurumi-scarlet
会员
注册时间: 2019-11-11
帖子: 9

Re: 求助:安装nvidia闭源驱动后不能进入gnome环境。

依云 说:

日志呢?一般是在 /var/log/Xorg.0.log。

原来有日志这种东西的吗?我重装了系统把gnome和gdm换成了kde和sddm,按照同样的指导完成了配置,进入kde成功了。日志没有存挺可惜的,本来可能能知道哪里出问题了。

连着折腾了几天电脑,小白的系统算是装好了吧,感谢狐狸的帮忙!

离线

页脚