您尚未登录。

#1 2019-04-19 12:21:08

bug_ggg
会员
注册时间: 2019-04-19
帖子: 2

qt无法正常使用

系统是arch+kde+sddm,装完系统后就安装好了qt,并且新建了一个项目运行了一下一切正常。但是,晚上回来准备用其他时,发现桌面上的qt creator图标不能启动了,然后顺着路径直接运行Qt5.12.2/Tools/QtCreator/bin/qtcreator出现以下错误

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

[1]    12918 abort (core dumped)  ./qtcreator

然后发现通过目录下的qtcreator.sh可以成功启动qt creator但是运行新建项目再次报错

/home/gcw/Qt5.12.2/5.12.2/gcc_64/bin/uic: relocation error: /home/gcw/Qt5.12.2/5.12.2/gcc_64/bin/uic: symbol _ZdlPvm version Qt_5 not defined in file libQt5Core.so.5 with link time reference
make: *** [Makefile:827: ui_mainwindow.h] Error 127
12:19:10: 进程"/usr/bin/make"退出,退出代码 2 。
Error while building/deploying project untitled2 (kit: Desktop Qt 5.12.2 GCC 64bit)
When executing step "Make"

研究了一会后,发现不创建ui文件可以正常编译运行。而且我最开始创建的带ui文件的项目可以正常运行,但是在修改ui文件后,编译出错。
有大佬知道这是什么问题吗?哭了

离线

#2 2019-04-19 17:40:23

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,045
个人网站

Re: qt无法正常使用

/home/gcw/Qt5.12.2/5.12.2/gcc_64/bin/uic?你干了什么?

离线

#3 2019-04-19 20:03:25

bug_ggg
会员
注册时间: 2019-04-19
帖子: 2

Re: qt无法正常使用

我啥也没干啊,就安装了oh-my-zsh,tensorflow,keras,opengl,再弄了一下sddm的主题,然后关机,等一会在打开就这样了。5555555555

从arch库里安装了个qtcreator解决了。。。。。。。。。。。。

最近编辑记录 bug_ggg (2019-04-19 21:14:59)

离线

页脚