您尚未登录。

#1 2019-03-06 15:58:48

静水
会员
注册时间: 2018-11-22
帖子: 21
个人网站

Archlinux软件包更新失败

安装了Archlinux Updates Indicator 用来通知软件包包是否有更新,很久一段时间未更新,再更新时发现有460多个更新项,但是更新总是失败,更新过程是这样的:

:: 正在同步软件包数据库...
 core 已经是最新版本
 extra 已经是最新版本
 community 已经是最新版本
 multilib 已经是最新版本
 archlinuxcn 已经是最新版本
:: 正在进行全面系统更新...
警告:cuda:忽略软件包更新 (9.2.148-2 => 10.0.130-2)
:: 替换 geoclue2 吗 (使用 extra/geoclue )? [Y/n] y
:: 替换 libsystemd 吗 (使用 core/systemd-libs )? [Y/n] y
警告:nodejs:忽略软件包更新 (11.1.0-1 => 11.10.1-1)
:: 替换 vimix-grub 吗 (使用 community/grub-theme-vimix )? [Y/n] y
正在解决依赖关系...
正在查找软件包冲突...
警告:检测到依赖关系环:
警告:egl-wayland 将在它 mesa 的依赖关系之前被安装
警告:检测到依赖关系环:
警告:rubygems 将在它 ruby 的依赖关系之前被安装

软件包 (472) accountsservice-0.6.54+2+g204a4ab-2  alsa-lib-1.1.8-1
             alsa-plugins-1.1.8-1  apache-2.4.38-1  appstream-glib-0.7.15-1
             apr-util-1.6.1-5  archlinux-keyring-20190123-2
             archlinuxcn-keyring-20190219-1  at-spi2-atk-2.30.1-1
             at-spi2-core-2.30.1-1  atom-1.34.0-1  audit-2.8.4-3
             augeas-1.11.0-2  avahi-0.7+18+g1b5f401-1  bash-5.0.0-1
             bbswitch-0.8-203  bc-1.07.1-3  bind-tools-9.13.7-1
             binutils-2.31.1-4  bluez-5.50-6  bluez-libs-5.50-6  bolt-0.7-2
             boost-libs-1.69.0-1  btrfs-progs-4.20.2-1
             ca-certificates-mozilla-3.42.1-1  cairo-1.16.0-2
             ceph-libs-13.2.1-3  clutter-gst-3.0.27-1  cryptsetup-2.1.0-1
             cups-2.2.10-2  cups-filters-1.22.1-1  cups-pk-helper-0.2.6-3
             curl-7.64.0-9  dbus-1.12.12-1  deepin-fonts-wine-2.18_17-1
             deepin-libwine-2.18_17-1  deepin-qt-dbus-factory-1.1.0-1
             deepin-qt5dxcb-plugin-1.1.24-1  deepin-qt5integration-0.3.7.2-2
             deepin-screenshot-4.1.8-1  deepin-wine-2.18_17-1
             deepin-wine-binfmt-2.18_17-1  deepin-wine-helper-1.2-1
             deepin-wine-plugin-1.0.2-2  deepin-wine32-2.18_17-1
             deepin-wine32-preloader-2.18_17-1  deepin-wine32-tools-2.18_17-1
             device-mapper-2.02.183-2  dialog-1:1.3_20190211-1  diffutils-3.7-1
             docker-1:18.09.3-1  dtkcore-1:2.0.9.17-1  dtkwidget-2.0.9.17-1
             dtkwm-2.0.9-4  e2fsprogs-1.44.5-1  egl-wayland-1.1.2-1
             electron-3.1.4-1  eog-3.28.4+5+ge02a9ae0-1
             evolution-data-server-3.30.5-1  exempi-2.5.0-1  fcitx-qt5-1.2.3-5
             ffmpeg-1:4.1.1-2  file-5.36-1  filesystem-2018.12-2
             firefox-65.0.2-1  folks-0.11.4+42+g5520ed9a-2
             freerdp-1:2.0.0_rc4-3  fuse-common-3.4.1-1  fuse2-2.9.9-1
             gawk-4.2.1-2  gcab-1.2-1  gcc-8.2.1+20181127-1
             gcc-libs-8.2.1+20181127-1  gcc7-7.4.1+20181207-2
             gcc7-libs-7.4.1+20181207-2  gcr-3.28.1-1  gdbm-1.18.1-2
             gdk-pixbuf2-2.38.1-1  gdm-3.30.3-1  geoclue-2.5.2-3
             geoclue2-2.5.1-1 [删除]  ghostscript-9.26-2  git-2.21.0-1
             gjs-2:1.54.3-2  glib2-2.58.3-1  glibmm-2.58.0-1
             glslang-7.10.2984-1  glusterfs-1:5.3-2  gmime3-3.2.3-3
             gnokii-0.6.31-18  gnome-contacts-3.30.2-1
             gnome-control-center-3.30.3-1  gnome-desktop-1:3.30.2.1-1
             gnome-online-accounts-3.30.2-1  gnome-settings-daemon-3.30.2-1
             gnome-software-3.30.6-1  gnome-sound-recorder-3.28.2-1
             gnome-tweaks-3.30.2-1  gnupg-2.2.13-1  gnutls-3.6.6-3  go-2:1.12-1
             go-tools-2:1.11+2495+9e9bf16a4-1
             gobject-introspection-runtime-1.58.3-1
             google-chrome-72.0.3626.121-1  google-chrome-dev-74.0.3724.8-1
             gparted-0.33.0-1  gpgme-1.12.0-2  graphene-1.8.4-1
             graphite-1:1.3.13-1  grep-3.3-1  grub-theme-vimix-20180916-1
             gsfonts-20180524-2  gssdp-1.0.3-1  gst-plugins-bad-1.14.4-8
             gst-plugins-good-1.14.4-2  gtk-sharp-2-2.12.45-2
             gtk-update-icon-cache-3.24.5-1  gtk3-3.24.5-1  gtkd-3.8.5-2
             guile-2.2.4-2  gupnp-igd-0.2.5-1  gvfs-1.38.1+9+gd4dab113-2
             gvfs-afc-1.38.1+9+gd4dab113-2  gvfs-goa-1.38.1+9+gd4dab113-2
             gvfs-google-1.38.1+9+gd4dab113-2
             gvfs-gphoto2-1.38.1+9+gd4dab113-2  gvfs-mtp-1.38.1+9+gd4dab113-2
             gvfs-nfs-1.38.1+9+gd4dab113-2  gvfs-smb-1.38.1+9+gd4dab113-2
             gzip-1.10-1  harfbuzz-2.3.1-2  harfbuzz-icu-2.3.1-2
             http-parser-2.9.0-1  hugo-0.54.0-1  hunspell-1.7.0-2
             iana-etc-20190219-1  imagemagick-7.0.8.32-1  inetutils-1.9.4-7
             intel-tbb-2019.3-1  iproute2-4.20.0-1  iputils-20180629.f6aac8d-4
             iso-codes-4.2-1  iw-5.0.1-1  jack-0.125.0-7  jansson-2.12-1
             jdk8-8u202-1  jekyll-3.8.5-2  js52-52.9.0-2  js60-60.4.0-2
             kmod-26-2  ladspa-1.15-1  lantern-bin-5.3.1-1
             lib32-alsa-lib-1.1.8-2  lib32-alsa-plugins-1.1.8-1
             lib32-dbus-1.12.12-1  lib32-expat-2.2.6-2
             lib32-gcc-libs-8.2.1+20181127-1  lib32-glib2-2.58.3-1
             lib32-harfbuzz-2.3.1-2  lib32-libcap-2.26-1  lib32-libdrm-2.4.97-1
             lib32-libelf-0.175-1  lib32-libgpg-error-1.35-1
             lib32-libjpeg-turbo-2.0.2-1  lib32-libldap-2.4.47-1
             lib32-libogg-1.3.3-3  lib32-libpng-1.6.36-1  lib32-libxml2-2.9.9-1
             lib32-llvm-libs-7.0.1-1  lib32-lm_sensors-3.5.0-2
             lib32-mesa-18.3.4-1  lib32-ncurses-6.1-4
             lib32-nvidia-utils-418.43-2  lib32-opencl-nvidia-418.43-2
             lib32-openssl-1:1.1.1.b-1  lib32-readline-8.0.0-1
             lib32-systemd-241.7-1  lib32-zstd-1.3.8-1  libassuan-2.5.3-1
             libatomic_ops-7.6.8-1  libbluray-1.1.0-1
             libcdio-paranoia-10.2+2.0.0-1  libcdr-0.1.5-1  libcmis-0.5.2-2
             libcups-2.2.10-2  libdmapsharing-2.9.39-2  libdrm-2.4.97-1
             libedit-20181209_3.1-1  libelf-0.175-1  libetonyek-0.1.9-1
             libfbclient-3.0.4.33054-1  libfdk-aac-2.0.0-1  libfontenc-1.1.4-1
             libgdm-3.30.3-1  libgnomekbd-3.26.1-1  libgpg-error-1.35-1
             libgphoto2-2.5.22-1  libgsf-1.14.45-1  libgweather-3.28.3-1
             libgxps-0.3.1-1  libibus-1.5.20-1  libidn2-2.1.1-2
             libinput-1.12.6-1  libixion-0.14.1-2  libjpeg-turbo-2.0.2-1
             libldap-2.4.47-1  liblouis-3.8.0-1  liblphobos-2:1.14.0-1
             libmagick-7.0.8.32-1  libmm-glib-1.10.0-1
             libnautilus-extension-3.30.5-1  libnfs-4.0.0-3
             libnghttp2-1.36.0-1  libnice-0.1.15-1
             libnm-1.14.7dev+3+g353743b99-1
             libnm-glib-1.14.7dev+3+g353743b99-1
             libnma-1.8.21dev+3+gb4c365b1-1  liborcus-0.14.1-2
             libphonenumber-8.10.1-2  libpipeline-1.5.1-1  libplacebo-1.7.0-1
             libpng-1.6.36-1  libpsl-0.20.2-5  libpwquality-1.4.0-2
             libqtxdg-3.3.0-2  libqxp-0.0.2-1  libraw-0.19.2-1
             libreoffice-fresh-6.2.0-3  libreoffice-fresh-zh-cn-6.2.0-1
             librsvg-2:2.44.13-1  libsasl-2.1.27-1  libsecret-0.18.8-2
             libsodium-1.0.17-1  libssh-0.8.7-1  libsynctex-2018.48691-6
             libsystemd-239.303-1 [删除]  libteam-1.28-2  libtommath-1.1.0-1
             libunwind-1.3.1-1  liburcu-0.10.2-1  libutil-linux-2.33.1-2
             libuv-1.26.0-1  libva-2.4.0-1  libvirt-5.1.0-1
             libvirt-glib-2.0.0-1  libvpx-1.8.0-1  libwbclient-4.9.4-2
             libwebp-1.0.2-1  libwpd-0.10.3-1  libwpg-0.3.3-1  libxau-1.0.9-1
             libxkbcommon-0.8.4-1  libxkbcommon-x11-0.8.4-1  libxml2-2.9.9-1
             libxnvctrl-418.43-1  libxslt-1.1.33-1  linux-5.0.arch1-1
             linux-firmware-20190212.28f5f7d-1  llvm-libs-7.0.1-2
             lm_sensors-3.5.0-1  lmdb-0.9.23-1  logrotate-3.15.0-1  lsof-4.91-1
             lua-5.3.5-2  lua51-5.1.5-8  lua52-5.2.4-4  lua52-socket-20190219-1
             lvm2-2.02.183-2  man-db-2.8.5-2  mesa-18.3.4-1  metis-5.1.0.p5-1
             mkinitcpio-busybox-1.30.1-1
             mobile-broadband-provider-info-20190116-1  mono-5.18.0.240-1
             mpfr-4.0.2-1  mtools-4.0.23-1  mutter-3.30.2-2  nautilus-3.30.5-1
             ncurses-6.1-6  ndctl-64.1-1  netcf-0.2.8-7  netctl-1.20-1
             nettle-3.4.1-1  networkmanager-1.14.7dev+3+g353743b99-1
             nm-connection-editor-1.8.21dev+3+gb4c365b1-1
             noto-fonts-20190111-1  npm-6.8.0-1  nss-3.42.1-1  nvidia-418.43-5
             nvidia-settings-418.43-1  nvidia-utils-418.43-2  openal-1.19.1-2
             opencl-nvidia-418.43-2  openra-20181215-1  openssl-1.1.1.b-1
             openssl-1.0-1.0.2.r-1  osinfo-db-20181214-1  p11-kit-0.23.15-1
             pacman-5.1.3-1  pacman-mirrorlist-20190109-1  pambase-20190105.1-1
             pango-1:1.42.4-1  papirus-icon-theme-20190302-1  parted-3.2-8
             pcre-8.43-1  pcre2-10.32-2  perl-5.28.1-1  phonon-qt5-4.10.2-1
             pipewire-0.2.5+3+g371da358-1  pixman-0.38.0-2  pkgconf-1.6.0-1
             polkit-0.115+24+g5230646-1  poppler-0.74.0-1
             poppler-glib-0.74.0-1  protobuf-3.6.1.3-1
             pycharm-professional-2018.3.5-1  python-3.7.2-3
             python-astroid-2.1.0-1  python-distro-1.4.0-1  python-idna-2.8-1
             python-lockfile-0.12.2-4  python-lxml-4.3.2-1
             python-msgpack-0.6.1-1  python-nautilus-1.2.2-3
             python-packaging-19.0-1  python-pep517-0.5.0-1  python-pip-18.1-1
             python-pycodestyle-2.5.0-1  python-pyflakes-2.1.1-1
             python-pylint-2.2.2-1  python-pyparsing-2.3.1-1
             python-requests-2.21.0-1  python-setuptools-1:40.8.0-1
             python-six-1.12.0-1  python-urllib3-1.24.1-2
             python-wrapt-1.11.1-1  python2-2.7.15-4  qemu-3.1.0-2
             qpdf-8.4.0-1  qt4-4.8.7-27  qt5-base-5.12.1-2
             qt5-declarative-5.12.1-1  qt5-graphicaleffects-5.12.1-1
             qt5-location-5.12.1-1  qt5-multimedia-5.12.1-1
             qt5-quickcontrols-5.12.1-2  qt5-quickcontrols2-5.12.1-1
             qt5-styleplugins-5.0.0.20170311-10  qt5-svg-5.12.1-1
             qt5-webchannel-5.12.1-1  qt5-webengine-5.12.1-2
             qt5-x11extras-5.12.1-1  qt5-xmlpatterns-5.12.1-1  re2-20190301-1
             readline-8.0.0-1  redland-1:1.0.17-7  rp-pppoe-3.13-1
             rtkit-0.11+10+g493a135-1  ruby-2.6.1-1  ruby-addressable-2.6.0-1
             ruby-benchmark-ips-2.7.2-2  ruby-benchmark_suite-1.0.0-3
             ruby-bundler-2.0.1-3  ruby-colorator-1.1.0-5
             ruby-concurrent-ruby-1.1.4-1  ruby-dbus-0.15.0-2
             ruby-diff-lcs-1.3-3  ruby-em-websocket-0.5.1-5
             ruby-eventmachine-1.2.7-2  ruby-ffi-1.10.0-2
             ruby-forwardable-extended-2.6.0-4  ruby-http_parser.rb-0.6.0-5
             ruby-i18n-0.9-0.9.5-1  ruby-jekyll-sass-converter-1.5.2-2
             ruby-jekyll-watch-2.0.0-3  ruby-json-2.2.0-2
             ruby-kramdown-2.0.0-1  ruby-kramdown-1-1.17.0-3
             ruby-liquid-4.0.1-2  ruby-listen-3.1.5-4  ruby-maruku-0.7.3-4
             ruby-mercenary-0.3.6-3  ruby-pathutil-0.16.1-3
             ruby-public_suffix-3.0.3-2  ruby-rake-12.3.1-3
             ruby-rake-compiler-1.0.7-2  ruby-rb-fsevent-0.10.3-2
             ruby-rb-inotify-0.9.10-3  ruby-rdoc-6.1.1-3  ruby-rouge-3.3.0-2
             ruby-rspec-3.8.0-2  ruby-rspec-core-3.8.0-2
             ruby-rspec-expectations-3.8.1-2  ruby-rspec-mocks-3.8.0-2
             ruby-rspec-support-3.8.0-2  ruby-ruby_dep-1.5.0-5
             ruby-safe_yaml-1.0.4-4  ruby-sass-3.7.3-1
             ruby-sass-listen-4.0.0-6  ruby-yajl-ruby-1.4.1-2
             ruby-yard-0.9.14-2  rubygems-3.0.2-3  run-parts-4.8.6.1-1
             s-nail-14.9.11-3  sddm-0.18.0-2  sed-4.7-1  shaderc-2018.0-3
             shadow-4.6-2  shared-mime-info-1.12-1  smbclient-4.9.4-2
             soundtouch-2.1.2-1  speexdsp-1.2rc3-4  spice-0.14.0-3
             sqlite-3.27.2-1  sudo-1.8.27-1  suitesparse-5.4.0-1
             systemd-241.7-2  systemd-libs-241.7-2  systemd-sysvcompat-241.7-2
             taglib-1.11.1-3  tar-1.32-1  tilix-1.8.9-2  totem-3.30.0-1
             totem-plparser-3.26.3-1  tracker-2.2.0-3  tracker-miners-2.2.0-1
             tslib-1.19-1  tzdata-2018i-1  usbmuxd-1.1.0+48+g1cc8b34-3
             util-linux-2.33.1-2  v4l-utils-1.16.3-1  vim-8.1.0877-1
             vim-runtime-8.1.0877-1  vimix-grub-20180916-1 [删除]
             vimix-gtk-themes-git-299.c6b15d0-1  virtualgl-2.6.1-1
             visual-studio-code-bin-1.31.1-1  vlc-3.0.6-8  vte-common-0.54.3-1
             vte3-0.54.3-1  vulkan-icd-loader-1.1.101-1  webkit2gtk-2.22.7-1
             webstorm-2018.3.5-1  wget-1.20.1-3  whois-5.4.1-1
             wpa_supplicant-2:2.6-2  x265-3.0-1  xdg-user-dirs-0.17-2
             xf86-input-libinput-0.28.2-1
             xf86-video-intel-1:2.99.917+860+g3a2dec17-1  xfsprogs-4.19.0-2
             xkeyboard-config-2.26-2  xorg-server-1.20.4-1
             xorg-server-common-1.20.4-1  xorg-server-devel-1.20.4-1
             xorg-server-xdmx-1.20.4-1  xorg-server-xephyr-1.20.4-1
             xorg-server-xnest-1.20.4-1  xorg-server-xvfb-1.20.4-1
             xorg-server-xwayland-1.20.4-1  xorg-xcursorgen-1.0.7-1
             xorg-xev-1.2.3-1  xorg-xhost-1.0.8-1  xorg-xlsatoms-1.1.3-1
             xorg-xmodmap-1.0.10-1  xorg-xrdb-1.2.0-1  xorg-xvinfo-1.1.4-1
             yarn-1.13.0-1  yay-9.1.0-1  zeromq-4.3.1-1  zsh-5.7.1-1
             zstd-1.3.8-1

全部安装大小:  8684.77 MiB
净更新大小:   125.59 MiB

:: 进行安装吗? [Y/n] y
(469/469) 正在检查密钥环里的密钥                   [######################] 100%
(469/469) 正在检查软件包完整性                     [######################] 100%
(469/469) 正在加载软件包文件                       [######################] 100%
(469/469) 正在检查文件冲突                         [######################] 100%
错误:无法提交处理 (有冲突的文件)
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/__pycache__/pyproject.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__init__.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/__init__.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/autocompletion.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/base_command.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/cmdoptions.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/main_parser.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/parser.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/__pycache__/status_codes.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/autocompletion.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/base_command.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/cmdoptions.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/main_parser.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/parser.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/cli/status_codes.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/models/__pycache__/candidate.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/models/__pycache__/format_control.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/models/__pycache__/link.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/models/candidate.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/models/format_control.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/models/link.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/pyproject.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/req/__pycache__/constructors.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/req/constructors.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/utils/__pycache__/compat.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/utils/__pycache__/models.cpython-37.pyc 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/utils/compat.py 
python-pip: 文件系统中已存在 /usr/lib/python3.7/site-packages/pip/_internal/utils/models.py 
发生错误,没有软件包被更新。
Done - Press enter to exit

离线

#2 2019-03-06 16:58:57

Mr.I
路人丙
所在地: SH
注册时间: 2015-08-29
帖子: 145

Re: Archlinux软件包更新失败

楼主你是手动更新过那个用 pacman 安装的 pip 了吧?

我看了一下,这里面的一些文件是老版本的 pip 中没有的。

比如 pip/_internal/models/ 目录里,目前最新版 18.1-1 中的 .py 是这样的:

usr/lib/python3.7/site-packages/pip/_internal/models/__init__.py
usr/lib/python3.7/site-packages/pip/_internal/models/candidate.py
usr/lib/python3.7/site-packages/pip/_internal/models/format_control.py
usr/lib/python3.7/site-packages/pip/_internal/models/index.py
usr/lib/python3.7/site-packages/pip/_internal/models/link.py

而稍微老一些的 18.0 版本这个目录下只有 __init__.py 和 index.py。

从症状上来看的话,应该是 pip/_internal 目录里面出现了一些 pacman 不认识(旧版没有)的文件,并且和新版中包含的文件重名,很可能是手动更新过的关系。

但是如果只是 pip 的话,直接覆盖掉应该也没有什么危险。

最近编辑记录 Mr.I (2019-03-06 17:07:27)


运维工程师,业余程序员,偶尔写写代码,对 ArchLinux 和 Gnome3 一见钟情 wink

离线

#3 2019-03-06 19:54:59

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,099
个人网站

Re: Archlinux软件包更新失败

pip 只能在虚拟环境中使用,不然会和 pacman 打架的。

离线

#4 2019-03-06 23:16:53

xtricman
エクス·トリクマン
注册时间: 2012-12-26
帖子: 696

Re: Archlinux软件包更新失败

依云 说:

pip 只能在虚拟环境中使用,不然会和 pacman 打架的。

这玩意在Linux下不是也安装包到家目录吗?如果不是root的话?

最近编辑记录 xtricman (2019-03-06 23:17:19)

离线

#5 2019-03-06 23:33:50

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,099
个人网站

Re: Archlinux软件包更新失败

xtricman 说:
依云 说:

pip 只能在虚拟环境中使用,不然会和 pacman 打架的。

这玩意在Linux下不是也安装包到家目录吗?如果不是root的话?

如果不是 root 会报错的。加 --user 才能安装到家目录下(然后家目录下的库和系统路径下的库打架)。

离线

页脚