您尚未登录。

#1 2017-08-28 23:42:13

LuGuoHuas
会员
注册时间: 2017-08-11
帖子: 9

Fcitx在wine中无法输入

Fcitx在其他地方可以使用,但是在wine的TIM中显示了输入框无法输入。可以帮我看看是什么问题吗?

# System Info:
1.  `uname -a`:

        Linux LARCH 4.12.8-2-ARCH #1 SMP PREEMPT Fri Aug 18 14:08:02 UTC 2017 x86_64 GNU/Linux

2.  `lsb_release`:

    `lsb_release` not found.

3.  `/etc/lsb-release`:

    `/etc/lsb-release` not found.

4.  `/etc/os-release`:

        NAME="Arch Linux"
        PRETTY_NAME="Arch Linux"
        ID=arch
        ID_LIKE=archlinux
        ANSI_COLOR="0;36"
        HOME_URL="https://www.archlinux.org/"
        SUPPORT_URL="https://bbs.archlinux.org/"
        BUG_REPORT_URL="https://bugs.archlinux.org/"

5.  Desktop Environment:

    Desktop environment is `kde`.

6.  Bash Version:

        BASH_VERSION='4.4.12(1)-release'

# Environment:
1.  DISPLAY:

        DISPLAY=':0'

2.  Keyboard Layout:

    1.  `setxkbmap`:

            xkb_keymap {
                xkb_keycodes  { include "evdev+aliases(qwerty)" };
                xkb_types     { include "complete"      };
                xkb_compat    { include "complete"      };
                xkb_symbols   { include "pc+us+inet(evdev)"     };
                xkb_geometry  { include "pc(pc105)"     };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us", "", ""

3.  Locale:

    1.  All locale:

            C
            POSIX
            en_US.utf8
            zh_CN.utf8

    2.  Current locale:

            LANG=mn_CN.UTF-8
            LC_CTYPE="mn_CN.UTF-8"
            LC_NUMERIC="mn_CN.UTF-8"
            LC_TIME="mn_CN.UTF-8"
            LC_COLLATE="mn_CN.UTF-8"
            LC_MONETARY="mn_CN.UTF-8"
            LC_MESSAGES="mn_CN.UTF-8"
            LC_PAPER="mn_CN.UTF-8"
            LC_NAME="mn_CN.UTF-8"
            LC_ADDRESS="mn_CN.UTF-8"
            LC_TELEPHONE="mn_CN.UTF-8"
            LC_MEASUREMENT="mn_CN.UTF-8"
            LC_IDENTIFICATION="mn_CN.UTF-8"
            LC_ALL=

        **Error occurs when running `locale`. Please check your locale settings.**

            locale: Cannot set LC_CTYPE to default locale: No such file or directory
            locale: Cannot set LC_MESSAGES to default locale: No such file or directory
            locale: Cannot set LC_ALL to default locale: No such file or directory

4.  Directories:

    1.  Home:

            /home/lluu

    2.  `${XDG_CONFIG_HOME}`:

        Environment variable `XDG_CONFIG_HOME` is not set.

        Current value of `XDG_CONFIG_HOME` is `~/.config` (`/home/lluu/.config`).

    3.  Fcitx Settings Directory:

        Current fcitx settings directory is `~/.config/fcitx` (`/home/lluu/.config/fcitx`).

5.  Current user:

    The script is run as lluu (1000).

# Fcitx State:
1.  executable:

    Found fcitx at `/usr/bin/fcitx`.

2.  version:

    Fcitx version: `4.2.9.1`

3.  process:

    Found 2 fcitx processes:

          676 fcitx
         1858 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` works properly.

# Fcitx Configure UI:
1.  Config Tool Wrapper:

    Found fcitx-configtool at `/usr/bin/fcitx-configtool`.

2.  Config GUI for gtk2:

    **Config GUI for gtk2 not found.**

3.  Config GUI for gtk3:

    **Config GUI for gtk3 not found.**

4.  Config GUI for kde:

    **`kcmshell4` not found.**

    **Cannot find a GUI config tool, please install one of `kcm-fcitx`, `fcitx-config-gtk2`, or `fcitx-config-gtk3`.**

# Frontends setup:
## Xim:
1.  `${XMODIFIERS}`:

    Environment variable XMODIFIERS is set to "@im=fcitx" correctly.
    Xim Server Name from Environment variable is fcitx.

2.  XIM_SERVERS on root window:

    Xim server name is the same with that set in the environment variable.

3.  XIM for Emacs:

    **Your LC_CTYPE is set to mn_CN.UTF-8 instead of one of zh, ja, ko. You may not be able to use input method in emacs because of an really old emacs bug that upstream refuse to fix for years.**

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    Environment variable QT_IM_MODULE is set to "fcitx" correctly.

2.  qt5 - `${QT_IM_MODULE}`:

    Environment variable QT_IM_MODULE is set to "fcitx" correctly.

3.  Qt IM module files:
    Found fcitx qt module: `/usr/lib/fcitx/qt/libfcitx-quickphrase-editor.so`.
    Found fcitx qt module: `/usr/lib/fcitx/qt/libfcitx-libpinyin-dictmanager.so`.
    Found fcitx im module for Qt5: `/usr/lib/qt/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.
    Found fcitx im module for Qt4: `/usr/lib/qt4/plugins/inputmethods/qtim-fcitx.so`.

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    Environment variable GTK_IM_MODULE is set to "fcitx" correctly.

2.  `gtk-query-immodules`:

    1.  gtk 2:

        Found `gtk-query-immodules` for gtk `2.24.31` at `/usr/bin/gtk-query-immodules-2.0`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.31

        Found fcitx im modules for gtk `2.24.31`.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found `gtk-query-immodules` for gtk `3.22.19` at `/usr/bin/gtk-query-immodules-3.0`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.22.19

        Found fcitx im modules for gtk `3.22.19`.

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

3.  Gtk IM module cache:

    1.  gtk 2:

        Found immodules cache for gtk `2.24.31` at `/usr/lib/gtk-2.0/2.10.0/immodules.cache`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.31

        Found fcitx im modules for gtk `2.24.31`.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found immodules cache for gtk `3.22.19` at `/usr/lib/gtk-3.0/3.0.0/immodules.cache`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.22.19

        Found fcitx im modules for gtk `3.22.19`.

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

4.  Gtk IM module files:

    1.  gtk 2:

        All found Gtk 2 immodule files exist.

    2.  gtk 3:

        All found Gtk 3 immodule files exist.

# Configuration:
## Fcitx Addons:
1.  Addon Config Dir:

    Found fcitx addon config directory: `/usr/share/fcitx/addon`.

2.  Addon List:

    1.  Found 27 enabled addons:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-googlepinyin
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-libpinyin
            fcitx-notificationitem
            fcitx-pinyin-enhance
            fcitx-pinyin
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  Found 2 disabled addons:

            fcitx-light-ui
            fcitx-qw

3.  Addon Libraries:

    All libraries for all addons are found.

4.  User Interface:

    Found 2 enabled user interface addons:

        fcitx-classic-ui
        fcitx-kimpanel-ui

## Input Methods:
1.  Found 5 enabled input methods:

        fcitx-keyboard-us
        googlepinyin
        pinyin-libpinyin
        shuangpin-libpinyin
        zhuyin-libpinyin

2.  Default input methods:

    You have a keyboard input method "fcitx-keyboard-us" correctly added as your default input method.

# Log:
1.  `date`:

        Mon Aug 28 23:29:17 CST 2017

2.  `~/.config/fcitx/log/`:

        total 0

3.  `~/.config/fcitx/log/crash.log`:

    `~/.config/fcitx/log/crash.log` not found.

最近编辑记录 LuGuoHuas (2017-08-28 23:45:15)

离线

#2 2017-08-29 09:45:42

pretzel
会员
注册时间: 2017-08-03
帖子: 10

Re: Fcitx在wine中无法输入

在Wine TIM的desktop文件中的Exec里面加环境变量

离线

#3 2017-08-29 22:03:56

LuGuoHuas
会员
注册时间: 2017-08-11
帖子: 9

Re: Fcitx在wine中无法输入

我是直接用的wine TIM.exe,你说的Exec加环境变量怎么加?加什么的环境变量?是要我用tim.desktop这个里面加吗?

离线

#4 2017-08-30 08:53:11

pretzel
会员
注册时间: 2017-08-03
帖子: 10

Re: Fcitx在wine中无法输入

呢可以先试试手动启动

XMODIFIERS=@im=fcitx GTK_IM_MODULE=fcitx QT4_IM_MODULE=fcitx QT_IM_MODULE=fcitx wine TIM.exe

可以的话再加到快捷方式里
在 desktop 文件的 Exec 中要用 env
env XMODIFIERS=@im=fcitx GTK_IM_MODULE=fcitx QT4_IM_MODULE=fcitx QT_IM_MODULE=fcitx wine TIM.exe

离线

#5 2017-08-30 10:24:25

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,388
个人网站

Re: Fcitx在wine中无法输入

mn_CN 是什么语言?

你的 TIM.exe 里能输入英文吗?

离线

#6 2017-09-02 19:28:18

LuGuoHuas
会员
注册时间: 2017-08-11
帖子: 9

Re: Fcitx在wine中无法输入

就是mn_CN的锅,在局域设置设置因为有个五星红旗选错了。非常感谢你们的帮助。

最近编辑记录 LuGuoHuas (2017-09-04 21:55:03)

离线

页脚