您尚未登录。

#1 2018-01-14 15:12:24

linux40
会员
注册时间: 2015-11-30
帖子: 28

想安装guile-emacs不过遇到了依赖问题。

guile-emacs-git依赖guile4emacs-git。
但guile4emacs的include和lib和guile是重复的,于是我加了一个guile的conflict在guile4emacs-git的PKGBUILD里面。
但是依赖guile的居然有make。。。这删不掉啊。。。
粗略扫了一下,这两个包就bin和info的名字不一样,include和lib都是一样的,怎么让开发者把相关包的依赖改了。。。论坛里有吗。。。

离线

#2 2018-01-15 02:27:49

SilverRainZ
其实不是会员
所在地: Royal Blue Shit Univeristy
注册时间: 2015-05-01
帖子: 105
个人网站

Re: 想安装guile-emacs不过遇到了依赖问题。

给 guile4emacs-git 加一个 provides = ('guile') 就能替换掉 guile 了。

想让开发者改的话到 AUR 上评论啊。

离线

#3 2018-01-15 09:48:00

linux40
会员
注册时间: 2015-11-30
帖子: 28

Re: 想安装guile-emacs不过遇到了依赖问题。

LastAvengers 说:

给 guile4emacs-git 加一个 provides = ('guile') 就能替换掉 guile 了。

想让开发者改的话到 AUR 上评论啊。


仔细看了一下,.so不一样,guile的.go是一样的,需要把目录改了,还是不装了。。。
不过aur那边的话,我选择了时区的,可是date -u那个命令还说我不对,就没注册了。

离线

#4 2018-01-15 11:29:49

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,740
个人网站

Re: 想安装guile-emacs不过遇到了依赖问题。

date -u 是指定了 UTC 啊。你试试 LANG=C date -u?

离线

#5 2018-01-15 14:05:43

linux40
会员
注册时间: 2015-11-30
帖子: 28

Re: 想安装guile-emacs不过遇到了依赖问题。

依云 说:

date -u 是指定了 UTC 啊。你试试 LANG=C date -u?

可能是LANG的原因吧,不过今天注册的时候没叫验证那个问题了,反馈了。

离线

页脚