您尚未登录。

#1 2018-06-03 08:34:38

xztx
会员
注册时间: 2016-02-15
帖子: 40

更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

更新时出现:
错误:无法准备事务处理 (无法满足依赖关系)
:: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'
怎么办?谢谢!

离线

#2 2018-06-03 10:49:49

zsrkmyn
lazy...
注册时间: 2013-05-05
帖子: 307

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

卸载 ffmpeg2.8 呗

离线

#3 2018-06-03 23:39:52

xztx
会员
注册时间: 2016-02-15
帖子: 40

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

zsrkmyn 说:

卸载 ffmpeg2.8 呗

$ sudo pacman -Rs ffmpeg
正在检查依赖关系...
错误:无法准备事务处理 (无法满足依赖关系)
:: audacity:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: chromaprint:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: deepin-music:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: ffmpegthumbnailer:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: firefox:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: kfilemetadata:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: mpv:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: qt5-webengine:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: qtav:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: vlc:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: vokoscreen:移除 ffmpeg 将破坏依赖关系 'ffmpeg'

离线

#4 2018-06-03 23:59:05

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,836
个人网站

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

xztx 说:
zsrkmyn 说:

卸载 ffmpeg2.8

$ sudo pacman -Rs ffmpeg

离线

#5 2018-06-04 00:01:20

xtricman
喵了个咪
注册时间: 2012-12-26
帖子: 514

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

2.8 2.8 2.8!

离线

#6 2018-06-04 09:03:09

xztx
会员
注册时间: 2016-02-15
帖子: 40

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

感谢大家的指导,问题解决了!

离线

#7 2018-06-05 12:56:52

CuminLo
会员
注册时间: 2018-06-05
帖子: 1

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

xztx 说:

感谢大家的指导,问题解决了!


请问怎么解决的?

我这里提示的依赖太多了

sudo pacman -Rs ffmpeg
正在检查依赖关系...
错误:无法准备事务处理 (无法满足依赖关系)
:: chromaprint:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: deepin-screen-recorder:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: electron:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: ffmpegthumbnailer:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: firefox:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: freshplayerplugin-git:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: minidlna:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: mpv:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: qt5-webengine:移除 ffmpeg 将破坏依赖关系 'ffmpeg'

离线

#8 2018-06-05 15:38:28

foodtooth
会员
注册时间: 2016-03-26
帖子: 26

Re: 更新时出现::: ffmpeg2.8:安装 x265 (2.8-1) 将破坏依赖关系 'libx265.so=151-64'

CuminLo 说:
xztx 说:

感谢大家的指导,问题解决了!


请问怎么解决的?

我这里提示的依赖太多了

sudo pacman -Rs ffmpeg
正在检查依赖关系...
错误:无法准备事务处理 (无法满足依赖关系)
:: chromaprint:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: deepin-screen-recorder:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: electron:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: ffmpegthumbnailer:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: firefox:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: freshplayerplugin-git:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: minidlna:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: mpv:移除 ffmpeg 将破坏依赖关系 'ffmpeg'
:: qt5-webengine:移除 ffmpeg 将破坏依赖关系 'ffmpeg'

诶……我来替大佬们,说亲切些吧……注意看上面大佬们的命令。2.8有没有,是不一样的,看红色的2.8,黑粗ffmpeg的提醒

离线

页脚