您尚未登录。

#1 2018-06-20 16:11:20

ianioc
会员
注册时间: 2018-06-20
帖子: 2

各位大佬求助啊;内核升级到4.17;iwlwifi找不到我的无线网卡pci信息了;自己编译iwlwifi模块报错;该怎么办

这个是我的内核信息和无线网卡信息;无线驱动固件已经下载;modinfo iwlwifi找不到我无线网卡的pci信息;怀疑是iwlwifi模块没有无线网卡的pci信息导致固件加载不了;但是自己编译最新的iwlwifi又报错;在4.16的时候自己编译iwlwifi无线网卡可以用;现在回滚需要回滚的又太多了;显卡驱动,内核.xorg都要回滚;该怎么办.....

无线网卡用的是killer 1550.和intel 9260ac一样的芯片组;但是pci信息不一样.

uname -r
4.17.2-1-ARCH

lspci -knn
45:00.0 Network controller [0280]: Intel Corporation Wireless-AC 9260 [8086:2526] (rev 29)
    Subsystem: Bigfoot Networks, Inc. Wireless-AC 9260 [1a56:1550]

lspci -vv
45:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
    Subsystem: Bigfoot Networks, Inc. Wireless-AC 9260
    Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at 9db00000 (64-bit, non-prefetchable) [disabled] [size=16K]
    Capabilities: <access denied>

lspci -n
45:00.0 0280: 8086:2526 (rev 29)

最近编辑记录 ianioc (2018-06-20 16:12:36)

离线

#2 2018-06-20 16:56:18

jouyouyun
会员
注册时间: 2011-10-10
帖子: 256

Re: 各位大佬求助啊;内核升级到4.17;iwlwifi找不到我的无线网卡pci信息了;自己编译iwlwifi模块报错;该怎么办

ianioc 说:

这个是我的内核信息和无线网卡信息;无线驱动固件已经下载;modinfo iwlwifi找不到我无线网卡的pci信息;怀疑是iwlwifi模块没有无线网卡的pci信息导致固件加载不了;但是自己编译最新的iwlwifi又报错;在4.16的时候自己编译iwlwifi无线网卡可以用;现在回滚需要回滚的又太多了;显卡驱动,内核.xorg都要回滚;该怎么办.....

无线网卡用的是killer 1550.和intel 9260ac一样的芯片组;但是pci信息不一样.

uname -r
4.17.2-1-ARCH

lspci -knn
45:00.0 Network controller [0280]: Intel Corporation Wireless-AC 9260 [8086:2526] (rev 29)
    Subsystem: Bigfoot Networks, Inc. Wireless-AC 9260 [1a56:1550]

lspci -vv
45:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
    Subsystem: Bigfoot Networks, Inc. Wireless-AC 9260
    Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at 9db00000 (64-bit, non-prefetchable) [disabled] [size=16K]
    Capabilities: <access denied>

lspci -n
45:00.0 0280: 8086:2526 (rev 29)

只需要装一个 4.16 的内核就可以啊,或者去修复下编译失败的错误

最近编辑记录 jouyouyun (2018-06-20 16:57:25)

离线

#3 2018-06-20 18:06:18

ianioc
会员
注册时间: 2018-06-20
帖子: 2

Re: 各位大佬求助啊;内核升级到4.17;iwlwifi找不到我的无线网卡pci信息了;自己编译iwlwifi模块报错;该怎么办

只需要装一个 4.16 的内核就可以啊,或者去修复下编译失败的错误

有太多的依赖包需要降级啊;怕玩崩了

离线

#4 2018-06-21 09:23:21

jouyouyun
会员
注册时间: 2011-10-10
帖子: 256

Re: 各位大佬求助啊;内核升级到4.17;iwlwifi找不到我的无线网卡pci信息了;自己编译iwlwifi模块报错;该怎么办

ianioc 说:

只需要装一个 4.16 的内核就可以啊,或者去修复下编译失败的错误

有太多的依赖包需要降级啊;怕玩崩了

你装了很多与内核版本相关的包吗?一般情况下内核还是很独立的

离线

#5 2018-06-21 09:26:03

jouyouyun
会员
注册时间: 2011-10-10
帖子: 256

Re: 各位大佬求助啊;内核升级到4.17;iwlwifi找不到我的无线网卡pci信息了;自己编译iwlwifi模块报错;该怎么办

直接安装 linux-lts 然后使用这个内核进入系统,再去编译安装 iwlwifi ,重启后继续使用 linux-lts 进入

离线

页脚