您尚未登录。

#1 2018-11-14 22:11:39

Callopingpig
会员
注册时间: 2018-10-07
帖子: 10

因升级导致pacman无法使用

pacman: /usr/lib/libssl.so.1.1:version “OPENSSL_1_1_1”not found (required by /usr/lib/libcurl.so.4)

离线

#2 2018-11-15 16:57:20

yw662
大会员
注册时间: 2018-10-10
帖子: 114

Re: 因升级导致pacman无法使用

你这比较棘手。。。libcurl依赖libssl但是你没有这个东西,大概率是说你用不了pacman了。。。。。

找个东西pacstrap一下吧


ecmascript是世界上最好的语言

离线

#3 2018-11-15 20:14:04

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,957
个人网站

Re: 因升级导致pacman无法使用

Callopingpig 说:

pacman: /usr/lib/libssl.so.1.1:version “OPENSSL_1_1_1”not found (required by /usr/lib/libcurl.so.4)

部分升级造成的吧。看看 /var/log/pacman.log 都升级了啥,降回去。去 /var/cache/pacman/pkg 里 pacman -U 对应的包文件。
如果你的缓存都没有的话,那从 live 系统进入 Syu 一下吧。

离线

#4 2018-11-15 23:09:38

Callopingpig
会员
注册时间: 2018-10-07
帖子: 10

Re: 因升级导致pacman无法使用

不用整体升级,我今天重新安装最新稳定版的openssl1.1.1就可以了,因为pacman无法使用,所以使用源码安装,感谢网友关心。

离线

#5 2018-11-15 23:14:16

驿窗
YCP
注册时间: 2016-06-03
帖子: 557

Re: 因升级导致pacman无法使用

缺什么补什么?

离线

#6 2018-11-15 23:30:05

Callopingpig
会员
注册时间: 2018-10-07
帖子: 10

Re: 因升级导致pacman无法使用

升级方法如下。 进入root模式,  先去Openssl的官网下载最新稳定版的软件包,然后解压,读里面的readme或install文件,然后照着里面说的做,安装完毕后查看依赖的库软件是否正确加载,ldd /usr/local/openssl/bin/openssl。重新配置软链接,ln -s /usr/local/openssl/lib/libessl.so.1.1  /usr/lib64/libssl.so.1.1,ln -s /usr/local/openssl/lib/libcrypto.so.1.1 /usr/lib64/libcrypto.so.1.1,ln -s /usr/local/openssl/bin/openssl /usr/bin/openssl,ln -s /usr/local/openssl/include/openssl /usr/include/openssl。如果提示文件已存在,把他们删去就可以

离线

#7 2018-11-16 02:38:20

yw662
大会员
注册时间: 2018-10-10
帖子: 114

Re: 因升级导致pacman无法使用

既然libcurl废了你又是怎么下载源码的 (+_+)


ecmascript是世界上最好的语言

离线

#8 2018-11-16 06:01:01

Callopingpig
会员
注册时间: 2018-10-07
帖子: 10

Re: 因升级导致pacman无法使用

在手机上下载,再传入电脑呗

离线

#9 2018-11-16 18:11:53

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,957
个人网站

Re: 因升级导致pacman无法使用

Callopingpig 说:

在手机上下载,再传入电脑呗

那你干嘛不直接下 pkg.tar.xz 包传过去安装呢?

离线

#10 2018-11-16 18:41:42

Remilia
RemiliaForever
注册时间: 2016-03-14
帖子: 49
个人网站

Re: 因升级导致pacman无法使用

这是把Arch当CentOS玩么。。。

离线

页脚