您尚未登录。

#1 2018-02-10 18:41:47

syq7009
会员
注册时间: 2018-02-10
帖子: 3

求助:os-prober安装出错,及多系统启动设置问题。

刚从Debian转过来,按照Wiki安装基本一切顺利,可os-prober安装出错(如下),请问如果os-prober没有安装,能否设置grub多启动?怎么设置?

# pacman -S os-prober
正在解决依赖关系...
正在查找软件包冲突...

软件包 (1) os-prober-1.71-1

下载大小:   0.02 MiB
全部安装大小:  0.05 MiB

:: 进行安装吗? [Y/n] y
:: 正在获取软件包......
os-prober-1.71-1-x86_64                                     16.6 KiB   135K/s 00:00 [################################################] 100%
(1/1) 正在检查密钥环里的密钥                                                         [################################################] 100%
(1/1) 正在检查软件包完整性                                                           [################################################] 100%
错误:os-prober: key "Timothy Redaelli <timothy.redaelli@gmail.com>" is disabled
:: 文件 /var/cache/pacman/pkg/os-prober-1.71-1-x86_64.pkg.tar.xz 已损坏 (无效或已损坏的软件包 (PGP 签名)).
打算删除吗? [Y/n] y
错误:无法提交处理 (无效或已损坏的软件包 (PGP 签名))
发生错误,没有软件包被更新。

最近编辑记录 syq7009 (2018-02-10 18:59:48)

离线

#2 2018-02-10 19:35:42

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,842
个人网站

Re: 求助:os-prober安装出错,及多系统启动设置问题。

os-prober 1.71 已经旧了。最新版是 1.76。
你是不是装的已经不支持了的 i686 版本?

离线

#3 2018-02-10 19:41:16

syq7009
会员
注册时间: 2018-02-10
帖子: 3

Re: 求助:os-prober安装出错,及多系统启动设置问题。

依云 说:

os-prober 1.71 已经旧了。最新版是 1.76。
你是不是装的已经不支持了的 i686 版本?

下载archlinux-2008.02.01-x86_64.iso后装的。

离线

#4 2018-02-10 21:26:31

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 4,842
个人网站

Re: 求助:os-prober安装出错,及多系统启动设置问题。

syq7009 说:
依云 说:

os-prober 1.71 已经旧了。最新版是 1.76。
你是不是装的已经不支持了的 i686 版本?

下载archlinux-2008.02.01-x86_64.iso后装的。

十年前的版本?

离线

#5 2018-02-10 23:08:34

syq7009
会员
注册时间: 2018-02-10
帖子: 3

Re: 求助:os-prober安装出错,及多系统启动设置问题。

依云 说:
syq7009 说:
依云 说:

os-prober 1.71 已经旧了。最新版是 1.76。
你是不是装的已经不支持了的 i686 版本?

下载archlinux-2008.02.01-x86_64.iso后装的。

十年前的版本?

输错了,是archlinux-2018.02.01-x86_64.iso

离线

#6 2018-07-30 14:44:28

dou4cc
会员
注册时间: 2018-07-25
帖子: 7

Re: 求助:os-prober安装出错,及多系统启动设置问题。

我也时不时遇到签章错误, 换软体仓库镜像解决.

离线

页脚