您尚未登录。

#1 2019-09-21 17:56:56

mike
会员
注册时间: 2019-09-21
帖子: 3

wps texstudio不能调用fcitx中文输入,但zim vim firefox octave shell spyder均可

不知道为何,我的fcitx-diagnose诊断信息如下:
# 系统信息:
1.  `uname -a`:

        Linux mike-XPS-13-9350 4.4.0-127-generic #153-Ubuntu SMP Sat May 19 10:58:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

2.  `lsb_release -a`:

        No LSB modules are available.
        Distributor ID:    Ubuntu
        Description:    Ubuntu 16.04 LTS
        Release:    16.04
        Codename:    xenial

3.  `lsb_release -d`:

        Description:    Ubuntu 16.04 LTS

4.  `/etc/lsb-release`:

        DISTRIB_ID=Ubuntu
        DISTRIB_RELEASE=16.04
        DISTRIB_CODENAME=xenial
        DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

5.  `/etc/os-release`:

        NAME="Ubuntu"
        VERSION="16.04 LTS (Xenial Xerus)"
        ID=ubuntu
        ID_LIKE=debian
        PRETTY_NAME="Ubuntu 16.04 LTS"
        VERSION_ID="16.04"
        HOME_URL="http://www.ubuntu.com/"
        SUPPORT_URL="http://help.ubuntu.com/"
        BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
        UBUNTU_CODENAME=xenial

6.  桌面环境:

    桌面环境为 `gnome3`。

7.  Bash 版本:

        BASH_VERSION='4.3.48(1)-release'

# 环境:
1.  DISPLAY:

        DISPLAY=':0'

2.  键盘布局:

    1.  `setxkbmap`:

            xkb_keymap {
                xkb_keycodes  { include "evdev+aliases(qwerty)"    };
                xkb_types     { include "complete"    };
                xkb_compat    { include "complete"    };
                xkb_symbols   { include "pc+us+inet(evdev)"    };
                xkb_geometry  { include "pc(pc105)"    };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us", "", ""

3.  Locale:

    1.  全部可用 locale:

            C
            C.UTF-8
            en_AG
            en_AG.utf8
            en_AU.utf8
            en_BW.utf8
            en_CA.utf8
            en_DK.utf8
            en_GB.utf8
            en_HK.utf8
            en_IE.utf8
            en_IN
            en_IN.utf8
            en_NG
            en_NG.utf8
            en_NZ.utf8
            en_PH.utf8
            en_SG.utf8
            en_US.utf8
            en_ZA.utf8
            en_ZM
            en_ZM.utf8
            en_ZW.utf8
            POSIX
            zh_CN.utf8
            zh_SG.utf8

    2.  当前 locale:

            LANG=zh_CN.UTF-8
            LANGUAGE=zh_CN:en_US:en_AU:en_CA:en
            LC_CTYPE="zh_CN.UTF-8"
            LC_NUMERIC=zh_CN.UTF-8
            LC_TIME=zh_CN.UTF-8
            LC_COLLATE="zh_CN.UTF-8"
            LC_MONETARY=zh_CN.UTF-8
            LC_MESSAGES="zh_CN.UTF-8"
            LC_PAPER=zh_CN.UTF-8
            LC_NAME=zh_CN.UTF-8
            LC_ADDRESS=zh_CN.UTF-8
            LC_TELEPHONE=zh_CN.UTF-8
            LC_MEASUREMENT=zh_CN.UTF-8
            LC_IDENTIFICATION=zh_CN.UTF-8
            LC_ALL=

4.  目录:

    1.  主目录:

            /home/mike

    2.  `${XDG_CONFIG_HOME}`:

        环境变量 `XDG_CONFIG_HOME` 没有设定。

        `XDG_CONFIG_HOME` 的当前值是 `~/.config` (`/home/mike/.config`)。

    3.  Fcitx 设置目录:

        当前 fcitx 设置目录是 `~/.config/fcitx` (`/home/mike/.config/fcitx`)。

5.  当前用户:

    脚本作为 mike (1000) 运行。

# Fcitx 状态:
1.  可执行文件:

    在 `/usr/bin/fcitx` 找到了 fcitx.

2.  版本:

    Fcitx 版本: `4.2.9.1`

3.  进程:

    找到了 2 个 fcitx 进程:

         2978 fcitx
         3015 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` 工作正常.

# Fcitx 配置界面:
1.  配置工具封装:

    在 `/usr/bin/fcitx-configtool` 找到了 fcitx-configtool。

2.  用于 GTK+-2.0 的配置界面:

    **未找到 gtk2 的配置界面.**

3.  用于 GTK+-3.0 的配置界面:

    在 `/usr/bin/fcitx-config-gtk3` 找到了 `fcitx-config-gtk3`。

4.  KDE 的配置界面:

# 前端设置:
## Xim:
1.  `${XMODIFIERS}`:

    环境变量 XMODIFIERS 已经正确地设为了 "@im=fcitx".
    从环境变量中获取的 Xim 服务名称为 fcitx.

2.  根窗口上的 XIM_SERVERS:

    **Xim 服务名称: "ibus" 与环境变量中设置的值 "fcitx" 不同.**

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    环境变量 QT4_IM_MODULE 已经正确地设为了 "fcitx".

2.  qt5 - `${QT_IM_MODULE}`:

    环境变量 QT_IM_MODULE 已经正确地设为了 "fcitx".

3.  Qt 输入法模块文件:
    找到了 Qt4 的输入法模块: `/usr/lib/x86_64-linux-gnu/qt4/plugins/inputmethods/qtim-fcitx.so`.
    找到了 Qt5 的输入法模块: `/usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    环境变量 GTK_IM_MODULE 已经正确地设为了 "fcitx".

2.  `gtk-query-immodules`:

    1.  gtk 2:

        **无法找到 gtk 2 的 `gtk-query-immodules`.**

        **无法找到 gtk 2 的 fcitx 输入法模块.**

    2.  gtk 3:

        **无法找到 gtk 3 的 `gtk-query-immodules`.**

        **无法找到 gtk 3 的 fcitx 输入法模块.**

3.  Gtk 输入法模块缓存:

    1.  gtk 2:

        在 `/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache` 找到了 gtk `2.24.30` 的输入法模块缓存.
        版本行:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0 from gtk+-2.24.30

        已找到 gtk `2.24.30` 的 fcitx 输入法模块.

            "/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so"
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*"

    2.  gtk 3:

        在 `/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache` 找到了 gtk `3.18.9` 的输入法模块缓存.
        版本行:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.18.9

        已找到 gtk `3.18.9` 的 fcitx 输入法模块.

            "/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-fcitx.so"
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*"

4.  Gtk 输入法模块文件:

    1.  gtk 2:

        找到的全部 Gtk 2 输入法模块文件均存在.

    2.  gtk 3:

        找到的全部 Gtk 3 输入法模块文件均存在.

# 配置:
## Fcitx 插件:
1.  插件配置文件目录:

    找到了 fcitx 插件配置目录: `/usr/share/fcitx/addon`.

2.  插件列表:

    1.  找到了 34 个已启用的插件:

            fcitx-autoeng
            fcitx-autoeng-ng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-cloudpinyin
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-fullwidth-char-enhance
            fcitx-googlepinyin
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-lua
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-punc-ng
            fcitx-quickphrase
            fcitx-remote
            fcitx-sogoucloudpinyin
            fcitx-sogoupinyin
            fcitx-spell
            fcitx-sunpinyin
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  找到了 0 个被禁用的插件:

3.  插件库:

    所有插件所需的库都被找到。

4.  用户界面:

    找到了 2 个已启用的用户界面插件:

        fcitx-classic-ui
        fcitx-kimpanel-ui

    Kimpanel 进程:

         3308 sogou-qimpanel

## 输入法:
1.  找到了 8 个启用的输入法:

        fcitx-keyboard-us
        sunpinyin
        pinyin
        shuangpin
        googlepinyin
        sogoupinyin
        wubi
        wbpy

2.  默认输入法:

    您已经正确的将一个键盘输入法 "fcitx-keyboard-us" 设为默认.

# 日志:
1.  `date`:

        2019年 09月 21日 星期六 17:42:01 CST

2.  `~/.config/fcitx/log/`:

        总用量 4
        -rw-rw-r-- 1 mike mike 2264 7月  15 21:24 crash.log

3.  `~/.config/fcitx/log/crash.log`:

        =========================
        FCITX 4.2.9.1 -- Get Signal No.: 6
        Date: try "date -d @1563197082" if you are using GNU date ***
        ProcessID: 4179
        fcitx(+0x162f)[0x563b51bbd62f]
        /lib/x86_64-linux-gnu/libc.so.6(+0x354b0)[0x7fc18ca7a4b0]
        /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x38)[0x7fc18ca7a428]
        /lib/x86_64-linux-gnu/libc.so.6(abort+0x16a)[0x7fc18ca7c02a]
        /lib/x86_64-linux-gnu/libc.so.6(+0x2dbd7)[0x7fc18ca72bd7]
        /lib/x86_64-linux-gnu/libc.so.6(+0x2dc82)[0x7fc18ca72c82]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x58aa7)[0x7fc186067aa7]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x5ae04)[0x7fc186069e04]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0xec9d9)[0x7fc1860fb9d9]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0xecaad)[0x7fc1860fbaad]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0xed707)[0x7fc1860fc707]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x695ff)[0x7fc1860785ff]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x6b505)[0x7fc18607a505]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x330c3)[0x7fc1860420c3]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x38668)[0x7fc186047668]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x2e58f)[0x7fc18603d58f]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x2ca47)[0x7fc18603ba47]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x25d0c)[0x7fc186034d0c]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-sogoupinyin.so(+0x282bf)[0x7fc1860372bf]
        /usr/lib/x86_64-linux-gnu/libfcitx-core.so.0(FcitxInstanceDoInputCallback+0x1ba)[0x7fc18d46b9ca]
        /usr/lib/x86_64-linux-gnu/libfcitx-core.so.0(FcitxInstanceProcessKey+0x651)[0x7fc18d46c0a1]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-ipc.so(+0x5677)[0x7fc1724e7677]
        /lib/x86_64-linux-gnu/libdbus-1.so.3(+0x21813)[0x7fc18bf86813]
        /lib/x86_64-linux-gnu/libdbus-1.so.3(dbus_connection_dispatch+0x3d4)[0x7fc18bf77d94]
        /usr/lib/x86_64-linux-gnu/fcitx/fcitx-dbus.so(+0x2048)[0x7fc18c1b3048]
        /usr/lib/x86_64-linux-gnu/libfcitx-core.so.0(+0x878e)[0x7fc18d45f78e]
        /usr/lib/x86_64-linux-gnu/libfcitx-core.so.0(FcitxInstanceRun+0x210)[0x7fc18d460170]
        fcitx(+0xfec)[0x563b51bbcfec]
        /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7fc18ca65830]
        fcitx(_start+0x29)[0x563b51bbd069]
======================================================

我在~/.profile文件中加入了:
export XIM_PROGRAM="fcitx"                                                                                     
export XMODIFIERS="@im=fcitx"                                                                                     
export GTK_IM_MODULE="fcitx"                                                                                       
export QT_IM_MODULE="fcitx"                                                                                         
export XIM="fcitx"
在wps配置文件/usr/bin/wps文件开头加入了:
#!/bin/bash     
export XMODIFIERS="@im=fcitx"     
export QT_IM_MODULE="fcitx"     
gOpt=   
#gOptExt=-multiply     
gTemplateExt=("wpt" "dot" "dotx" "dotm")
但仍然不见效,跪求大神相助~~~

离线

#2 2019-09-21 18:58:38

luxni
会员
注册时间: 2014-06-08
帖子: 160

Re: wps texstudio不能调用fcitx中文输入,但zim vim firefox octave shell spyder均可

1.  gtk 2:

        **无法找到 gtk 2 的 `gtk-query-immodules`.**

        **无法找到 gtk 2 的 fcitx 输入法模块.**

    2.  gtk 3:

        **无法找到 gtk 3 的 `gtk-query-immodules`.**

        **无法找到 gtk 3 的 fcitx 输入法模块.**

你看下是不是有东西没有装上??

$ pacman -Qs fcitx
local/fcitx 4.2.9.6-2 (fcitx-im)
Flexible Context-aware Input Tool with eXtension
local/fcitx-gtk2 4.2.9.6-2 (fcitx-im)
GTK2 IM Module for fcitx
local/fcitx-gtk3 4.2.9.6-2 (fcitx-im)
GTK3 IM Module for fcitx
local/fcitx-qt4 4.2.9.6-1 (fcitx-im)
Qt4 IM Module for fcitx
local/fcitx-qt5 1.2.3-10 (fcitx-im)
Qt5 IM Module for Fcitx
local/kcm-fcitx 0.5.5-2
KDE Config Module for Fcitx

离线

#3 2019-09-21 19:30:17

mike
会员
注册时间: 2019-09-21
帖子: 3

Re: wps texstudio不能调用fcitx中文输入,但zim vim firefox octave shell spyder均可

luxni 说:

1.  gtk 2:

        **无法找到 gtk 2 的 `gtk-query-immodules`.**

        **无法找到 gtk 2 的 fcitx 输入法模块.**

    2.  gtk 3:

        **无法找到 gtk 3 的 `gtk-query-immodules`.**

        **无法找到 gtk 3 的 fcitx 输入法模块.**

你看下是不是有东西没有装上??

$ pacman -Qs fcitx
local/fcitx 4.2.9.6-2 (fcitx-im)
Flexible Context-aware Input Tool with eXtension
local/fcitx-gtk2 4.2.9.6-2 (fcitx-im)
GTK2 IM Module for fcitx
local/fcitx-gtk3 4.2.9.6-2 (fcitx-im)
GTK3 IM Module for fcitx
local/fcitx-qt4 4.2.9.6-1 (fcitx-im)
Qt4 IM Module for fcitx
local/fcitx-qt5 1.2.3-10 (fcitx-im)
Qt5 IM Module for Fcitx
local/kcm-fcitx 0.5.5-2
KDE Config Module for Fcitx

这个pacman命令打开的是 吃豆人游戏啊。下面的信息是怎么出来的??

离线

#4 2019-09-21 19:57:27

luxni
会员
注册时间: 2014-06-08
帖子: 160

Re: wps texstudio不能调用fcitx中文输入,但zim vim firefox octave shell spyder均可

emmmmmm ,不好意思,没有仔细看,原来是ubuntu。

你应该在 “其他发行版” 处发贴。

你可以使用ubuntu的包管理器搜索下。

因为不知道你是怎么安装fcitx的,所以我只能去ubuntu官网搜索找找,

下面是关于fcitx gtk 的依赖,你看下自己安装了没。

fcitx-config-gtk
fcitx-config-gtk2
fcitx-frontend-gtk2
fcitx-frontend-gtk3

最近编辑记录 luxni (2019-09-21 19:59:17)

离线

#5 2019-09-22 12:18:27

依云
性别女,谢绝一切男性化称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,393
个人网站

Re: wps texstudio不能调用fcitx中文输入,但zim vim firefox octave shell spyder均可

**Xim 服务名称: "ibus" 与环境变量中设置的值 "fcitx" 不同.**

离线

#6 2019-09-22 14:20:29

mike
会员
注册时间: 2019-09-21
帖子: 3

Re: wps texstudio不能调用fcitx中文输入,但zim vim firefox octave shell spyder均可

依云 说:

**Xim 服务名称: "ibus" 与环境变量中设置的值 "fcitx" 不同.**

Xim 服务名称: "ibus" 与环境变量中设置的值 "fcitx" 不同.
鉴于你在使用 GNOME 3,试试如下命令
gsettings set org.gnome.settings-daemon.plugins.keyboard active false
原理就是,GNOME 3 要养它家的 ibus,排挤其它输入法框架。
GNOME3.8集成了iBus,我们需要禁用iBus模块

这是在其他帖子上看到您给出的解决方案,但是我在我的shell中键入如下命令
gsettings set org.gnome.settings-daemon.plugins.keyboard active false
还是无效啊,求助!!!

离线

页脚