您尚未登录。

#1 2020-04-21 21:54:06

NaCl_cn
会员
注册时间: 2020-04-21
帖子: 9

求助,BricsCAD运行的问题

运行BricsCAD时,系统提示./bricscad: /home/nacl/builds/CAD/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)
在网上查了一下,都是很老的帖子,说是要把libpng降级到1.6.28。那么问题来了,首先是我不知道怎么降级安装,第二这个1.6.28的版本似乎太老了吧,担心真的降级了以后会影响其他的软件运行。求大神帮助,感谢感谢~~~

离线

#2 2020-04-21 21:56:19

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,034
个人网站

Re: 求助,BricsCAD运行的问题

这个软件是自己带了一部分库么……

离线

#3 2020-04-21 22:39:16

NaCl_cn
会员
注册时间: 2020-04-21
帖子: 9

Re: 求助,BricsCAD运行的问题

依云 说:

这个软件是自己带了一部分库么……

是的,但是libpng是系统自己的库

离线

#4 2020-04-22 00:54:11

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,034
个人网站

Re: 求助,BricsCAD运行的问题

真糟糕……那你自己编译一个它需要的 libpng 版本吧。不过它带了库文件,有没有带对应的头文件呢?

离线

#5 2020-04-23 21:55:48

NaCl_cn
会员
注册时间: 2020-04-21
帖子: 9

Re: 求助,BricsCAD运行的问题

依云 说:

真糟糕……那你自己编译一个它需要的 libpng 版本吧。不过它带了库文件,有没有带对应的头文件呢?

是libpng提示他要求的zlib版本不对,他要求的zlib版本比我现在的低。。。。

离线

#6 2020-04-23 23:05:35

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,034
个人网站

Re: 求助,BricsCAD运行的问题

是它自带了 zlib 没带 libpng,于是用的系统的 libpng 和它自带的 zlib,然而这个 zlib 太旧了。

离线

#7 2020-04-25 13:55:52

NaCl_cn
会员
注册时间: 2020-04-21
帖子: 9

Re: 求助,BricsCAD运行的问题

./bricscad: /home/nacl/builds/CAD/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)
[nacl@NaClhp CAD]$ sudo pacman -Q zlib
zlib 1:1.2.11-4
[nacl@NaClhp CAD]$ sudo pacman -Q libpng
libpng 1.6.37-1

离线

#8 2020-04-26 19:36:16

NaCl_cn
会员
注册时间: 2020-04-21
帖子: 9

Re: 求助,BricsCAD运行的问题

依云 说:

是它自带了 zlib 没带 libpng,于是用的系统的 libpng 和它自带的 zlib,然而这个 zlib 太旧了。

感谢,感谢,问题解决了。
首先是下载了 zlib1.2.9重新编译安装了。另外,还要把软件自带的库替换掉。软件带的库都比较老。

离线

#9 2020-12-03 08:18:58

gaaraljh
会员
注册时间: 2020-12-02
帖子: 1

Re: 求助,BricsCAD运行的问题

直接删除这个文件就行了。

离线

页脚