您尚未登录。

#1 2020-09-06 00:23:34

xQmQ
会员
注册时间: 2020-08-24
帖子: 34
个人网站

[已解决]尝试禁用独显导致开机异常

本人笔记本电脑系统为windows10+arch Linux,为了在arch Linux下禁用独显,Windows10下开启独显,根据网上教程进行了操作,重新启动以后无法进入lightdm启动界面

硬件配置:
Intel UHD Graphics 630 + NVIDIA GEFORCE GTX1050Ti

驱动安装:
在安装显卡驱动时安装了 xf86-video-intel 和 mesa ,未安装独显驱动

执行操作:
根据教程 (https://www.joxrays.com/linux-ban-nvidia/)执行了相关操作
(个人认为问题出在了将nouveau列入黑名单这步操作上)

故障描述:
重启arch Linux后卡在了  /dev/sda3: clean ... files,... blocks  界面,一直无法进入lightdm启动界面

个人想法:
根据wiki,nouveau是一个NVIDIA显卡开源驱动,但是我没有安装这个驱动,导致在如网上教程所说将nouveau列入黑名单时,arch无法执行相关操作,才一直卡在  /dev/sda3: clean ... files,... blocks  界面

想请教大家一下,我的想法对不对;对的话应该如何操作,挽救一下系统(好不容易配置好的不想重来了)
非常感谢

最近编辑记录 xQmQ (2020-09-06 09:21:00)

离线

#2 2020-09-06 00:31:51

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,419
个人网站

Re: [已解决]尝试禁用独显导致开机异常

你的想法不对。
没特别的原因的话,不用装 xf86-video-intel。
如果你没有做配置的话,Xorg 应该会跑在 Intel 显卡上才对。
去看 Xorg 的日志,大概在 /var/log/Xorg.0.log。

离线

#3 2020-09-06 09:20:15

xQmQ
会员
注册时间: 2020-08-24
帖子: 34
个人网站

Re: [已解决]尝试禁用独显导致开机异常

依云 说:

你的想法不对。
没特别的原因的话,不用装 xf86-video-intel。
如果你没有做配置的话,Xorg 应该会跑在 Intel 显卡上才对。
去看 Xorg 的日志,大概在 /var/log/Xorg.0.log。

早上进行了修复,成功回来了。感谢大佬的帮助

离线

#4 2020-10-01 00:41:01

yueuyln
会员
注册时间: 2020-10-01
帖子: 11

Re: [已解决]尝试禁用独显导致开机异常

我好像也是这个问题,请问怎么解决的,谢谢

离线

#5 2020-10-01 16:57:14

yueuyln
会员
注册时间: 2020-10-01
帖子: 11

Re: [已解决]尝试禁用独显导致开机异常

已经接触,这里ctrl+alt+f2, 再删除之前安装的驱动, pacman -R xxxxx  ,重新安装  nvidia nvidia-utlis nvidia-prime ,修改下配置文件就可以了。具体的可以看狐狸姐姐的博客有一篇,https://blog.lilydjwg.me/2019/9/3/nvidia-prime-setup.214768.html。

yueuyln 说:

我好像也是这个问题,请问怎么解决的,谢谢

离线

页脚