您尚未登录。

#1 2020-10-01 13:32:35

布丁酱
Arch!Arch!Arch!
所在地: 成都
注册时间: 2020-07-27
帖子: 186
个人网站

python2-pyqt5的依赖问题

今日滚动又遇到依赖问题,自己尝试解决失败,寻求社区帮助


╰─❯ yay                                                                                                                                                                                                                                     ─╯
:: 正在同步软件包数据库...
core 已经是最新版本
extra 已经是最新版本
community 已经是最新版本
multilib 已经是最新版本
blackarch 已经是最新版本
archlinuxcn 已经是最新版本
repo-ck 已经是最新版本
:: 正在进行全面系统更新...
警告:python-pystache:本地 (1:0.5.4-7) 比 community 的版本更新 (0.5.4-8)
正在解析依赖关系...
警告:无法解决 "pyqt5-common","python2-pyqt5" 的一个依赖关系
:: 因为无法解决依赖关系,以下软件包无法进行更新:
      python2-pyqt5

:: 您想在本次更新中跳过上述软件包吗? [y/N] y
正在查找软件包冲突...
今日无事可做
:: Searching databases for updates...
:: Searching AUR for updates...
-> python-pystache: local (1:0.5.4-7) is newer than community (0.5.4-8)
-> texlive-most-doc: local (20200913-1) is newer than AUR (20200622-1)
-> Missing AUR Packages:  extundelete  lx-music-desktop
-> Flagged Out Of Date AUR Packages:  mininet
:: 2 Packages to upgrade.
2  blackarch/python2-pyqt5  5.15.1-1      -> 5.15.2-1
1  aur/deepin-wine-tim      3.1.0.21789-1 -> 3.2.0.21856-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==>
-> Could not find all required packages:
    pyqt5-common (Wanted by: python2-pyqt5)
╭─   ~                                                                                                                                                                                                           took  15s at  13:31:08 ─╮
╰─❯                         




╭─   ~                                                                                                                                                                                                                      at  13:31:35 ─╮
╰─❯ yay -S python2-pyqt5                                                                                                                                                                                                                    ─╯
正在解析依赖关系...
警告:无法解决 "pyqt5-common","python2-pyqt5" 的一个依赖关系
:: 因为无法解决依赖关系,以下软件包无法进行更新:
      python2-pyqt5

:: 您想在本次更新中跳过上述软件包吗? [y/N] n
错误:无法准备事务处理 (无法满足依赖关系)
:: 无法满足依赖 'pyqt5-common' (python2-pyqt5 需要)
error installing repo packages
╭─   ~                                                                                                                                                                                                            took  6s at  13:31:50 ─╮
╰─❯                   



╭─   ~                                                                                                                                                                                                            took  6s at  13:31:50 ─╮
╰─❯ yay -S pyqt5-common                                                                                                                                                                                                                     ─╯
-> Could not find all required packages:
    pyqt5-common (Target)
╭─   ~                                                                                                                                                                                                                      at  13:32:16 ─╮
╰─❯


布丁酱是菜鸡,没毛病,他是菜鸡:)

离线

#2 2020-10-01 18:16:46

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,615
个人网站

Re: python2-pyqt5的依赖问题

python2-pyqt5 没啦。pyqt5-common 合并到 python-pyqt5 中去了。

离线

#3 2020-10-01 18:49:23

布丁酱
Arch!Arch!Arch!
所在地: 成都
注册时间: 2020-07-27
帖子: 186
个人网站

Re: python2-pyqt5的依赖问题

收到,谢谢云云哥


布丁酱是菜鸡,没毛病,他是菜鸡:)

离线

页脚