您尚未登录。

#1 2020-10-21 19:38:22

cuipo123
会员
注册时间: 2020-10-21
帖子: 2

[已解决] archlinux 开机灰屏卡住,进入不了GDM,也无法切换tty登录

环境是archlinux+gnome+gdm

每天晚上回来第一次开机就出现标题症状,关掉再重启就能进gnome了。再重启又会出现这情况,除非先关机再开机才能进去。

以下是xorg日志:

[     5.592] (--) Log file renamed from "/var/log/Xorg.pid-475.log" to "/var/log/Xorg.0.log"
[     5.592] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[     5.592] 
X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
[     5.593] Build Operating System: Linux Arch Linux
[     5.593] Current Operating System: Linux hm 5.8.14-arch1-1 #1 SMP PREEMPT Wed, 07 Oct 2020 23:59:46 +0000 x86_64
[     5.593] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=04952d52-ad51-41c3-bd2f-44f003add22a rw loglevel=3
[     5.593] Build Date: 02 September 2020  06:17:44AM
[     5.593]  
[     5.593] Current version of pixman: 0.40.0
[     5.593] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[     5.593] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     5.593] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 21 18:30:34 2020
[     5.594] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     5.594] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     5.594] (==) No Layout section.  Using the first Screen section.
[     5.594] (==) No screen section available. Using defaults.
[     5.594] (**) |-->Screen "Default Screen Section" (0)
[     5.594] (**) |   |-->Monitor "<default monitor>"
[     5.594] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[     5.594] (==) Automatically adding devices
[     5.594] (==) Automatically enabling devices
[     5.594] (==) Automatically adding GPU devices
[     5.594] (==) Automatically binding GPU devices
[     5.594] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     5.595] (WW) The directory "/usr/share/fonts/misc" does not exist.
[     5.595] 	Entry deleted from font path.
[     5.595] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     5.595] 	Entry deleted from font path.
[     5.595] (==) FontPath set to:
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[     5.595] (==) ModulePath set to "/usr/lib/xorg/modules"
[     5.595] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[     5.595] (II) Module ABI versions:
[     5.595] 	X.Org ANSI C Emulation: 0.4
[     5.595] 	X.Org Video Driver: 24.1
[     5.595] 	X.Org XInput driver : 24.1
[     5.595] 	X.Org Server Extension : 10.0
[     5.596] (++) using VT number 1

[     5.597] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[     5.598] (--) PCI:*(6@0:0:0) 1002:731f:1da2:e416 rev 202, Mem @ 0x40000000/268435456, 0x50000000/2097152, 0x50300000/524288, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[     5.598] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     5.598] (II) LoadModule: "glx"
[     5.598] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     5.599] (II) Module glx: vendor="X.Org Foundation"
[     5.599] 	compiled for 1.20.9, module version = 1.0.0
[     5.599] 	ABI class: X.Org Server Extension, version 10.0
[     5.599] (==) Matched ati as autoconfigured driver 0
[     5.599] (==) Matched modesetting as autoconfigured driver 1
[     5.599] (==) Matched fbdev as autoconfigured driver 2
[     5.599] (==) Matched vesa as autoconfigured driver 3
[     5.599] (==) Assigned the driver to the xf86ConfigLayout
[     5.599] (II) LoadModule: "ati"
[     5.600] (WW) Warning, couldn't open module ati
[     5.600] (EE) Failed to load module "ati" (module does not exist, 0)
[     5.600] (II) LoadModule: "modesetting"
[     5.600] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     5.600] (II) Module modesetting: vendor="X.Org Foundation"
[     5.601] 	compiled for 1.20.9, module version = 1.20.9
[     5.601] 	Module class: X.Org Video Driver
[     5.601] 	ABI class: X.Org Video Driver, version 24.1
[     5.601] (II) LoadModule: "fbdev"
[     5.601] (WW) Warning, couldn't open module fbdev
[     5.601] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.601] (II) LoadModule: "vesa"
[     5.601] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[     5.601] (II) Module vesa: vendor="X.Org Foundation"
[     5.601] 	compiled for 1.20.9, module version = 2.5.0
[     5.601] 	Module class: X.Org Video Driver
[     5.601] 	ABI class: X.Org Video Driver, version 24.1
[     5.601] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     5.601] (II) VESA: driver for VESA chipsets: vesa
[     5.601] (EE) o pen/dev/dri/card0: No such file or directory
[     5.601] (WW) Falling back to old probe method for modesetting
[     5.601] (EE) open /dev/dri/card0: No such file or directory
[     5.601] vesa: Refusing to run on UEFI
[     5.601] (EE) Screen 0 deleted because of no matching config section.
[     5.601] (II) UnloadModule: "modesetting"
[     5.601] (EE) Device(s) detected, but none match those in the config file.
[     5.601] (EE) 
Fatal server error:
[     5.601] (EE) no screens found(EE) 
[     5.601] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[     5.601] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     5.601] (EE) 
[     5.601] (EE) Server terminated with error (1). Closing log file.

新手碰到这问题一头雾水,求大佬帮忙分析下

最近编辑记录 cuipo123 (2020-11-08 18:55:39)

离线

#2 2020-10-21 19:43:02

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,216
个人网站

Re: [已解决] archlinux 开机灰屏卡住,进入不了GDM,也无法切换tty登录

尝试用 vesa 去了……应该是开机加载内核的显示驱动动作慢了一步。你可以去把你的显卡对应的内核模块加到 /etc/mkinitcpio.conf 里以便尽早加载。记得改好后执行 mkinitcpio -P 重新生成 initramfs 文件。

在线

#3 2020-10-21 20:04:27

cuipo123
会员
注册时间: 2020-10-21
帖子: 2

Re: [已解决] archlinux 开机灰屏卡住,进入不了GDM,也无法切换tty登录

照大佬说的操作,问题已解决,感谢大佬。

离线

#4 2021-01-16 22:31:47

吃过没看
会员
注册时间: 2021-01-14
帖子: 3

Re: [已解决] archlinux 开机灰屏卡住,进入不了GDM,也无法切换tty登录

我的问题表现和楼主类似,仅仅是略有不同,但是 log 日志是一样的。故根据大佬的建议,一顿尝试之后,终于把问题解决了。多谢大佬,同时补充一下我的问题表现以及解决方式,以供同样问题的人参考。


机型:yoga14s 2021 ADM R7 4800H 锐龙版的, 显卡也是amd的,安装的显卡驱动是 xf86-video-amdgpu

我的表现如下:
1.进入系统后,左上角光标闪烁,整个页面黑屏
2.通过切换tty,如:ctrl + alt + tty2(其他的tty也可以),登录与否均可,再次切回到 tty1,这时会展示登录页面,后续就是普通的登录了
3.如果设置为自动登录,那么就不会有 光标闪烁这个页面,可以顺利显示桌面。


解决方式:

vim   /etc/mkinitcpio.conf

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(amdgpu)                            # 这里!!!在这里增加 amdgpu, 不是 xf86-video-admgpu

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()
.....


:wq
mkinitcpio -P



原因如下:

https://wiki.archlinux.org/index.php/Xo … %E6%96%87)

Xorg 会自动搜索安装的驱动:

如果无法找到设备在下表中列出的驱动,会首先查看是否安装了 fbdev (xf86-video-fbdev).
如果依然没有找到,会搜索 vesa (xf86-video-vesa), 这是一个支持大部分显卡的通用驱动,不提供任何 2D 和 3D 加速功能。
如果没有找到 vesa,Xorg 会使用 kernel mode setting, 这个驱动提供了 GLAMOR 加速 (参考 modesetting(4)).
要充分发挥显卡性能,请按下表安装驱动程序。推荐先使用开源驱动,这些驱动出问题的可能性较小。

最近编辑记录 吃过没看 (2021-01-16 22:42:38)

离线

页脚