您尚未登录。

#1 2020-11-12 22:35:12

黎小木
会员
注册时间: 2020-11-12
帖子: 4

安装 arch linux+windows双系统后丢失无线网卡

电脑型号 联想拯救者R7000
无线网卡型号 intel AX200
处理器型号 AMD 4800H
linux安装完成后,安装了KDE桌面并添加了启动项,但是运行Linux系统时tty1一直卡在starting vision界面(直接从grub进来就是,没有输入账户和密码)
有几次凑巧进入KDE桌面时,第一次进入成功连接了无线网络(无线网卡没出问题)
设置了字体重启后进入KDE桌面就丢失了无线网卡,而且进入KDE极不稳定,通过tty重新设置了启动项,但打开Windows后就发现系统丢失了无线网卡,在设备管理器和驱动管理界面都没有检测到网卡插入

离线

#2 2020-11-16 12:44:04

savvvygh
会员
注册时间: 2014-02-16
帖子: 144

Re: 安装 arch linux+windows双系统后丢失无线网卡

应该是老问题了,windows10的关机问题。不要关机,重启windows10试试。

离线

#3 2020-11-16 20:55:25

黎小木
会员
注册时间: 2020-11-12
帖子: 4

Re: 安装 arch linux+windows双系统后丢失无线网卡

savvvygh 说:

应该是老问题了,windows10的关机问题。不要关机,重启windows10试试。

emmmm,我设置安全启动下,没有效果。拯救者R7000主板开机默认关闭网卡,所以在装的时候经常用rfkill unblock wifi指令打开无线网卡开关,等装好了之后安装了KDE桌面,卡在了starting vision 页面停了,然后有一次在卡进去的时候一直按enter键进去了,无线网卡还是好的,但是更改系统语言重启后就显示没有无线网卡。然后再也进不去jde桌面,我打开windows后发现windows也丢失了无线网卡,并在设备管理器下没有发现AX200网卡模块,而arch通过iwd指令检测网卡模块也没有,目前还没有拿到售后进行硬件检测,想知道是不是软件问题。我问了一个学计科专业的同学,他说可能是安装的软件覆盖了无线网卡模块,本人不是学计算机专业的。如果是软件的问题,直接在windows下格式化linux分区有没有效果?

离线

#4 2020-11-16 22:06:32

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,661
个人网站

Re: 安装 arch linux+windows双系统后丢失无线网卡

黎小木 说:
savvvygh 说:

应该是老问题了,windows10的关机问题。不要关机,重启windows10试试。

emmmm,我设置安全启动下,没有效果。拯救者R7000主板开机默认关闭网卡,所以在装的时候经常用rfkill unblock wifi指令打开无线网卡开关,等装好了之后安装了KDE桌面,卡在了starting vision 页面停了,然后有一次在卡进去的时候一直按enter键进去了,无线网卡还是好的,但是更改系统语言重启后就显示没有无线网卡。然后再也进不去jde桌面,我打开windows后发现windows也丢失了无线网卡,并在设备管理器下没有发现AX200网卡模块,而arch通过iwd指令检测网卡模块也没有,目前还没有拿到售后进行硬件检测,想知道是不是软件问题。我问了一个学计科专业的同学,他说可能是安装的软件覆盖了无线网卡模块,本人不是学计算机专业的。如果是软件的问题,直接在windows下格式化linux分区有没有效果?

再 rfkill 看一下呢?

在线

#5 2020-11-17 02:15:23

黎小木
会员
注册时间: 2020-11-12
帖子: 4

Re: 安装 arch linux+windows双系统后丢失无线网卡

依云 说:
黎小木 说:
savvvygh 说:

应该是老问题了,windows10的关机问题。不要关机,重启windows10试试。

emmmm,我设置安全启动下,没有效果。拯救者R7000主板开机默认关闭网卡,所以在装的时候经常用rfkill unblock wifi指令打开无线网卡开关,等装好了之后安装了KDE桌面,卡在了starting vision 页面停了,然后有一次在卡进去的时候一直按enter键进去了,无线网卡还是好的,但是更改系统语言重启后就显示没有无线网卡。然后再也进不去jde桌面,我打开windows后发现windows也丢失了无线网卡,并在设备管理器下没有发现AX200网卡模块,而arch通过iwd指令检测网卡模块也没有,目前还没有拿到售后进行硬件检测,想知道是不是软件问题。我问了一个学计科专业的同学,他说可能是安装的软件覆盖了无线网卡模块,本人不是学计算机专业的。如果是软件的问题,直接在windows下格式化linux分区有没有效果?

再 rfkill 看一下呢?

问题在于现在iwd模式都检测不到网卡,也就是说,根本没有这玩意。rfkill当然试过,不顶用了才发现无线网卡消失了。

离线

#6 2020-11-17 08:55:13

布丁酱
Arch!Arch!Arch!
所在地: 成都
注册时间: 2020-07-27
帖子: 188
个人网站

Re: 安装 arch linux+windows双系统后丢失无线网卡

win10 cmd shutdown -s -t 0
重启换系统


布丁酱是菜鸡,没毛病,他是菜鸡:)

离线

#7 2021-03-03 10:27:31

IZAY01
会员
所在地: Beijing
注册时间: 2021-03-02
帖子: 3
个人网站

Re: 安装 arch linux+windows双系统后丢失无线网卡

savvvygh 说:

应该是老问题了,windows10的关机问题。不要关机,重启windows10试试。

我装双系统也发现了,Windows10 和 Archlinux 在一定程度上会相互影响。比如 Archlinux 下的一些驱动故障(例如触控板)可以由正常状态的 Windows 直接重启到 Archlinux 解决。而关机再开机到 Archlinux 则会出现如触控板等无法驱动的故障。
其实我一直比较好奇,为什么双系统竟然是会互相影响的 —— 感觉比较反(我曾经的)直觉

离线

#8 2021-03-03 11:09:22

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,661
个人网站

Re: 安装 arch linux+windows双系统后丢失无线网卡

IZAY01 说:

我装双系统也发现了,Windows10 和 Archlinux 在一定程度上会相互影响。比如 Archlinux 下的一些驱动故障(例如触控板)可以由正常状态的 Windows 直接重启到 Archlinux 解决。而关机再开机到 Archlinux 则会出现如触控板等无法驱动的故障。
其实我一直比较好奇,为什么双系统竟然是会互相影响的 —— 感觉比较反(我曾经的)直觉

因为你的 Windows 10 在你点击「关机」时,并没有真正地关机,而只是休眠,等待下一次唤醒,所以一些硬件状态并不会重置。等你启动到 Linux,Linux 就懵了。
和 Windows 10 双系统时,你要么使用「重启」代替「关机」(那个是真的重启),要么去设置里关闭「快速启动」选项(不过和 UTC 时钟一样,我设置了,但是好像没能生效)。

在线

#9 2021-03-03 17:30:28

黎小木
会员
注册时间: 2020-11-12
帖子: 4

Re: 安装 arch linux+windows双系统后丢失无线网卡

依云 说:
IZAY01 说:

我装双系统也发现了,Windows10 和 Archlinux 在一定程度上会相互影响。比如 Archlinux 下的一些驱动故障(例如触控板)可以由正常状态的 Windows 直接重启到 Archlinux 解决。而关机再开机到 Archlinux 则会出现如触控板等无法驱动的故障。
其实我一直比较好奇,为什么双系统竟然是会互相影响的 —— 感觉比较反(我曾经的)直觉

因为你的 Windows 10 在你点击「关机」时,并没有真正地关机,而只是休眠,等待下一次唤醒,所以一些硬件状态并不会重置。等你启动到 Linux,Linux 就懵了。
和 Windows 10 双系统时,你要么使用「重启」代替「关机」(那个是真的重启),要么去设置里关闭「快速启动」选项(不过和 UTC 时钟一样,我设置了,但是好像没能生效)。

我拿到售后了,售后直接给我重装了原厂windows,然后就找到了。我再次安装linux后发现同样的问题都没出,包括kde桌面的问题。咨询了一个更专业的人后,应该是在系统分区时arch的缓存分区和windows重叠,最后把网卡的驱动覆盖掉了,人建议我装的时候尽可能不要选择双系统,虚拟机和外挂pe都没这个问题。pe是将arch的全部放在可移动设备上,就不存在覆盖。
其实我感觉,售后就是进windows然后点了和恢复出厂,一点技术含量都没有。。。。。

离线

#10 2021-03-03 18:52:55

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,661
个人网站

Re: 安装 arch linux+windows双系统后丢失无线网卡

黎小木 说:

我拿到售后了,售后直接给我重装了原厂windows,然后就找到了。我再次安装linux后发现同样的问题都没出,包括kde桌面的问题。咨询了一个更专业的人后,应该是在系统分区时arch的缓存分区和windows重叠,最后把网卡的驱动覆盖掉了,人建议我装的时候尽可能不要选择双系统,虚拟机和外挂pe都没这个问题。pe是将arch的全部放在可移动设备上,就不存在覆盖。
其实我感觉,售后就是进windows然后点了和恢复出厂,一点技术含量都没有。。。。。

什么乱七八糟的,分区重叠能精确地覆盖掉特定的文件?
可能售后给你装的 Windows 关闭了「快速启动」功能(或者由于某些原因 Windows 没有启动这个功能)。

Windows 那边的驱动更完善,它可以让硬件从那种休眠状态中恢复,Linux 的不行。

在线

页脚