您尚未登录。

#1 2020-12-02 15:21:17

importcjj
会员
注册时间: 2020-12-02
帖子: 6

安装完成之后重启,直接进入bios

纯新手,跟着wiki中的安装指南安装的,没有任何报错。尝试了多次,每次都是重启后进入bios,貌似是找不到系统,后来换了一块老的macbook拆下的固态也一样。

不过在virtualbox中尝试安装一次成功。。。

开始怀疑硬盘有问题,但是发现可以安装centos,有没有大佬可以指导一下。

相关硬件:
硬盘:闪迪的1tb固态
主板:微星

离线

#2 2020-12-02 15:24:04

importcjj
会员
注册时间: 2020-12-02
帖子: 6

Re: 安装完成之后重启,直接进入bios

uefi模式

分区情况
/dev/nvme0n1p1   550M  EFI
/dev/nvme0n1p2   3G       Linux swap
/dev/nvme0n1p3               Linux fs

离线

#3 2020-12-02 15:29:24

importcjj
会员
注册时间: 2020-12-02
帖子: 6

Re: 安装完成之后重启,直接进入bios

grub这部分
mount /dev/nvme0n1p1 /boot/EFI
grub-install --target=x86_64-efi  --bootloader-id=grub_uefi --recheck

离线

#4 2020-12-02 16:22:22

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,615
个人网站

Re: 安装完成之后重启,直接进入bios

执行「efibootmgr」看看输出。

离线

#5 2020-12-02 16:44:47

importcjj
会员
注册时间: 2020-12-02
帖子: 6

Re: 安装完成之后重启,直接进入bios

依云 说:

执行「efibootmgr」看看输出。

我现在还在重新尝试中,不过我发现了一个现象

grub-install之后efibootmgr输出里是有grub-uefi这一项的
大概是
Boot0000*  grub-uefi
Boot0001* CentOs Linux
...

但是reboot之后就没有这个启动项了
再通过安装盘,重新挂载进入,然后efibootmgr输出里也没有grub-uefi了

离线

#6 2020-12-02 16:51:27

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,615
个人网站

Re: 安装完成之后重启,直接进入bios

那就是引导项没写进去?主板 bug?

离线

#7 2020-12-02 16:54:10

importcjj
会员
注册时间: 2020-12-02
帖子: 6

Re: 安装完成之后重启,直接进入bios

依云 说:

那就是引导项没写进去?主板 bug?

那就操蛋了,但是我的centos是后安装的,就很顺利的安装完成了,也能启动

离线

#8 2020-12-02 18:14:25

importcjj
会员
注册时间: 2020-12-02
帖子: 6

Re: 安装完成之后重启,直接进入bios

依云 说:

那就是引导项没写进去?主板 bug?

放弃GRUB了 改用systemd-boot成功启动了。感谢帮忙哈,谢谢

离线

#9 2020-12-04 13:36:11

uihe
会员
注册时间: 2014-09-26
帖子: 15

Re: 安装完成之后重启,直接进入bios

分区看看,用EFI的话,EFI要放到FAT32上

离线

页脚