您尚未登录。

#1 2021-03-29 11:19:04

atmouse
会员
注册时间: 2011-08-24
帖子: 701

【已解决】sway使用EGL会导致图形崩溃

硬件是intel i7-6700k, i915
简单说就是,开机启动的3分钟内,感觉是只要使用gpu的进程,该进程就会挂掉连sway都会挂掉,回到tty,然后多重试几次进sway,开chromium,大概几次之后就不会崩溃了。dmesg没有任何提示

内核 Linux  5.11.0-1-optiplex #79 SMP PREEMPT Thu, 18 Feb 2021 05:46:13 +0000 x86_64 GNU/Linux,这个内核编译比较久了,之前没出现,就最近出现了
启动 sway,然后启动vulkaninfo,或者chromium 都会崩溃,chromium 由于是用 systemctl --user 启动的,可以看到 挂掉之前的stderr是什么 cannot connect to display device

几乎所有app包都是官方包,而有一些aur编译的包都是老早前编译的,应该没关系,以下这些都不是最近编译的。
```
pacman -Qm
anbox-git 1:r1335.2b39153-1
anbox-image-houdini 2018.07.19-5
cfssl 1.5.0-1
efistub-wrapper 0-1
evhz-git r27.3b65648-1
frpc 0.29.1-1
frps 0.29.1-1
google-cloud-sdk 319.0.0-1
libsmi 0.5.0-2
linux-firmware-intel-ipts r452.10a5083db-1
linux-megx570 5.10-1
linux-megx570-headers 5.10-1
linux-optiplex 5.11-1
linux-optiplex-headers 5.11-1
linux-surface3 5.8.13-1
linux-surface3-headers 5.8.13-1
lxc-git 1:4.0.5-1
oguri-git r112.d6f195a-1
otp-uinput 0.2.1-1
preloader-signed 20130208-1
properties-cpp 0.0.1-1
redshift-wayland-git 1.12.r25.g7da875d-1
ryzen-stabilizator-git r19.90a2f7a-1
scrcpy 1.16-1
softethervpn v4.29_9680-1
sway-services-git r24.52d395b-1
wrk 4.1.0-4
```

而最近由于经常有 pacman -Syu ,也更新了 vulkan, mesa等很多包,实在不知道是啥包有问题,一个个退回去挺蛋疼,虽然系统有快照,但是想想退回去也得一个个排查

有没有人知道最近 2021-03-19 差不多这个之后出现的这种类似问题?我Arch主要用于办公,实在没什么时间折腾

最近编辑记录 atmouse (2021-04-08 11:30:43)

离线

#2 2021-03-29 13:09:36

atmouse
会员
注册时间: 2011-08-24
帖子: 701

Re: 【已解决】sway使用EGL会导致图形崩溃

把 spectre 跟 meltdown mitigation 重新关掉(pti=off spectre_v2=off l1tf=off nospec_store_bypass_disable no_stf_barrier)就不会了,很久之前为了性能一直关着, 前几天看到什么新闻又把他去掉设置成默认(auto是开起来)

不管了,还是不要去上乱七八糟的网站吧

最近编辑记录 atmouse (2021-03-29 13:10:28)

离线

#3 2021-03-29 19:37:10

xtricman
エクス·トリクマン
注册时间: 2012-12-26
帖子: 1,222

Re: 【已解决】sway使用EGL会导致图形崩溃

Chromium 是systemd --user启动的啊,那是chromium当桌面用了吗?

最近编辑记录 xtricman (2021-03-29 19:40:03)


反社会,精神极其不稳定,随时可能炸碎身边所有人

离线

#4 2021-03-29 19:46:42

xtricman
エクス·トリクマン
注册时间: 2012-12-26
帖子: 1,222

Re: 【已解决】sway使用EGL会导致图形崩溃

我觉得楼主还是没说清楚是怎么启动的,chromium需要有一个Xorg或者Sway先它运行。没有就会报那个错。


反社会,精神极其不稳定,随时可能炸碎身边所有人

离线

#5 2021-04-07 10:41:09

atmouse
会员
注册时间: 2011-08-24
帖子: 701

Re: 【已解决】sway使用EGL会导致图形崩溃

spectre 跟 meltdown mitigation 重新关掉还是会(今天升级了systemd)。
今天真的把内核从 5.11 升级到 5.12rc6 就不会了(本来想按以前计划5.12一正式就升级)

5.11 是真的5.11 没有带后续修补的,出问题概率还是很大的,每次都是一出正式我就升级,然而后续5.11.x 都没升级直接等下个版本。
应该就是这个原因了,希望不要打脸

最近编辑记录 atmouse (2021-04-08 13:09:23)

离线

#6 2021-04-07 10:48:41

atmouse
会员
注册时间: 2011-08-24
帖子: 701

Re: 【已解决】sway使用EGL会导致图形崩溃

xtricman 说:

我觉得楼主还是没说清楚是怎么启动的,chromium需要有一个Xorg或者Sway先它运行。没有就会报那个错。

本来不论是否用systemd启动,都有可能崩溃,从终端命令启动也一样。可以排除是systemd管理器的问题。 也有可能真是新systemd跟内核兼容出现了问题

想知道我为啥用systemd管理chromium?
一是可以用cgroup限制内存,二是管理习惯

% tail .config/sway/config
```
#}

# waybar enabled as systemd user service
#bar {
#    swaybar_command waybar
#}

#include /etc/sway/config.d/*

exec "systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK XCURSOR_SIZE XDG_CURRENT_DESKTOP; systemctl --user start sway-session.target"
```

最近编辑记录 atmouse (2021-04-07 22:38:45)

离线

#7 2021-04-07 23:56:23

atmouse
会员
注册时间: 2011-08-24
帖子: 701

Re: 【已解决】sway使用EGL会导致图形崩溃

又打脸了,跟内核没关系,找到了100%重现的办法了。绝对是sway,wlroot或者mesa的bug

# 会崩溃的操作
开机进tty敲sway命令启动sway
进入sway,这时候按Mod4+Enter快捷键启动任何一个全屏(tile窗口肯定是全屏的吧)的wayland的终端程序(weston-terminal,或者alacritty)
在终端里面,马上敲命令启动任何用到egl的图形程序(vulkaninfo,vkcube,glxgears,chromium都可),这时候egl就会丢失,wayland 直接挂掉,连带sway一起挂掉回到tty

# 不会崩溃的操作
开机进tty敲sway命令启动sway
进入sway,这时候不启动任何窗口,而是按快捷键启动一个bmenu这种启动器
在启动器里面命令启动 egl的图形程序比如chromium,就会正常启动,然后后续不管是否Mod4+Enter启动终端再启动什么程序都不会崩溃

# 另一个不会崩溃的操作
开机进tty敲sway命令启动sway
进入sway,等待30秒再操作,一切就正常了

weston-launch没有任何问题

最近编辑记录 atmouse (2021-04-08 09:25:46)

离线

#8 2021-04-08 04:01:45

yw662
大会员
所在地: localhost
注册时间: 2018-10-10
帖子: 375

Re: 【已解决】sway使用EGL会导致图形崩溃

Proprietary graphics drivers, including nvidia, are not supported. Please use the open source equivalents, such as nouveau, if you would like to use Sway.

https://github.com/swaywm/sway/wiki#nvidia-users

读过这句话吗。。。。sway和wlroot永远不会支持egl。
建议:1.用i卡。2.用a卡。

最近编辑记录 yw662 (2021-04-08 04:03:10)


ecmascript是世界上最好的语言

离线

#9 2021-04-08 09:23:23

atmouse
会员
注册时间: 2011-08-24
帖子: 701

Re: 【已解决】sway使用EGL会导致图形崩溃

yw662 说:

Proprietary graphics drivers, including nvidia, are not supported. Please use the open source equivalents, such as nouveau, if you would like to use Sway.

https://github.com/swaywm/sway/wiki#nvidia-users

读过这句话吗。。。。sway和wlroot永远不会支持egl。
建议:1.用i卡。2.用a卡。

啊这,我满怀期待,你却不知道我问题出在哪

离线

#10 2021-04-08 09:49:23

atmouse
会员
注册时间: 2011-08-24
帖子: 701

Re: 【已解决】sway使用EGL会导致图形崩溃

sway 1.6 出来了,官方包可得赶紧更新呐。。。千万要修复这个问题啊

EDIT:升级 community-staging/sway-1.6 ,修复了

最近编辑记录 atmouse (2021-04-08 11:30:21)

离线

#11 2021-04-08 12:16:11

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,218
个人网站

Re: 【已解决】sway使用EGL会导致图形崩溃

yw662 说:

Proprietary graphics drivers, including nvidia, are not supported. Please use the open source equivalents, such as nouveau, if you would like to use Sway.

https://github.com/swaywm/sway/wiki#nvidia-users

读过这句话吗。。。。sway和wlroot永远不会支持egl。
建议:1.用i卡。2.用a卡。

啊,哪里说了不支持 egl 么?那不用 egl 用什么,glx?

离线

#12 2021-04-08 18:12:11

yw662
大会员
所在地: localhost
注册时间: 2018-10-10
帖子: 375

Re: 【已解决】sway使用EGL会导致图形崩溃

依云 说:
yw662 说:

Proprietary graphics drivers, including nvidia, are not supported. Please use the open source equivalents, such as nouveau, if you would like to use Sway.

https://github.com/swaywm/sway/wiki#nvidia-users

读过这句话吗。。。。sway和wlroot永远不会支持egl。
建议:1.用i卡。2.用a卡。

啊,哪里说了不支持 egl 么?那不用 egl 用什么,glx?

想错了我还以为楼主说的是eglstream

最近编辑记录 yw662 (2021-04-08 18:12:22)


ecmascript是世界上最好的语言

离线

页脚