您尚未登录。

#1 2021-11-05 09:40:04

公子希夷
会员
注册时间: 2019-12-17
帖子: 34

[求助] 关于wine的问题

使用winecfg进行一些设定的时候,出现版本不匹配问题,具体输入输出情况如下:

输入:> $ WINEPREFIX=~/.deepinwine/Spark-TIM regedit                                     

输出: wine client error:0: version mismatch 595/734.
            Your wineserver binary was not upgraded correctly,
            or you have an older one somewhere in your PATH.
            Or maybe the wrong wineserver is still running?

同样,输入:WINEPREFIX=~/.deepinwine/Spark-TIM winecfg

也是这样子的结果;

wine版本信息如下:

> $ wine --version                                                                 
wine-6.20 (Staging)

离线

#2 2021-11-05 10:14:12

Tee
会员
注册时间: 2016-09-10
帖子: 88
个人网站

Re: [求助] 关于wine的问题

是不是因为目录是 deepin-wine的,而你用 wine 来运行。
试试

deepin-wine winecfg


啦哆咪 - 用Linux制作音乐
https://lado.me

离线

#3 2021-11-05 10:53:27

公子希夷
会员
注册时间: 2019-12-17
帖子: 34

Re: [求助] 关于wine的问题

Tee 说:

是不是因为目录是 deepin-wine的,而你用 wine 来运行。
试试

deepin-wine winecfg


输入:> $ deepin-wine winecfg                                                             
输出:      zsh: command not found: deepin-wine

我本来也想把两个版本都贴上的,然后....就这样子了

不过.deepinwine文件夹里面有个deepin-wine5的文件夹,所以deepinwine版本应该是最新的deepin-wine5

对了,输入 deepinwine --version ; deepin-wine --version 也是一样的结果

离线

#4 2021-11-05 11:10:53

Tee
会员
注册时间: 2016-09-10
帖子: 88
个人网站

Re: [求助] 关于wine的问题

公子希夷 说:

对了,输入 deepinwine --version ; deepin-wine --version 也是一样的结果

诶,不知道是不是你的deepin-wine坏了吗?我这边可以的

5XLaKlT.png

WK0FREI.png

最近编辑记录 Tee (2021-11-05 11:21:21)


啦哆咪 - 用Linux制作音乐
https://lado.me

离线

#5 2021-11-05 11:41:23

公子希夷
会员
注册时间: 2019-12-17
帖子: 34

Re: [求助] 关于wine的问题

Tee 说:
公子希夷 说:

对了,输入 deepinwine --version ; deepin-wine --version 也是一样的结果

诶,不知道是不是你的deepin-wine坏了吗?我这边可以的

https://i.imgur.com/5XLaKlT.png

https://i.imgur.com/WK0FREI.png


感谢你的帮助和图示,我想我已经解决问题了,

输入deepin-wine确实不行,但是输入 deepin-wine5就可以完美解决

是我的疏忽,还以为是同一个命令来着

另外这也证明了,原因确实是试图用wine打开deepin-wine5的原因

再次感谢你的帮助

最近编辑记录 公子希夷 (2021-11-05 11:42:18)

离线

页脚