您尚未登录。

#1 2021-11-14 21:58:37

Adopac
会员
注册时间: 2021-11-14
帖子: 2
个人网站

求助,kde无法关闭防止撕裂

因为要用obs录屏,所以要么开fps要么关掉vsync,但是vsync在设置里,防止撕裂(垂直同步)处没有能关闭的选项,请问有什么方法可以关掉它吗?
或者有没有什么其他的方法可结局录屏的问题?OBS和simplescreenrecorder都会出现闪屏的现象。

离线

#2 2021-11-14 22:41:27

ddqi
weearc
注册时间: 2017-01-27
帖子: 25
个人网站

Re: 求助,kde无法关闭防止撕裂

两个方法:
1. 换wayland,目前wayland下录制确实不会闪烁
2. 强行关闭垂直同步,方法来自于 reddit:

<device screen="0" driver="dri2">
        <application name="Default">
                <option name="vblank_mode" value="0"/>
        </application>
</device>

在家目录下创建包含如上内容的文件,命名为 .drirc,注销并重新登陆即可关闭垂直同步。
注:实际选项请根据你的实际设置来填写

最近编辑记录 ddqi (2021-11-14 22:42:04)


blog.weearc.top   ,喜欢安逸也喜欢折腾

离线

#3 2021-11-21 14:42:59

Adopac
会员
注册时间: 2021-11-14
帖子: 2
个人网站

Re: 求助,kde无法关闭防止撕裂

ddqi 说:

两个方法:
1. 换wayland,目前wayland下录制确实不会闪烁
2. 强行关闭垂直同步,方法来自于 reddit:

<device screen="0" driver="dri2">
        <application name="Default">
                <option name="vblank_mode" value="0"/>
        </application>
</device>

在家目录下创建包含如上内容的文件,命名为 .drirc,注销并重新登陆即可关闭垂直同步。
注:实际选项请根据你的实际设置来填写

十分感谢。

离线

页脚