您尚未登录。

#1 2023-03-22 11:12:53

gzroc
会员
注册时间: 2021-03-24
帖子: 224

vim配置出现这个问题如何解决?

每次进入vim会提示这行
错误信息:YouCompleteMe unavailable: requires Vim compiled with Python (3.6.0+) support.
在网上搜了下,有一些解决方法,不过试了好像不行,特来请教。

最近编辑记录 gzroc (2023-03-22 11:13:18)

离线

#2 2023-03-22 11:27:01

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,694
个人网站

Re: vim配置出现这个问题如何解决?

所以你装的哪个 vim?有 +python3 支持么?

离线

#3 2023-03-22 13:13:41

szbgwr
会员
注册时间: 2023-03-22
帖子: 3

Re: vim配置出现这个问题如何解决?

vim --version可以看到vim支持python几

离线

#4 2023-03-22 16:09:04

gzroc
会员
注册时间: 2021-03-24
帖子: 224

Re: vim配置出现这个问题如何解决?

➜  ~ vim --version
NVIM v0.8.3
Build type: Release
LuaJIT 2.1.0-beta3
Compiled by builduser

Features: +acl +iconv +tui
See ":help feature-compile"

   system vimrc file: "$VIM/sysinit.vim"
  fall-back for $VIM: "/usr/share/nvim"

Run :checkhealth for more info

离线

#5 2023-03-22 18:34:46

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,694
个人网站

Re: vim配置出现这个问题如何解决?

哦 nvim 啊。这个我不懂。

离线

#6 2023-04-01 11:52:56

gzroc
会员
注册时间: 2021-03-24
帖子: 224

Re: vim配置出现这个问题如何解决?

依云 说:

哦 nvim 啊。这个我不懂。

大佬用的是哪个vim?

离线

#7 2023-04-01 11:57:15

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,694
个人网站

Re: vim配置出现这个问题如何解决?

我用的 gvim-lily,带补丁的 Vim。
另外 neovim 不是 vim,不要混淆。

离线

#8 2023-04-04 13:40:32

zsrkmyn
lazy...
注册时间: 2013-05-05
帖子: 331

Re: vim配置出现这个问题如何解决?

离线

页脚