您尚未登录。

#1 2023-09-09 23:37:44

cchack
会员
注册时间: 2023-09-09
帖子: 14

【已解决】新人安装求教,USERADD创建用户报错

useradd -m -G wheel sun
useradd:group 'users' does not exist
useradd: the GROUP= configuration in  /etc/default/useradd will be ignored
useradd:group 'wheel ' does not exist


大佬们,这个是什么问题?
安装第一次的时候是引导不行,重新安装就这样了,不能创建用户,单独一个硬盘安装,与WIN11双系统,引导公用的WIN11的引导分区。
现在的情况是创建用户不行!

最近编辑记录 cchack (2023-09-10 17:17:14)

离线

#2 2023-09-10 00:01:24

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,701
个人网站

Re: 【已解决】新人安装求教,USERADD创建用户报错

你指定的组 wheel 不存在。谁教你这样做的啊。

离线

#3 2023-09-10 00:01:33

akumaexs
会员
注册时间: 2023-01-12
帖子: 19

Re: 【已解决】新人安装求教,USERADD创建用户报错

sudo包没有装

离线

#4 2023-09-10 00:04:30

cchack
会员
注册时间: 2023-09-09
帖子: 14

Re: 【已解决】新人安装求教,USERADD创建用户报错

依云 说:

你指定的组 wheel 不存在。谁教你这样做的啊。

我是看B站上面的安装教程安装
这个命令有错误吗?大佬

离线

#5 2023-09-10 00:06:26

akumaexs
会员
注册时间: 2023-01-12
帖子: 19

Re: 【已解决】新人安装求教,USERADD创建用户报错

cchack 说:
依云 说:

你指定的组 wheel 不存在。谁教你这样做的啊。

我是看B站上面的安装教程安装
这个命令有错误吗?大佬

意思是,你现在没有wheel组
`useradd -m -G wheel xxx` 是把你创建的用户添加进wheel组,但你现在没有wheel组

先看一下sudo 包装了没有

离线

#6 2023-09-10 00:13:09

cchack
会员
注册时间: 2023-09-09
帖子: 14

Re: 【已解决】新人安装求教,USERADD创建用户报错

akumaexs 说:
cchack 说:
依云 说:

你指定的组 wheel 不存在。谁教你这样做的啊。

我是看B站上面的安装教程安装
这个命令有错误吗?大佬

意思是,你现在没有wheel组
`useradd -m -G wheel xxx` 是把你创建的用户添加进wheel组,但你现在没有wheel组

先看一下sudo 包装了没有


我试着创建了这个wheel组 和 users 这俩组,竟然不报错了,可以创建用户了。

但我并不知道是否对后期有有什么影响!

离线

#7 2023-09-10 00:16:20

akumaexs
会员
注册时间: 2023-01-12
帖子: 19

Re: 【已解决】新人安装求教,USERADD创建用户报错

cchack 说:
akumaexs 说:
cchack 说:
依云 说:

你指定的组 wheel 不存在。谁教你这样做的啊。

我是看B站上面的安装教程安装
这个命令有错误吗?大佬

意思是,你现在没有wheel组
`useradd -m -G wheel xxx` 是把你创建的用户添加进wheel组,但你现在没有wheel组

先看一下sudo 包装了没有


我试着创建了这个wheel组 和 users 这俩组,竟然不报错了,可以创建用户了。

但我并不知道是否对后期有有什么影响!

emmm,你为什么不` pacman -S sudo --needed ` 一下,不然你之后怎么sudo提权
然后去visudo里改一下配置文件

话说你看的什么教程,感觉不太靠谱以及,肯定是你中间漏打了什么包

离线

#8 2023-09-10 00:34:53

cchack
会员
注册时间: 2023-09-09
帖子: 14

Re: 【已解决】新人安装求教,USERADD创建用户报错

akumaexs 说:
cchack 说:
akumaexs 说:
cchack 说:
依云 说:

你指定的组 wheel 不存在。谁教你这样做的啊。

我是看B站上面的安装教程安装
这个命令有错误吗?大佬

意思是,你现在没有wheel组
`useradd -m -G wheel xxx` 是把你创建的用户添加进wheel组,但你现在没有wheel组

先看一下sudo 包装了没有


我试着创建了这个wheel组 和 users 这俩组,竟然不报错了,可以创建用户了。

但我并不知道是否对后期有有什么影响!

emmm,你为什么不` pacman -S sudo --needed ` 一下,不然你之后怎么sudo提权
然后去visudo里改一下配置文件

话说你看的什么教程,感觉不太靠谱以及,肯定是你中间漏打了什么包


因为是双系统,所以特意在哔哩哔哩找了一个最近的8月底新出的教程!

但是人家没有我这种问题!所以我就很奇怪,现在已经进系统了,一切正常,sudo也正常!

让我有种不可思议的错觉!

离线

#9 2023-09-10 09:09:59

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,701
个人网站

Re: 【已解决】新人安装求教,USERADD创建用户报错

查了一下,wheel 和 users 组是 systemd 包应当创建的。你可能是安装过程中出了点啥问题导致没能成功创建。

离线

#10 2023-09-10 10:53:17

wktl
会员
注册时间: 2023-09-10
帖子: 1

Re: 【已解决】新人安装求教,USERADD创建用户报错

我也遇到了,systemd的问题,可以看一下这里:https://bugs.archlinux.org/task/79619

离线

#11 2023-09-10 14:56:48

a beginner
会员
注册时间: 2023-09-08
帖子: 1

Re: 【已解决】新人安装求教,USERADD创建用户报错

俺也遇到了

离线

#12 2023-09-10 17:16:56

cchack
会员
注册时间: 2023-09-09
帖子: 14

Re: 【已解决】新人安装求教,USERADD创建用户报错

依云 说:

查了一下,wheel 和 users 组是 systemd 包应当创建的。你可能是安装过程中出了点啥问题导致没能成功创建。

谢谢!已解决

离线

页脚