您尚未登录。

#1 2024-04-05 19:25:46

who_am_i_123456
会员
注册时间: 2024-04-04
帖子: 15

archlinuxcn源无法安装软件,已损坏 (无效或已损坏的软件包 (PGP 签名))

想要安装wine-for-wechat,一直显示
错误:wine-for-wechat: 来自 "lilac (build machine) <lilac@build.archlinuxcn.org>" 的签名是未知信任的
:: 文件 /var/cache/pacman/pkg/wine-for-wechat-9.5-1-x86_64.pkg.tar.zst 已损坏 (无效或已损坏的软件包 (PGP 签名)).
打算删除吗? [Y/n]
报错
后来想要安装archlinuxcn-keyring,结果也是一样
错误:archlinuxcn-keyring: 来自 "Jiachen YANG (Arch Linux Packager Signing Key) <farseerfc@archlinux.org>" 的签名是勉强信任的
:: 文件 /var/cache/pacman/pkg/archlinuxcn-keyring-20230923-1-any.pkg.tar.zst 已损坏 (无效或已损坏的软件包 (PGP 签名)).
打算删除吗? [Y/n] n
错误:无法提交处理 (无效或已损坏的软件包 (PGP 签名))
发生错误,没有软件包被更新。
该怎么解决呢,感谢

最近编辑记录 who_am_i_123456 (2024-04-05 19:26:32)

离线

#2 2024-04-05 21:59:06

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,704
个人网站

Re: archlinuxcn源无法安装软件,已损坏 (无效或已损坏的软件包 (PGP 签名))

需要手动信任一下 farseerfc: https://www.archlinuxcn.org/archlinuxcn … eerfc-key/

离线

#3 2024-04-05 21:59:59

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,704
个人网站

Re: archlinuxcn源无法安装软件,已损坏 (无效或已损坏的软件包 (PGP 签名))

另外 AUR 里有腾讯开发的 UOS 版本微信(Qt + X11),可以试用一下。

离线

#4 2024-04-06 11:50:36

who_am_i_123456
会员
注册时间: 2024-04-04
帖子: 15

Re: archlinuxcn源无法安装软件,已损坏 (无效或已损坏的软件包 (PGP 签名))

解决了,谢谢
aur里面的微信安装太慢,等不及了了

离线

页脚