您尚未登录。

#1 2012-06-01 13:28:49

lizhihao
会员
注册时间: 2012-06-01
帖子: 2

pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

进行安装吗? [Y/n] y
:: 正在从 core 软件库获取软件包...
krb5-1.10.1-3-i686                                178.0   B  3.77M/s 00:00 [###########################################] 100%
krb5-1.10.1-3-i686                                861.0   B  32.8M/s 00:00 [###########################################] 100%
:: 正在从 extra 软件库获取软件包...
libcups-1.5.3-3-i686                              178.0   B  4.04M/s 00:00 [###########################################] 100%
libcups-1.5.3-3-i686                              861.0   B  29.3M/s 00:00 [###########################################] 100%
xkeyboard-config-2.6-1-any                        178.0   B  3.86M/s 00:00 [###########################################] 100%
xkeyboard-config-2.6-1-any                        861.0   B  29.3M/s 00:00 [###########################################] 100%
(3/3) 正在检查软件包完整性                                                  [###########################################] 100%
错误:无法提交处理 (传递了错误的或 NULL 参数)
发生错误,没有软件包被更新。


求教....

离线

#2 2012-06-01 13:48:40

zhangyan
会员
注册时间: 2012-01-18
帖子: 13

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

刚才我也是这样!

......
xfce4-settings-4.10...   178.0   B   545K/s 00:00 [######################] 100%
xfce4-settings-4.10...   861.0   B  2.21M/s 00:00 [######################] 100%
xfdesktop-4.10.0-3-i686  178.0   B   542K/s 00:00 [######################] 100%
xfdesktop-4.10.0-3-i686  861.0   B  2.24M/s 00:00 [######################] 100%
xfwm4-themes-4.10.0...   178.0   B   547K/s 00:00 [######################] 100%
xfwm4-themes-4.10.0...   861.0   B  2.21M/s 00:00 [######################] 100%
(112/112) checking package integrity               [######################] 100%
error: failed to commit transaction (wrong or NULL argument passed)
Errors occurred, no packages were upgraded.

最近编辑记录 zhangyan (2012-06-01 13:49:24)

离线

#3 2012-06-01 19:51:34

cuihao
所在地: USTC, Hefei
注册时间: 2011-08-19
帖子: 1,221
个人网站

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

163源坏了。


Site: I-YU.ME   Twitter: @cuihaoleo   Org: LUG@USTC
AD:  ~欢迎参与志愿计算~

离线

#4 2012-06-02 20:17:12

zhangyan
会员
注册时间: 2012-01-18
帖子: 13

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

谢谢,我更改了/etc/pacman.d/mirrorlist中的源,再更新好像不起作用?仍然报错,咋回事?

最近编辑记录 zhangyan (2012-06-02 20:26:36)

离线

#5 2012-06-02 22:42:40

indam
会员
注册时间: 2012-06-02
帖子: 1

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

我了个去,还真是163的源坏了,折腾了我两天!!!

离线

#6 2012-06-02 23:30:16

nigelvon
会员
注册时间: 2012-06-02
帖子: 1

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

我了个去,我也是这个问题,找了一堆英文的帖子搞半天都没解决。

离线

#7 2012-06-03 00:13:09

枫叶饭团
免费会员
所在地: C.C.
注册时间: 2011-08-27
帖子: 190
个人网站

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

还好我当天就在pkg里找到163源坏了的通告

离线

#8 2012-06-04 11:42:57

lizhihao
会员
注册时间: 2012-06-01
帖子: 2

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

j既然源坏了,可是错误信息也体现不出来...还以为所我本地出问题了。。。

离线

#9 2012-06-04 19:56:58

依云
性别女,请正确称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,474
个人网站

Re: pacman 无法更新软件包,错误:无法提交处理 (传递了错误的或 NULL 参数)

lizhihao 说:

j既然源坏了,可是错误信息也体现不出来...还以为所我本地出问题了。。。

你去163找那个不懂 HTTP 的人啊。

离线

页脚