您尚未登录。

#1 2019-05-05 13:06:28

sevk
会员
注册时间: 2019-05-05
帖子: 3

刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

:: 正在同步软件包数据库...
core 已经是最新版本
extra 已经是最新版本
community 已经是最新版本
:: 正在进行全面系统更新...
:: 替换 libmagick 为 extra/imagemagick 吗 ? [Y/n]
正在解析依赖关系...
正在查找软件包冲突...

软件包 (152) accountsservice-0.6.55-1  android-tools-9.0.0_r35-1  ark-19.04.0-1
             attica-5.57.0-1  avahi-0.7+18+g1b5f401-2  baloo-5.57.0-1
             bind-tools-9.14.1-1  binutils-2.32-1  botan-2.10.0-1
             chromium-74.0.3729.131-2  clang-8.0.0-4  cmake-3.14.3-1
             dhcpcd-7.2.1-1  ebook-tools-0.2.2-6  exo-0.12.5-1  falkon-3.1.0-4
             fcitx-4.2.9.6-2  fcitx-gtk2-4.2.9.6-2  fcitx-gtk3-4.2.9.6-2
             fcitx-qt5-1.2.3-7  freetype2-2.10.0-2  fuse-common-3.5.0-1
             gcc-8.3.0-1  gcc-libs-8.3.0-1  glib-networking-2.60.2-1
             glibc-2.29-1  gnome-desktop-1:3.32.1.2-1
             gst-plugins-base-1.16.0-2  gst-plugins-base-libs-1.16.0-2
             gstreamer-1.16.0-1  gvim-8.1.1186-1  http-parser-2.9.1-1
             icu-64.2-1  imagemagick-7.0.8.44-1  intel-tbb-2019.5-1
             kaccounts-integration-19.04.0-1  kactivities-5.57.0-1
             karchive-5.57.0-1  kauth-5.57.0-1  kbookmarks-5.57.0-1
             kcmutils-5.57.0-1  kcodecs-5.57.0-1  kcompletion-5.57.0-1
             kconfig-5.57.0-1  kconfigwidgets-5.57.0-1  kcoreaddons-5.57.0-1
             kcrash-5.57.0-1  kdbusaddons-5.57.0-1  kdeclarative-5.57.0-1
             kdesu-5.57.0-1  kfilemetadata-5.57.0-1  kglobalaccel-5.57.0-2
             kguiaddons-5.57.0-1  ki18n-5.57.0-1  kiconthemes-5.57.0-1
             kidletime-5.57.0-1  kinit-5.57.0-1  kio-5.57.0-1
             kitemmodels-5.57.0-1  kitemviews-5.57.0-1  kjobwidgets-5.57.0-1
             knewstuff-5.57.0-1  knotifications-5.57.0-1  kpackage-5.57.0-1
             kparts-5.57.0-1  kpmcore-4.0.0-2  kpty-5.57.0-1  kservice-5.57.0-1
             ktextwidgets-5.57.0-1  kwallet-5.57.0-1  kwidgetsaddons-5.57.0-1
             kwindowsystem-5.57.0-1  kxmlgui-5.57.0-1  libcap-2.27-1
             libdbusmenu-qt5-0.9.3+16.04.20160218-4  libdrm-2.4.98-1
             libkipi-19.04.0-1  libmagick-7.0.8.40-1 [删除]  libmwaw-0.3.15-1
             libnm-1.18.0-1  libqtshadowsocks-2.1.0-6
             libreoffice-fresh-6.2.3-2  libreoffice-fresh-zh-cn-6.2.3-1
             libsynctex-2018.48691-9  libtool-2.4.6+42+gb88cebd5-3
             libuv-1.28.0-1  libwacom-0.33-1  libwmf-0.2.12-1
             libwnck3-3.32.0-2  linux-5.0.11.arch1-1  linux-api-headers-5.0.7-1
             linux-firmware-20190424.4b6cf2b-1  linux-headers-5.0.11.arch1-1
             llvm-8.0.0-2  llvm-libs-8.0.0-2  lz4-1:1.9.1-1  mesa-19.0.3-1
             nano-4.2-1  openssh-8.0p1-1  opus-1.3.1-1  orc-0.4.29-1
             parted-3.2-9  partitionmanager-4.0.0-1  perl-5.28.2-1
             poppler-0.76.1-1  poppler-glib-0.76.1-1  poppler-qt5-0.76.1-1
             purpose-5.57.0-1  pygobject-devel-3.32.1-1
             python-gobject-3.32.1-1  python-pyparsing-2.4.0-1
             python-setuptools-1:41.0.1-1  python-urllib3-1.24.2-1
             qbs-1.13.0-1  qca-2.2.1-1  qt5-base-5.12.3-2
             qt5-declarative-5.12.3-1  qt5-location-5.12.3-1
             qt5-multimedia-5.12.3-1  qt5-quickcontrols-5.12.3-1
             qt5-quickcontrols2-5.12.3-1  qt5-script-5.12.3-1
             qt5-sensors-5.12.3-1  qt5-speech-5.12.3-1  qt5-svg-5.12.3-1
             qt5-tools-5.12.3-1  qt5-webchannel-5.12.3-1
             qt5-webengine-5.12.3-1  qt5-webkit-5.212.0alpha2-28
             qt5-x11extras-5.12.3-1  qt5-xmlpatterns-5.12.3-1
             qtcreator-4.9.0-1  signon-kwallet-extension-19.04.0-1
             smartmontools-7.0-1  socat-1.7.3.3-1  solid-5.57.0-1
             sonnet-5.57.0-1  spectacle-19.04.0-1  syntax-highlighting-5.57.0-1
             systemd-242.19-1  systemd-libs-242.19-1
             systemd-sysvcompat-242.19-1  thin-provisioning-tools-0.8.0-1
             vim-runtime-8.1.1186-1  virtualbox-6.0.6-2
             virtualbox-host-modules-arch-6.0.6-5  vte-common-0.56.2-1
             vte3-0.56.2-1  xfce4-datetime-plugin-0.7.1-1
             xfce4-notifyd-0.4.4-1  xmlsec-1.2.28-1  zstd-1.4.0-1

全部安装大小:  3060.73 MiB
净更新大小:    18.75 MiB

:: 进行安装吗? [Y/n]
(151/151) 正在检查密钥环里的密钥                   [######################] 100%
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
(151/151) 正在检查软件包完整性                     [######################] 100%
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
...
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
错误:GPGME 错误:无效的加密引擎
:: 文件 /var/cache/pacman/pkg/linux-api-headers-5.0.7-1-any.pkg.tar.xz 已损坏 (无效或已损坏的软件包 (PGP 签名)).
打算删除吗? [Y/n]





▶ gpg -v
gpg: /usr/lib/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/libsqlite3.so.0)



▶ sqlite3 -v
sqlite3: /usr/lib/libm.so.6: version `GLIBC_2.29' not found (required by sqlite3)




▶ sudo pacman-key --init
gpg: /usr/lib/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/libsqlite3.so.0)
gpg: /usr/lib/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/libsqlite3.so.0)
==> 正在更新可信数据库...
gpg: /usr/lib/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib/libsqlite3.so.0)
==> 错误: 信任数据库无法更新。



不小心只更新了sqlite3,现在所有使用sqlite3的软件都不能用了,包括pacman , 怎么办?
如何替换sqlite3为旧的GLIBC_2.28的版本?

最近编辑记录 sevk (2019-05-05 13:17:59)

离线

#2 2019-05-05 14:37:27

xtricman
エクス·トリクマン
注册时间: 2012-12-26
帖子: 675

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

应该是pacman不需要SQLite3但是gpg需要,设法跳过对gpg的调用。
https://www.archlinux.org/pacman/pacman … _a_id_sc_a
设置成Never再整个更新一次系统试试看,成功之后再改回来
或者到ALA把旧版sqlite包下载下来pacman -U应该可以手工装上。(至少需要SigLevel=Optional 否则又要查签名又要gpg了。)

最近编辑记录 xtricman (2019-05-05 17:52:23)


5萬人民幣買個老婆,要國產的,賣的私聊

离线

#3 2019-05-05 17:49:19

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,045
个人网站

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

囧,你这是 gpg 坏了啊。你没清掉 /var/cache/pacman/pkg 的话可以去里边找到旧版本的 sqlite3 装上。

离线

#4 2019-05-05 17:55:44

xtricman
エクス·トリクマン
注册时间: 2012-12-26
帖子: 675

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

依云 说:

囧,你这是 gpg 坏了啊。你没清掉 /var/cache/pacman/pkg 的话可以去里边找到旧版本的 sqlite3 装上。

如果是SigLevel=Required不就还得检查签名又要调用一次gpg吗?gpg是坏的。死循环啊。


5萬人民幣買個老婆,要國產的,賣的私聊

离线

#5 2019-05-05 18:15:23

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,045
个人网站

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

xtricman 说:
依云 说:

囧,你这是 gpg 坏了啊。你没清掉 /var/cache/pacman/pkg 的话可以去里边找到旧版本的 sqlite3 装上。

如果是SigLevel=Required不就还得检查签名又要调用一次gpg吗?gpg是坏的。死循环啊。

本地文件默认不需要签名。

离线

#6 2019-05-05 22:15:59

Mr.I
路人丙
所在地: SH
注册时间: 2015-08-29
帖子: 136

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

实在不行就用 LiveCD 来修呗,随便弄成什么样都能救活


运维工程师,业余程序员,偶尔写写代码,对 ArchLinux 和 Gnome3 一见钟情 wink

离线

#7 2019-05-13 11:25:48

sevk
会员
注册时间: 2019-05-05
帖子: 3

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

当时我用rdesktop控制另一台电脑的浏览器下载sqlite3的源码,编译安装了一下就好了 big_smile  。

最近编辑记录 sevk (2019-05-14 10:03:05)

离线

#8 2019-05-13 21:16:31

Callopingpig
会员
注册时间: 2018-10-07
帖子: 17

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

找一个适配的sqlite3,拷进电脑然后编译,把sqlite3降包也可以

离线

#9 2019-05-13 22:56:44

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,045
个人网站

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

sevk 说:

当时我用sqlite3的源码编译安装了一下就好了 big_smile  。

你厉害,随时准备着 sqlite3 的源码啊。

离线

#10 2019-05-14 10:02:16

sevk
会员
注册时间: 2019-05-05
帖子: 3

Re: 刚才更新时,不小心只更新了sqlite3,然后pacman不能用了,咋办?

依云 说:
sevk 说:

当时我用sqlite3的源码编译安装了一下就好了 big_smile  。

你厉害,随时准备着 sqlite3 的源码啊。


用rdesktop控制另一台电脑,打开sqlite官方网站下载的

最近编辑记录 sevk (2019-05-14 10:03:33)

离线

页脚