您尚未登录。

#16 2013-10-12 00:04:22

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:

你说的是在dhcpcd和pppoe-start都连上之后吗?前几天能连上的时候连上了我有用ip link看过,是有的。但具体输出是什么不记得了。现在是我dhcpcd连不上……更不用说pppoe-start了,所有我看不到ppp*有没有IP或其它输出。

dhcpcd 之前、pppoe-start 之后。

我去看看……我一直以为顺序是先dhcpcd再ppp……

最近编辑记录 Kelei (2013-10-12 00:13:58)

离线

#17 2013-10-12 00:14:17

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:

你说的是在dhcpcd和pppoe-start都连上之后吗?前几天能连上的时候连上了我有用ip link看过,是有的。但具体输出是什么不记得了。现在是我dhcpcd连不上……更不用说pppoe-start了,所有我看不到ppp*有没有IP或其它输出。

dhcpcd 之前、pppoe-start 之后。


没看到有IP什么的……

8e70d792gw1e9hp1gzcupj21kw0w0tq1.jpg

离线

#18 2013-10-12 00:19:52

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 7,100
个人网站

Re: 安装完archlinux 2013.10.01之后突然无法上网

Kelei 说:
百合仙子 说:
Kelei 说:

你说的是在dhcpcd和pppoe-start都连上之后吗?前几天能连上的时候连上了我有用ip link看过,是有的。但具体输出是什么不记得了。现在是我dhcpcd连不上……更不用说pppoe-start了,所有我看不到ppp*有没有IP或其它输出。

dhcpcd 之前、pppoe-start 之后。


没看到有IP什么的……

http://ww1.sinaimg.cn/mw690/8e70d792gw1 … 0w0tq1.jpg

dhcpcd ppp0

离线

#19 2013-10-12 00:20:48

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:
百合仙子 说:
Kelei 说:

你说的是在dhcpcd和pppoe-start都连上之后吗?前几天能连上的时候连上了我有用ip link看过,是有的。但具体输出是什么不记得了。现在是我dhcpcd连不上……更不用说pppoe-start了,所有我看不到ppp*有没有IP或其它输出。

dhcpcd 之前、pppoe-start 之后。


没看到有IP什么的……

http://ww1.sinaimg.cn/mw690/8e70d792gw1 … 0w0tq1.jpg

dhcpcd ppp0

马上重启去试试!

离线

#20 2013-10-12 00:35:20

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:
百合仙子 说:
Kelei 说:

你说的是在dhcpcd和pppoe-start都连上之后吗?前几天能连上的时候连上了我有用ip link看过,是有的。但具体输出是什么不记得了。现在是我dhcpcd连不上……更不用说pppoe-start了,所有我看不到ppp*有没有IP或其它输出。

dhcpcd 之前、pppoe-start 之后。


没看到有IP什么的……

http://ww1.sinaimg.cn/mw690/8e70d792gw1 … 0w0tq1.jpg

dhcpcd ppp0


貌似pppoe-start之后,会自己开启了dhcpcd。然后过了不久,它自动关闭了(还是我-k关掉了?它说:dhcpcd not running,我不知道它是说因自己退出了没运行还是我k了之后没运行)。然后我再试了dhcpcd ppp0和dhclient ppp0都是不行。流程可以看一下图里面的红色行。

8e70d792gw1e9hpm9g9hzj21kw0w04gx.jpg


----------------------
重新再试了一次,那个pppoe-start启动的dhcpcd应该是在我-k之前因为time out自动退出的。

最近编辑记录 Kelei (2013-10-12 00:59:59)

离线

#21 2013-10-12 11:36:38

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 7,100
个人网站

Re: 安装完archlinux 2013.10.01之后突然无法上网

Kelei 说:

貌似pppoe-start之后,会自己开启了dhcpcd。然后过了不久,它自动关闭了(还是我-k关掉了?它说:dhcpcd not running,我不知道它是说因自己退出了没运行还是我k了之后没运行)。然后我再试了dhcpcd ppp0和dhclient ppp0都是不行。流程可以看一下图里面的红色行。

http://ww1.sinaimg.cn/large/8e70d792gw1 … 0w04gx.jpg


----------------------
重新再试了一次,那个pppoe-start启动的dhcpcd应该是在我-k之前因为time out自动退出的。

再抓一次从 pppoe-start 开始到 dhcpcd 退出的包?

离线

#22 2013-10-12 11:51:12

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:

貌似pppoe-start之后,会自己开启了dhcpcd。然后过了不久,它自动关闭了(还是我-k关掉了?它说:dhcpcd not running,我不知道它是说因自己退出了没运行还是我k了之后没运行)。然后我再试了dhcpcd ppp0和dhclient ppp0都是不行。流程可以看一下图里面的红色行。

http://ww1.sinaimg.cn/large/8e70d792gw1 … 0w04gx.jpg


----------------------
重新再试了一次,那个pppoe-start启动的dhcpcd应该是在我-k之前因为time out自动退出的。

再抓一次从 pppoe-start 开始到 dhcpcd 退出的包?


好了,执行顺序如下:pppoe-setup -> tcpdump -> pppoe-start 然后到dhcpcd自动退出的包:

http://pan.baidu.com/s/1xd0kH

离线

#23 2013-10-12 14:50:36

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 7,100
个人网站

Re: 安装完archlinux 2013.10.01之后突然无法上网

Kelei 说:
百合仙子 说:
Kelei 说:

貌似pppoe-start之后,会自己开启了dhcpcd。然后过了不久,它自动关闭了(还是我-k关掉了?它说:dhcpcd not running,我不知道它是说因自己退出了没运行还是我k了之后没运行)。然后我再试了dhcpcd ppp0和dhclient ppp0都是不行。流程可以看一下图里面的红色行。

http://ww1.sinaimg.cn/large/8e70d792gw1 … 0w04gx.jpg


----------------------
重新再试了一次,那个pppoe-start启动的dhcpcd应该是在我-k之前因为time out自动退出的。

再抓一次从 pppoe-start 开始到 dhcpcd 退出的包?


好了,执行顺序如下:pppoe-setup -> tcpdump -> pppoe-start 然后到dhcpcd自动退出的包:

http://pan.baidu.com/s/1xd0kH

只看到 PPP 会话了。在会话中,对方服务器给了一个 110.65.82.54 的 IP 地址,你的机器没有用上吗?是不是你的 pppoe 配置不对?
也许你要对 ppp0 抓下包?

离线

#24 2013-10-12 14:51:32

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:
百合仙子 说:
Kelei 说:

貌似pppoe-start之后,会自己开启了dhcpcd。然后过了不久,它自动关闭了(还是我-k关掉了?它说:dhcpcd not running,我不知道它是说因自己退出了没运行还是我k了之后没运行)。然后我再试了dhcpcd ppp0和dhclient ppp0都是不行。流程可以看一下图里面的红色行。

http://ww1.sinaimg.cn/large/8e70d792gw1 … 0w04gx.jpg


----------------------
重新再试了一次,那个pppoe-start启动的dhcpcd应该是在我-k之前因为time out自动退出的。

再抓一次从 pppoe-start 开始到 dhcpcd 退出的包?


好了,执行顺序如下:pppoe-setup -> tcpdump -> pppoe-start 然后到dhcpcd自动退出的包:

http://pan.baidu.com/s/1xd0kH

只看到 PPP 会话了。在会话中,对方服务器给了一个 110.65.82.54 的 IP 地址,你的机器没有用上吗?是不是你的 pppoe 配置不对?
也许你要对 ppp0 抓下包?


哦好的!我除了没设DNS外,其它都正确,需要设吗?win下的IP是110.65.92.107。我去看看有没有。

最近编辑记录 Kelei (2013-10-12 14:53:38)

离线

#25 2013-10-12 14:52:55

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 7,100
个人网站

Re: 安装完archlinux 2013.10.01之后突然无法上网

Kelei 说:

哦好的!我除了没设DNS外,其它都正确,需要设吗?

应该不需要吧。

离线

#26 2013-10-12 15:03:22

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:
Kelei 说:

哦好的!我除了没设DNS外,其它都正确,需要设吗?

应该不需要吧。


好像不行啊。我运行pppoe-start之前开不了tcpdump,它说ppp0不存在;但我开了pppoe-start再开tcpdump,这时已经没有收发包了……一直是"Got 0"。

离线

#27 2013-10-13 10:22:56

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

还是不行……

离线

#28 2013-10-15 07:47:34

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

各种google无效 求大神

离线

#29 2013-10-15 13:03:24

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 7,100
个人网站

Re: 安装完archlinux 2013.10.01之后突然无法上网

我也不知道要怎么办了……

离线

#30 2013-10-15 17:38:45

Kelei
会员
注册时间: 2013-10-11
帖子: 21

Re: 安装完archlinux 2013.10.01之后突然无法上网

百合仙子 说:

我也不知道要怎么办了……


我也不知道怎么好了……我不想换回来Ubuntu啊。。又没有另一个网络环境可以测试,各种蛋疼!不知道还有没有其它的方法

离线

页脚