您尚未登录。

#1 2011-10-14 08:19:51

naturennn
会员
注册时间: 2011-08-20
帖子: 27

这个是怎么回事?

更新的时候
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: package-query: requires pacman<3.6

然后pacman -Qi pacman
名称   : pacman
版本   : 3.5.4-4
URL地址 : http://www.archlinux.org/pacman/
软件许可 : GPL
软件组  : base
提供   : 无
依赖于  : bash  glibc>=2.14  libarchive>=2.8.4  libfetch>=2.28  pacman-mirrorlist
可选依赖 : fakeroot: for makepkg usage as normal user
             curl: for rankmirrors usage
要求被  : package-query  pacman-contrib  yaourt
冲突与  : 无
取代   : 无
安装后大小: 2844.00 K
打包者  : Allan McRae <allan@archlinux.org>
架构   : i686
编译日期 : 2011年08月14日 星期日 05时52分05秒
安装日期 : 2011年08月15日 星期一 08时23分00秒
安装原因 : 单独指定安装
安装脚本 : 是
描述   : A library-based package manager with dependency support

离线

#2 2011-10-14 13:14:24

cuihao
所在地: USTC, Hefei
注册时间: 2011-08-19
帖子: 1,222
个人网站

Re: 这个是怎么回事?

关掉testing库,或者用:

yaourt -Syua --ignore pacman

testing出4.0版本的pacman了,package-query不支持。


Site: I-YU.ME   Twitter: @cuihaoleo   Org: LUG@USTC
AD:  ~欢迎参与志愿计算~

离线

页脚