您尚未登录。

#1 2019-06-04 13:10:03

surfan
会员
注册时间: 2014-11-13
帖子: 21

[已解决]安装 XMind 后,启动报错。

安装 XMind 后,启动弹出下图这个窗口,改装 XMind-zen,不管是新建还是打开以前的文件都是一直转圈,请问要如何解决?谢谢。

FluxBB XMind 错误

最近编辑记录 surfan (2019-06-05 17:07:32)

离线

#2 2019-06-04 15:52:13

Mr.I
路人丙
所在地: SH
注册时间: 2015-08-29
帖子: 167

Re: [已解决]安装 XMind 后,启动报错。

楼主用了哪个版本的 JRE ?


运维工程师,业余程序员,偶尔写写代码,对 ArchLinux 和 Gnome3 一见钟情 wink

离线

#3 2019-06-04 17:20:16

surfan
会员
注册时间: 2014-11-13
帖子: 21

Re: [已解决]安装 XMind 后,启动报错。

Mr.I 说:

楼主用了哪个版本的 JRE ?

~ java -version       
openjdk version "1.8.0_212"
OpenJDK Runtime Environment (build 1.8.0_212-b01)
OpenJDK 64-Bit Server VM (build 25.212-b01, mixed mode)

装软件时自动装上的。

离线

#4 2019-06-04 21:27:30

Mr.I
路人丙
所在地: SH
注册时间: 2015-08-29
帖子: 167

Re: [已解决]安装 XMind 后,启动报错。

删掉 ~/.xmind 再启动一下试试呢?


运维工程师,业余程序员,偶尔写写代码,对 ArchLinux 和 Gnome3 一见钟情 wink

离线

#5 2019-06-05 09:05:42

surfan
会员
注册时间: 2014-11-13
帖子: 21

Re: [已解决]安装 XMind 后,启动报错。

Mr.I 说:

删掉 ~/.xmind 再启动一下试试呢?

删除  ~/.xmind 和卸载程序都试过很多次,问题依旧。

离线

#6 2019-06-05 10:10:29

Mr.I
路人丙
所在地: SH
注册时间: 2015-08-29
帖子: 167

Re: [已解决]安装 XMind 后,启动报错。

surfan 说:

删除  ~/.xmind 和卸载程序都试过很多次,问题依旧。

Hmmm,我把我的 zen 卸掉装了个 XMind,重现了这个问题,简单删除 ~/.xmind 并无法解决。

------------------------------

稍微研究了一下,解决方案如下:
  编辑 /usr/share/xmind/XMind/XMind.ini,删除其中的 --add-modules=java.se.ee 那一行
  然后再删除一次 ~/.xmind 并再次启动即可使用。


方案来源:
  https://aur.archlinux.org/cgit/aur.git/ … ll?h=xmind


至于 zen 那个问题我倒是没有重现 hmm

最近编辑记录 Mr.I (2019-06-05 10:10:47)


运维工程师,业余程序员,偶尔写写代码,对 ArchLinux 和 Gnome3 一见钟情 wink

离线

#7 2019-06-05 11:14:43

Mr.I
路人丙
所在地: SH
注册时间: 2015-08-29
帖子: 167

Re: [已解决]安装 XMind 后,启动报错。

好吧,xmind-zen 的那个问题我也重现了。

由于之前一直用着 2018 年版的 xmind-zen 没有更新,所以没有重现问题。
在重新装回来 xmind-zen 之后出现了和楼主一样的问题,但是该问题我目前没有找到相关的资料。

鉴于后续版本跟新中似乎没有加入什么重要的 Feature,我使用了一个简单粗暴的解决方法:
  降级到 2018 年版的 xmind-zen

------------------------------------

操作流程很简单:

1. 克隆 AUR 仓库:

git clone https://aur.archlinux.org/xmind-zen.git

2. 进入到克隆下来的仓库里面并回退到老版本(2018 年那个版本)

git reset --hard 978fd6f

3. 使用 ABS 构建软件包:

makepkg

4. 降级软件包:

pacman -U xmind-zen-201807162014-1-x86_64.pkg.tar.xz

-------------------------

Hmmm,然后就好了。

P.S.  那个问题好像和 electron2 有关,不过我并不确定,这只是我猜的。

最近编辑记录 Mr.I (2019-06-05 11:20:06)


运维工程师,业余程序员,偶尔写写代码,对 ArchLinux 和 Gnome3 一见钟情 wink

离线

#8 2019-06-05 16:54:34

surfan
会员
注册时间: 2014-11-13
帖子: 21

Re: [已解决]安装 XMind 后,启动报错。

Mr.I 说:
surfan 说:

删除  ~/.xmind 和卸载程序都试过很多次,问题依旧。

Hmmm,我把我的 zen 卸掉装了个 XMind,重现了这个问题,简单删除 ~/.xmind 并无法解决。

------------------------------

稍微研究了一下,解决方案如下:
  编辑 /usr/share/xmind/XMind/XMind.ini,删除其中的 --add-modules=java.se.ee 那一行
  然后再删除一次 ~/.xmind 并再次启动即可使用。


方案来源:
  https://aur.archlinux.org/cgit/aur.git/ … ll?h=xmind


至于 zen 那个问题我倒是没有重现 hmm

非常感谢,按照您的方法已经成功解决,谢谢!

离线

#9 2019-06-16 15:45:15

XGod
会员
注册时间: 2019-06-16
帖子: 2

Re: [已解决]安装 XMind 后,启动报错。

Mr.I 说:

好吧,xmind-zen 的那个问题我也重现了。

由于之前一直用着 2018 年版的 xmind-zen 没有更新,所以没有重现问题。
在重新装回来 xmind-zen 之后出现了和楼主一样的问题,但是该问题我目前没有找到相关的资料。

鉴于后续版本跟新中似乎没有加入什么重要的 Feature,我使用了一个简单粗暴的解决方法:
  降级到 2018 年版的 xmind-zen

------------------------------------

操作流程很简单:

1. 克隆 AUR 仓库:

git clone https://aur.archlinux.org/xmind-zen.git

2. 进入到克隆下来的仓库里面并回退到老版本(2018 年那个版本)

git reset --hard 978fd6f

3. 使用 ABS 构建软件包:

makepkg

4. 降级软件包:

pacman -U xmind-zen-201807162014-1-x86_64.pkg.tar.xz

-------------------------

Hmmm,然后就好了。

P.S.  那个问题好像和 electron2 有关,不过我并不确定,这只是我猜的。


按照您的方法已经成功解决,谢谢!

离线

页脚