您尚未登录。

#1 2019-11-02 21:32:04

roadgo
会员
注册时间: 2012-04-07
帖子: 308

[已解决]因为要用蓝牙耳机,所以配置了PulseAudio

发现托盘上的主音量控制静音后,再开就没有声音了。要用pavucontrol 取消静音后才能放出声音。

最近编辑记录 roadgo (2019-11-22 18:24:04)

离线

#2 2019-11-02 22:36:46

roadgo
会员
注册时间: 2012-04-07
帖子: 308

Re: [已解决]因为要用蓝牙耳机,所以配置了PulseAudio

Output stuck muted while Master is toggled
In setups with multiple outputs (e.g. 'Headphone' and 'Speaker') using plain amixer to toggle Master can trigger PulseAudio to mute the active output too, but it does not necessarily unmute it when Master is toggled back to be unmuted. [1] To resolve this, amixer must have the device flag set to 'pulse':

$ amixer -D pulse sset Master toggle
This will cause amixer to ask PulseAudio to do the toggling rather than toggling it directly. Because of this, PulseAudio will correctly unmute Master as well as any applicable output.

离线

#3 2019-11-02 22:37:24

roadgo
会员
注册时间: 2012-04-07
帖子: 308

Re: [已解决]因为要用蓝牙耳机,所以配置了PulseAudio

感觉这段有点象。但是失败。。。
amixer -D pulse sset Master toggle
ALSA lib control.c:1375:(snd_ctl_open_noupdate) Invalid CTL pulse
amixer: Mixer attach pulse error: No such file or directory

离线

#4 2019-11-22 18:24:21

roadgo
会员
注册时间: 2012-04-07
帖子: 308

Re: [已解决]因为要用蓝牙耳机,所以配置了PulseAudio

重新安装udev

离线

页脚