您尚未登录。

#1 2011-11-30 13:51:31

艾冷娃
会员
注册时间: 2011-11-24
帖子: 11

解决 archlinux 和 windows 双系统启动时间不准的问题

这里讲的是 arch 和 windows 都设置为 UTC 的情况:
此方法在两台机器上通过。一台 win7 加 arch ,一台 xp 加 arch。

按以下步骤解决:

  1. 在windows中设置 UTC

    • 打开注册表

      regedit
    • 找到 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation 项,新建名为 RealTimeIsUniversal 一个 DWORD 值,取值为 1 。

      也可直接做成一个 .reg 文件方便以后使用

      Windows Registry Editor Version 5.00
      
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
           "RealTimeIsUniversal"=dword:00000001
  2. 在 arch 中设置 UTC 并调整系统及硬件时间

    • 可以手动或者使用 openntpd 调整系统时间,我采用后一种。安装并启动 openntpd 。

      pacman -S openntpd
      /etc/rc.d/openntpd start

      跟时间服务器同步时间

      ntpd -s

      这样系统时间现在应该是准确的了

    • 正确配置时区和守护进程

      vim /etc/rc.conf

      调整下面两项的值为

      HARDWARECLOCK="UTC"
      TIMEZONE="Asia/Shanghai"

      确保 hwclock 或者 ntpd 在 DAEMONS 中开机启动,因为我使用了 ntpd ,所以把 hwclock 禁用了。

      DAEMONS=(...!hwclock ntpd...) 
    • 运行指令写入硬件时间,之后即可重启试验效果了

      hwclock -w

离线

#2 2011-11-30 17:42:25

phoenixlzx
晩ご飯だよー
注册时间: 2011-08-19
帖子: 1,789
个人网站

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

就是UTC的问题吧...

离线

#3 2011-11-30 18:02:06

dryland718
会员
所在地: 3.1415926535897932384626433832
注册时间: 2011-10-30
帖子: 66
个人网站

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

NB...

离线

#4 2011-12-05 15:08:07

_Fly
会员
注册时间: 2011-11-08
帖子: 15

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

必须禁用 hwcolock 吗 ? :em23  :em23

离线

#5 2011-12-05 15:09:57

灰色小狼
KDE就是好就是好就是好
注册时间: 2011-08-19
帖子: 161

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

装arch时候时间干嘛不选local……

离线

#6 2011-12-05 23:23:14

ffwalle
机器人
注册时间: 2011-12-03
帖子: 391

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

灰色小狼 说:

装arch时候时间干嘛不选local……

选了也没用,时区都是对的,但是时间不对。


just for fun :-)

离线

#7 2011-12-05 23:23:59

ffwalle
机器人
注册时间: 2011-12-03
帖子: 391

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

艾冷娃 说:

这里讲的是 arch 和 windows 都设置为 UTC 的情况:
此方法在两台机器上通过。一台 win7 加 arch ,一台 xp 加 arch。

按以下步骤解决:

  1. 在windows中设置 UTC

    • 打开注册表

      regedit
    • 找到 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation 项,新建名为 RealTimeIsUniversal 一个 DWORD 值,取值为 1 。

      也可直接做成一个 .reg 文件方便以后使用

      Windows Registry Editor Version 5.00
      
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
           "RealTimeIsUniversal"=dword:00000001
  2. 在 arch 中设置 UTC 并调整系统及硬件时间

    • 可以手动或者使用 openntpd 调整系统时间,我采用后一种。安装并启动 openntpd 。

      pacman -S openntpd
      /etc/rc.d/openntpd start

      跟时间服务器同步时间

      ntpd -s

      这样系统时间现在应该是准确的了

    • 正确配置时区和守护进程

      vim /etc/rc.conf

      调整下面两项的值为

      HARDWARECLOCK="UTC"
      TIMEZONE="Asia/Shanghai"

      确保 hwclock 或者 ntpd 在 DAEMONS 中开机启动,因为我使用了 ntpd ,所以把 hwclock 禁用了。

      DAEMONS=(...!hwclock ntpd...) 
    • 运行指令写入硬件时间,之后即可重启试验效果了

      hwclock -w

openntpd在2009年就已经不维护了,arch组里面的建议是用ntpd。只是很多博客互相抄袭,都写个openntpd来误人子弟


just for fun :-)

离线

#8 2011-12-13 09:43:55

wptskybzy
会员
注册时间: 2011-11-18
帖子: 6

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

其实用不着修改windows的注册表,直接启用NTP,并禁用本地时间服务器就可以了。

离线

#9 2011-12-13 09:53:17

fly020212
会员
注册时间: 2011-12-09
帖子: 3

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

使用了 localtime,就不会使用夏时制,也许是这个原因造成的时间不正确吧

离线

#10 2011-12-14 10:05:40

ffwalle
机器人
注册时间: 2011-12-03
帖子: 391

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

fly020212 说:

使用了 localtime,就不会使用夏时制,也许是这个原因造成的时间不正确吧

貌似我曾经试过这个方法,不过还是会改时间成utc,不知道怎么回事。还是安装ntpd来解决,不过有一个不好的就是系统启动要稍微等待一下(1,2分钟吧),系统时间才会同步成网络时间。


just for fun :-)

离线

#11 2012-04-24 13:10:16

隐否
会员
注册时间: 2012-04-24
帖子: 2

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

另外一个贴中的:
HARDWARECLOCK="localtime"
sudo date --set="01:21 2012-04-15"

这个也行,我的是XP和Arch

离线

#12 2019-11-30 14:51:15

依云
a.k.a. 百合仙子
所在地: 一个等待妹纸出现的地方
注册时间: 2011-08-21
帖子: 5,294
个人网站

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

Windows 10 Home(最近更新的版本)下此注册表项(HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TimeZoneInformation RealTimeIsUniversal)被证明无效。

在线

#13 2019-11-30 23:33:28

yw662
大会员
注册时间: 2018-10-10
帖子: 228

Re: 解决 archlinux 和 windows 双系统启动时间不准的问题

啊对了我之前也发现了这个问题来着
不知道该怎么搞了


ecmascript是世界上最好的语言

离线

页脚