您尚未登录。

#1 2020-02-13 15:35:51

jingmouren
会员
注册时间: 2014-09-13
帖子: 93

cajviewer无法运行,提示需要windows 98或以上版本

用yaourt从aur安装的cajviewer
无法运行,提示如标题

而 /usr/bin/cajviewer 脚本的内容为
#!/usr/bin/bash

if [ -n "$CAJVIEWER_WINEPREFIX" ]; then
    export WINEPREFIX="$CAJVIEWER_WINEPREFIX"
fi

XDG_DATA_HOME=${XDG_DATA_HOME:-"$HOME/.local/share"}

prog=$(winepath -u "C:\\Program Files\\TTKN\\CAJViewer 7.2\\CAJVieweru.exe")
installer="/usr/share/cajviewer/installer.exe"

function install() {
    winetricks -q mdac28 mfc42
    tmpdir="$(mktemp -d)"
    wine "$installer" /Q /T:$(winepath -w "$tmpdir") /C
    msiexec /i "${tmpdir}/CAJViewer 7.2.msi" /qb-
    rm -rf "$tmpdir"
    rm -rf "$XDG_DATA_HOME/applications/wine/Programs/同方知网/CAJViewer"
}
if [ ! -e "$prog" ]; then
    install
fi

exec wine "$prog" $@


该如何解决?谢谢

离线

#2 2020-02-18 11:02:42

jingmouren
会员
注册时间: 2014-09-13
帖子: 93

Re: cajviewer无法运行,提示需要windows 98或以上版本

https://blog.csdn.net/weixin_34390105/a … s/91419643 这个文章
sudo pacman -S wine wine-mono wine_gecko
加装了后两个软件后
再把 C:\\Program Files\\
加上(x86)
好了

最近编辑记录 jingmouren (2020-02-18 11:03:21)

离线

页脚