您尚未登录。

#1 2012-01-17 15:02:35

hou9983
会员
注册时间: 2012-01-03
帖子: 23

我的pacman为什么无法更新呢? (已解决)

显示这个:

[arch@myhost ~]$ sudo pacman -S pacman
正在解决依赖关系...
正在查找内部冲突...
错误:无法准备事务处理 (无法满足依赖关系)
:: package-query: 要求 pacman<3.6

按这个错误信息来看是要求我的pacman版本号低于3.6才行,但是我的pacman版本号如下:

[arch@myhost ~]$ pacman --version

.--.                  Pacman v3.5.4 - libalpm v6.0.4
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2011 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
'--'
                       本程序可以在GNU一般公众许可条款下
                       自由分发

如上所示,我的pacman版本号是3.5.4,低于3.6啊,不知道为什么不行呢?

离线

#2 2012-01-17 15:15:49

ReiFFEXzyx
古悠行者
注册时间: 2011-08-20
帖子: 187

Re: 我的pacman为什么无法更新呢? (已解决)

pacman升级4.0.1了

sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
repo-ck is up to date
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...

Targets (2): libarchive-3.0.3-2  pacman-4.0.1-4

Total Download Size:    2.13 MB
Total Installed Size:   6.16 MB

Proceed with installation? [Y/n] y
:: Retrieving packages from core...
libarchive-3.0.3-2...  1173.8K  362.4K/s 00:00:03 [########################] 100%
pacman-4.0.1-4-x86_64  1011.5K  415.7K/s 00:00:02 [########################] 100%
(2/2) checking package integrity                   [########################] 100%
(2/2) checking for file conflicts                  [########################] 100%
(1/2) upgrading libarchive                         [########################] 100%
(2/2) upgrading pacman                             [########################] 100%
warning: /etc/pacman.conf installed as /etc/pacman.conf.pacnew
warning: /etc/makepkg.conf installed as /etc/makepkg.conf.pacnew
>>> Run `pacman-key --init` to set up your pacman keyring.

pacman 4.0加入了GPG签名
后续的GPG签名问题请看这里
<!-- l --><a class="postlink-local" href="http://www.archlinuxcn.org/viewtopic.php?f=22&t=533">viewtopic.php?f=22&t=533</a><!-- l -->


[fracting的大作]Wine使用中的一些常见误区
http://forum.ubuntu.org.cn/viewtopic.php?f=121&t=363147
顺便学习一下对待开源软件的正确态度

离线

#3 2012-01-17 15:39:25

hou9983
会员
注册时间: 2012-01-03
帖子: 23

Re: 我的pacman为什么无法更新呢? (已解决)

我使用pacman -Syu以后,也是同样的问题。

:: 下列软件包应当首先更新:
    pacman
:: 打算取消当前操作
:: 并马上安装这些软件包吗?  [Y/n] y

正在解决依赖关系...
正在查找内部冲突...
错误:无法准备事务处理 (无法满足依赖关系)
:: package-query: 要求 pacman<3.6

离线

#4 2012-01-17 15:59:24

ReiFFEXzyx
古悠行者
注册时间: 2011-08-20
帖子: 187

Re: 我的pacman为什么无法更新呢? (已解决)

hou9983 说:

我使用pacman -Syu以后,也是同样的问题。

:: 下列软件包应当首先更新:
    pacman
:: 打算取消当前操作
:: 并马上安装这些软件包吗?  [Y/n] y

正在解决依赖关系...
正在查找内部冲突...
错误:无法准备事务处理 (无法满足依赖关系)
:: package-query: 要求 pacman<3.6

https://bbs.archlinux.org/viewtopic.php?id=128401
http://unix.stackexchange.com/questions ... s-too-high
也许有帮助

P.S. 最好关掉testing


[fracting的大作]Wine使用中的一些常见误区
http://forum.ubuntu.org.cn/viewtopic.php?f=121&t=363147
顺便学习一下对待开源软件的正确态度

离线

#5 2012-01-17 16:44:30

jouyouyun
会员
注册时间: 2011-10-10
帖子: 266

Re: 我的pacman为什么无法更新呢? (已解决)

先把 yaourt 卸了,更新完后在重装

离线

#6 2012-01-17 17:35:03

cuihao
所在地: USTC, Hefei
注册时间: 2011-08-19
帖子: 1,221
个人网站

Re: 我的pacman为什么无法更新呢? (已解决)

如果开testing并用pacman4,就需要用yaourt-git:
https://aur.archlinux.org/packages.php?ID=18676


Site: I-YU.ME   Twitter: @cuihaoleo   Org: LUG@USTC
AD:  ~欢迎参与志愿计算~

离线

#7 2012-01-21 22:23:43

hou9983
会员
注册时间: 2012-01-03
帖子: 23

Re: 我的pacman为什么无法更新呢? (已解决)

我的testing一直都是关着的。最后是通过删除yaourt和package-query,然后更新,就好了

离线

页脚