您尚未登录。

#1 2020-02-14 10:49:37

fengzheng081212
会员
注册时间: 2019-11-10
帖子: 35

我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

现在开机只有win10引导,win10引导使独立的一个,archlinux是另一个硬盘,也是独立的一个,各不相干的,原来的archLinux开机grub引导有win10引导选项,进BIOS改开机硬盘uefi引导选项选原来的archLinux,开机还是win10,没有grub了!所以我重新插archLinux安装盘,chroot进系统修复grub,但是没有grub选项了,开机有grub但是只有win10没有archLinux选项了!
FluxBB bbcode 测试

离线

#2 2020-02-14 11:51:11

依云
性别女,谢绝一切男性化称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,393
个人网站

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

你是不是两个 EFI 项用了同一个 ID?
重新 grub 吧。重新生成配置文件没用的。

离线

#3 2020-02-14 12:51:32

yw662
大会员
注册时间: 2018-10-10
帖子: 250

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

为什么你的/boot/efi是sda2,下面grub找的是sdd1……

你efi引导项里面写成u盘的了?


ecmascript是世界上最好的语言

在线

#4 2020-02-14 13:08:38

fengzheng081212
会员
注册时间: 2019-11-10
帖子: 35

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

依云 说:

你是不是两个 EFI 项用了同一个 ID?
重新 grub 吧。重新生成配置文件没用的。

两个EFI项用了同一个ID,这个不懂啊,efi分区我重新格式化了,fstab也重新生成了,然后重新安装grub,重新生成grub配置还是不行
FluxBB bbcode 测试
FluxBB bbcode 测试

离线

#5 2020-02-14 13:17:54

fengzheng081212
会员
注册时间: 2019-11-10
帖子: 35

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

yw662 说:

为什么你的/boot/efi是sda2,下面grub找的是sdd1……

你efi引导项里面写成u盘的了?

不懂啊,我把archLinux安装在我的一个U盘里面了,u盘启动时正常了,拔掉u盘,原来硬盘的grub启动项不见了

离线

#6 2020-02-14 13:37:04

依云
性别女,谢绝一切男性化称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,393
个人网站

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

哦,看来得把旧的启动项删掉。用 efivar 命令删,具体用法见 man 手册。

离线

#7 2020-02-14 15:00:58

fengzheng081212
会员
注册时间: 2019-11-10
帖子: 35

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

依云 说:

哦,看来得把旧的启动项删掉。用 efivar 命令删,具体用法见 man 手册。

查了一下百度,用这个命令删除了所有多余的主板uefi启动项,efibootmgr //显示efi的启动项
删除一个引导项
# efibootmgr -b 0001 -B
其中 0001是要删除的引导项编号,通过 efibootmgr命令可以直接查看。输出如下所示:
# efibootmgr
BootCurrent: 0001
Timeout: 10 seconds
BootOrder: 0001,0002,0003
Boot0001* Asianux
Boot0002* RedFlag
Boot0003* Primary Master CDROM
其中, Boot0001中的 0001就是编号,对应的引导项是 Asianux

重新安装grub,重新生成grub启动项,还是没有archlinu启动项,难道要手动编制添加一个吗!
FluxBB bbcode 测试

离线

#8 2020-02-14 15:58:01

依云
性别女,谢绝一切男性化称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,393
个人网站

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

fengzheng081212 说:

重新安装grub,重新生成grub启动项,还是没有archlinu启动项,难道要手动编制添加一个吗!
https://s2.ax1x.com/2020/02/14/1XOWAH.md.jpg

先 chroot 进去呀。

离线

#9 2020-02-14 17:54:41

fengzheng081212
会员
注册时间: 2019-11-10
帖子: 35

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

依云 说:
fengzheng081212 说:

重新安装grub,重新生成grub启动项,还是没有archlinu启动项,难道要手动编制添加一个吗!
https://s2.ax1x.com/2020/02/14/1XOWAH.md.jpg

先 chroot 进去呀。

谢谢啊,问题解决了,boot目录被我清空了,efi分区被我格式化了,导致efi分区uuid变化了,解决办法是重新安装Linux内核到boot文件夹,删掉fstab重新生成新的fstab,然后重新安装grub和重新生成grub.cfg,开机grub启动项都有了,能正常进系统 了!

离线

#10 2020-02-14 18:18:42

依云
性别女,谢绝一切男性化称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,393
个人网站

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

原来你还做了那么多操作,是说怎么对不上呢。

离线

#11 2020-02-14 18:20:49

fengzheng081212
会员
注册时间: 2019-11-10
帖子: 35

Re: 我把u盘安装了一个arch Linux,作为便携式移动系统,U盘系统正常了。然后拔掉U盘,开机原来的grub引导没有了,需要怎么修复啊

依云 说:

原来你还做了那么多操作,是说怎么对不上呢。

小白一个啊!谢谢!

离线

页脚