您尚未登录。

#1 2020-02-14 20:49:46

adamzyg
会员
注册时间: 2019-11-07
帖子: 33

fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

Sorry, since I can't input chinese, so I post the crash issue in english.

fcitx5 crash log:

Fcitx 4.99.0 -- Get Signal No.: 11
Date: try "date -d @1581684234" if you are using GNU date ***
ProcessID: 5006
fcitx5(+0xa7fe)[0x5573f13657fe]
/usr/lib/libc.so.6(+0x3bd70)[0x7f6e2b3d5d70]
/usr/lib/libFcitx5Core.so.5(_ZN5fcitx19CommonCandidateListD1Ev+0x70)[0x7f6e2b8f6810]
/usr/lib/libFcitx5Core.so.5(_ZN5fcitx19CommonCandidateListD0Ev+0xa)[0x7f6e2b8f68aa]
/usr/lib/libFcitx5Core.so.5(_ZN5fcitx10InputPanel5resetEv+0x84)[0x7f6e2b8f5814]
/usr/lib/fcitx5/pinyin.so(+0x151f1)[0x7f6e287901f1]
/usr/lib/fcitx5/pinyin.so(+0x18fb9)[0x7f6e28793fb9]
/usr/lib/libFcitx5Core.so.5(_ZN5fcitx8Instance9postEventERNS_5EventE+0x304)[0x7f6e2b89a8a4]
/usr/lib/fcitx5/dbusfrontend.so(+0xe69b)[0x7f6e298f969b]
/usr/lib/libFcitx5Utils.so.1(+0x3b744)[0x7f6e2b7e2744]
/usr/lib/libsystemd.so.0(+0x6c729)[0x7f6e2b2ec729]
/usr/lib/libsystemd.so.0(+0x54151)[0x7f6e2b2d4151]
/usr/lib/libsystemd.so.0(+0x545f4)[0x7f6e2b2d45f4]
/usr/lib/libsystemd.so.0(+0x3c977)[0x7f6e2b2bc977]
/usr/lib/libsystemd.so.0(sd_event_dispatch+0x11a)[0x7f6e2b2bd40a]
/usr/lib/libsystemd.so.0(sd_event_run+0x99)[0x7f6e2b2c0709]
/usr/lib/libsystemd.so.0(sd_event_loop+0x58)[0x7f6e2b2c0928]
/usr/lib/libFcitx5Utils.so.1(_ZN5fcitx9EventLoop4execEv+0x12)[0x7f6e2b7e4992]
/usr/lib/libFcitx5Core.so.5(_ZN5fcitx8Instance4execEv+0x2c)[0x7f6e2b8a261c]
fcitx5(+0x90ca)[0x5573f13640ca]
/usr/lib/libc.so.6(__libc_start_main+0xf3)[0x7f6e2b3c1023]
fcitx5(+0x983e)[0x5573f136483e]

最近编辑记录 adamzyg (2020-02-14 21:04:58)


niania

离线

#2 2020-02-14 21:22:51

依云
性别女,请正确称呼
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 5,666
个人网站

Re: fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

降级到 r440.8bee2b2-1。

搞错了,440 是坏的,应该降到 439。441 按理说应该是好的……

最近编辑记录 依云 (2020-02-14 21:36:38)

离线

#3 2020-02-14 21:31:10

adamzyg
会员
注册时间: 2019-11-07
帖子: 33

Re: fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

依云 说:

降级到 r440.8bee2b2-1。

嗯,多谢。我降级到fcitx5-git-r439.30a3cee-1了。多亏没清理cache


niania

离线

#4 2020-03-01 18:10:02

adamzyg
会员
注册时间: 2019-11-07
帖子: 33

Re: fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

话说,你们的441真得不崩溃?


niania

离线

#5 2020-03-02 14:38:09

Tee
会员
注册时间: 2016-09-10
帖子: 45
个人网站

Re: fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

adamzyg 说:

话说,你们的441真得不崩溃?

我用了一天441没有崩,不过似乎无视了一些rime的自定义设置,比如 Shift_L Shift_R。于是我便换回fcitx4了


啦哆咪 - 用Linux制作音乐
https://lado.me

离线

#6 2020-03-07 13:25:06

adamzyg
会员
注册时间: 2019-11-07
帖子: 33

Re: fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

升级到fcitx5-git-r444.b43466d-1-x86_64.pkg.tar.zst还是会崩溃,难道是因为我换了皮肤导致的?
试过两个皮肤:https://github.com/iovxw/fcitx5-simple-theme                 https://github.com/hosxy/Fcitx5-Material-Color
都crash,不知道啥问题。

最近编辑记录 adamzyg (2020-03-08 14:22:58)


niania

离线

#7 2020-03-12 21:04:45

adamzyg
会员
注册时间: 2019-11-07
帖子: 33

Re: fcitx5 crash which is installed by package fcitx5-git r441.9436416-2

好了,在 ~/.config/fcitx5/conf/pinyin.conf 加上

PreeditInApplicaation=True

这个皮肤爱了 https://github.com/hosxy/Fcitx5-Material-Color,使用起来跟Windows10一样的感觉~


niania

离线

页脚