您尚未登录。

#1 2020-05-17 16:15:45

dxcqcv
会员
注册时间: 2012-12-28
帖子: 239

安装 kubeless 报错,求帮忙

我使用yaourt安装 kubeless,但报错提示go的vendoring不一致,这个如何修复?命令和报错如下

yaourt -S kubeless
Build Kubeless Components binaries
go: inconsistent vendoring in /tmp/yaourt-tmp-clyde/aur-kubeless/src/gopath/src/github.com/kubeless/kubeless:
	golang.org/x/net@v0.0.0-20200226121028-0de0cce0169b: is explicitly required in go.mod, but vendor/modules.txt indicates golang.org/x/net@v0.0.0-20190125091013-d26f9f9a57f3

run 'go mod vendor' to sync, or use -mod=mod or -mod=readonly to ignore the vendor directory
make: *** [Makefile:26: binary] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build kubeless.







我尝试去kubeless目录, `/tmp/yaourt-tmp-clyde/aur-kubeless/src/gopath/src/github.com/kubeless/kubeless`

运行go mod vendor,但是依旧不能成功,报错如下

go mod vendor
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/kubespec
go: finding module for package github.com/google/go-jsonnet/ast
go: finding module for package github.com/go-openapi/spec
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/jsonnet
go: finding module for package github.com/go-openapi/swag
go: finding module for package github.com/google/go-jsonnet/parser
go: finding module for package github.com/blang/semver
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/nodemaker
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/kubeversion
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/printer
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/astext
go: finding module for package github.com/ksonnet/ksonnet-lib/ksonnet-gen/ksonnet
go: found github.com/ksonnet/ksonnet-lib/ksonnet-gen/ksonnet in github.com/ksonnet/ksonnet-lib v0.1.12
go: found github.com/google/go-jsonnet/ast in github.com/google/go-jsonnet v0.15.0
go: found github.com/blang/semver in github.com/blang/semver v3.5.1+incompatible
go: found github.com/go-openapi/spec in github.com/go-openapi/spec v0.19.8
go: found github.com/go-openapi/swag in github.com/go-openapi/swag v0.19.9
go: finding module for package github.com/google/go-jsonnet/parser
github.com/kubeless/kubeless/ksonnet-lib/ksonnet-gen/printer imports
	github.com/google/go-jsonnet/parser: module github.com/google/go-jsonnet@latest found (v0.15.0), but does not contain package github.com/google/go-jsonnet/parser

learning Arch linux

离线

#2 2020-05-27 10:43:41

nsfoxer
会员
注册时间: 2020-04-17
帖子: 12

Re: 安装 kubeless 报错,求帮忙

yaourt 好久之前就不维护了,建议使用 yay 等其他软件

离线

页脚