您尚未登录。

#1 2013-07-04 21:49:52

jiangshen671
会员
注册时间: 2013-07-04
帖子: 4

[已解决] xfce4安装fcitx不能激活!很简单的一个原因!

[jiangweihua@jiang ~]$ fcitx
[jiangweihua@jiang ~]$ (INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-xkbdbus.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-table.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-notificationitem.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-xkb.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-kimpanel-ui.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-unicode.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-punc.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-quickphrase.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-remote-module.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-chttrans.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-dbus.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-classic-ui.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-qw.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-fullwidth-char.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-ipc.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-keyboard.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-freedesktop-notify.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-x11.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-xim.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-imselector.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-autoeng.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-spell.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-vk.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-pinyin-enhance.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-pinyin.conf
(INFO-1356 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-clipboard.conf
(WARN-1356 /build/fcitx/src/fcitx-4.2.8/src/frontend/xim/xim.c:161) 请设置环境变量XMODIFIERS

按wiki的方法安装的,能启动,就是死活不能激活!烦死!

[jiangweihua@jiang ~]$ (INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-xkbdbus.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-table.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-notificationitem.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-xkb.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-kimpanel-ui.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-unicode.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-punc.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-quickphrase.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-remote-module.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-chttrans.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-dbus.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-classic-ui.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-qw.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-fullwidth-char.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-ipc.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-keyboard.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-freedesktop-notify.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-x11.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-xim.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-imselector.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-autoeng.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-spell.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-vk.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-pinyin-enhance.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-pinyin.conf
(INFO-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/addon.c:151) 加载附加组件配置文件: fcitx-clipboard.conf
(WARN-1370 /build/fcitx/src/fcitx-4.2.8/src/module/dbus/dbusstuff.c:246) DBus Service Already Exists
(ERROR-1370 /build/fcitx/src/fcitx-4.2.8/src/lib/fcitx/instance.c:424) Exiting.

什么.xinitrc和.xprofile都试过了,无用!xfce4加silm


[jiangweihua@jiang ~]$ fcitx-diagnose
# 系统信息:
1.  `uname -a`:

        Linux jiang.linux 3.9.8-1-ARCH #1 SMP PREEMPT Fri Jun 28 07:43:59 CEST 2013 i686 GNU/Linux

2.  `lsb_release`:

    `lsb_release` 未找到.

3.  `/etc/lsb-release`:

    `/etc/lsb-release` 未找到.

4.  `/etc/os-release`:

        NAME="Arch Linux"
        ID=arch
        PRETTY_NAME="Arch Linux"
        ANSI_COLOR="0;36"
        HOME_URL="https://www.archlinux.org/"
        SUPPORT_URL="https://bbs.archlinux.org/"
        BUG_REPORT_URL="https://bugs.archlinux.org/"

5.  桌面环境:

    桌面环境为 `xfce`。

# 环境:
1.  DISPLAY:

        DISPLAY=':0.0'

2.  键盘布局:

    1.  `setxkbmap`:

            xkb_keymap {
            	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
            	xkb_types     { include "complete"	};
            	xkb_compat    { include "complete"	};
            	xkb_symbols   { include "pc+us+inet(evdev)"	};
            	xkb_geometry  { include "pc(pc104)"	};
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "evdev", "us", "", ""

3.  Locale:

    1.  全部可用 locale:

            C
            POSIX
            zh_CN
            zh_CN.gb18030
            zh_CN.gb2312
            zh_CN.gbk
            zh_CN.utf8

    2.  当前 locale:

            LANG=zh_CN.UTF-8
            LC_CTYPE="zh_CN.UTF-8"
            LC_NUMERIC="zh_CN.UTF-8"
            LC_TIME="zh_CN.UTF-8"
            LC_COLLATE="zh_CN.UTF-8"
            LC_MONETARY="zh_CN.UTF-8"
            LC_MESSAGES="zh_CN.UTF-8"
            LC_PAPER="zh_CN.UTF-8"
            LC_NAME="zh_CN.UTF-8"
            LC_ADDRESS="zh_CN.UTF-8"
            LC_TELEPHONE="zh_CN.UTF-8"
            LC_MEASUREMENT="zh_CN.UTF-8"
            LC_IDENTIFICATION="zh_CN.UTF-8"
            LC_ALL=

# Fcitx 状态:
1.  可执行文件:

    在 `/usr/bin/fcitx` 找到了 fcitx.

2.  版本:

    Fcitx 版本: `4.2.8`

3.  进程:

    找到了 2 个 fcitx 进程:

         1356 fcitx
         1365 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` 工作正常.

# Fcitx 配置界面:
1.  配置工具封装:

    在 `/usr/bin/fcitx-configtool` 找到了 fcitx-configtool。

2.  用于 GTK+-2.0 的配置界面:

    在 `/usr/bin/fcitx-config-gtk` 找到了 `fcitx-config-gtk`。

3.  用于 GTK+-3.0 的配置界面:

    **未找到 gtk3 的配置界面.**

4.  KDE 的配置界面:

    **`kcmshell4` 未找到.**

# 前端设置:
## Xim:
1.  `${XMODIFIERS}`:

    **请使用您发行版提供的工具将环境变量 XMODIFIERS 设为 "@im=fcitx" 或者将 `export XMODIFIERS=@im=fcitx` 添加到您的 `~/.xprofile` 中. 参见 [输入法相关的环境变量: XMODIFIERS]([url]http://fcitx-im.org/wiki/Input_method_related_environment_variables/zh-cn#XMODIFIERS[/url]).**
    从环境变量中获取的 Xim 服务名称为 fcitx.

2.  根窗口上的 XIM_SERVERS:

    Xim 服务的名称与环境变量中设置的相同.

## Qt:
1.  `${QT_IM_MODULE}`:

    **请使用您发行版提供的工具将环境变量 QT_IM_MODULE 设为 "fcitx" 或者将 `export QT_IM_MODULE=fcitx` 添加到您的 `~/.xprofile` 中. 参见 [输入法相关的环境变量: QT_IM_MODULE]([url]http://fcitx-im.org/wiki/Input_method_related_environment_variables/zh-cn#QT_IM_MODULE[/url]).**
find: “/usr/lib/firmware/b43legacy”: 权限不够
find: “/usr/lib/firmware/b43”: 权限不够

2.  Qt 输入法模块文件:
    找到了 fcitx 的 qt 模块: `/usr/lib/fcitx/qt/libfcitx-quickphrase-editor.so`.
    找到了 Qt4 的输入法模块: `/usr/lib/qt4/plugins/inputmethods/qtim-fcitx.so`.
    Qt5**无法找到 ${1} 的 fcitx 输入法模块.**

## Gtk:
1.  `${GTK_IM_MODULE}`:

    **请使用您发行版提供的工具将环境变量 GTK_IM_MODULE 设为 "fcitx" 或者将 `export GTK_IM_MODULE=fcitx` 添加到您的 `~/.xprofile` 中. 参见 [输入法相关的环境变量: GTK_IM_MODULE]([url]http://fcitx-im.org/wiki/Input_method_related_environment_variables/zh-cn#GTK_IM_MODULE[/url]).**

2.  `gtk-query-immodules`:
find: “/usr/lib/firmware/b43legacy”: 权限不够
find: “/usr/lib/firmware/b43”: 权限不够

    1.  gtk 2:

        在 `/usr/bin/gtk-query-immodules-2.0` 找到了 gtk `2.24.19` 的 `gtk-query-immodules`.
        版本行:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.19

        已找到 gtk `2.24.19` 的 fcitx 输入法模块.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

find: “/usr/lib/firmware/b43legacy”: 权限不够
find: “/usr/lib/firmware/b43”: 权限不够
    2.  gtk 3:

        在 `/usr/bin/gtk-query-immodules-3.0` 找到了 gtk `3.8.2` 的 `gtk-query-immodules`.
        版本行:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.8.2

        已找到 gtk `3.8.2` 的 fcitx 输入法模块.

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

3.  Gtk 输入法模块缓存:

    1.  gtk 2:

        在 `/etc/gtk-2.0/gtk.immodules` 找到了 gtk `2.24.19` 的输入法模块缓存.
        版本行:

            # Created by usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.19

        已找到 gtk `2.24.19` 的 fcitx 输入法模块.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        在 `/usr/lib/gtk-3.0/3.0.0/immodules.cache` 找到了 gtk `3.8.2` 的输入法模块缓存.
        版本行:

            # Created by usr/bin/gtk-query-immodules-3.0 from gtk+-3.8.2

        已找到 gtk `3.8.2` 的 fcitx 输入法模块.

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

4.  Gtk 输入法模块文件:

    1.  gtk 2:

        找到的全部 Gtk 2 输入法模块文件均存在.

    2.  gtk 3:

        找到的全部 Gtk 3 输入法模块文件均存在.

# 配置:
## Fcitx 插件:
1.  插件配置文件目录:

    找到了 fcitx 插件配置目录: `/usr/share/fcitx/addon`.

2.  插件列表:

    1.  找到了 25 个已启用的插件:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  找到了 1 个被禁用的插件:

            fcitx-qw

    3.  用户界面:

        找到了 2 个已启用的用户界面插件:

            fcitx-classic-ui
            fcitx-kimpanel-ui

## 输入法:
^[OF1.  找到了 5 个启用的输入法:

        fcitx-keyboard-us
        pinyin
        shuangpin
        wubi
        wbpy

2.  默认输入法:

    您已经正确的将一个键盘输入法 "fcitx-keyboard-us" 设为默认.

# 日志:
1.  `date`:

        2013年 07月 04日 星期四 21:52:38 UTC

2.  `~/.config/fcitx/log/`:

        总用量 0

3.  `~/.config/fcitx/log/crash.log`:

    `~/.config/fcitx/log/crash.log` 未找到.

最近编辑记录 jiangshen671 (2013-07-05 23:14:21)

离线

#2 2013-07-04 22:37:32

cuihao
所在地: USTC, Hefei
注册时间: 2011-08-19
帖子: 1,222
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

说的不是挺明白么:

1.  `${XMODIFIERS}`:

    **请使用您发行版提供的工具将环境变量 XMODIFIERS 设为 "@im=fcitx" 或者将 `export XMODIFIERS=@im=fcitx` 添加到您的 `~/.xprofile` 中. 参见 [输入法相关的环境变量: XMODIFIERS](http://fcitx-im.org/wiki/Input_method_r … XMODIFIERS).**
    从环境变量中获取的 Xim 服务名称为 fcitx.

xfce 是用什么启动的?slim或直接startx的话,添加下面的内容到 ~/.xinitrc 即可:

export XMODIFIERS="@im=fcitx"
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx

Site: I-YU.ME   Twitter: @cuihaoleo   Org: LUG@USTC
AD:  ~欢迎参与志愿计算~

离线

#3 2013-07-04 23:34:42

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,391
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

C.f. https://bbs.archlinuxcn.org/viewtopic.php?id=1862

不懂 bbcode 就算了,提问前能不能略微搜索下!!!!

离线

#4 2013-07-05 22:05:17

jiangshen671
会员
注册时间: 2013-07-04
帖子: 4

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

我当然有搜索!也改了~/.xinitrc和~/.xprofile,只是没有用!就是这样,不行的话,就换发行版算了!麻烦!

离线

#5 2013-07-05 22:09:47

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,391
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

jiangshen671 说:

我当然有搜索!也改了~/.xinitrc和~/.xprofile,只是没有用!就是这样,不行的话,就换发行版算了!麻烦!

搜索过的话,你就应该明白,不把配置贴出来让大家帮你乱猜一通是不好的。

离线

#6 2013-07-05 22:18:21

cuihao
所在地: USTC, Hefei
注册时间: 2011-08-19
帖子: 1,222
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

报告具体环境啦,
xfce怎么启动的,.xinitrc 和 .xprofile 怎么写的?


Site: I-YU.ME   Twitter: @cuihaoleo   Org: LUG@USTC
AD:  ~欢迎参与志愿计算~

离线

#7 2013-07-05 22:43:45

jiangshen671
会员
注册时间: 2013-07-04
帖子: 4

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

.xprofile

export XMODIFIERS=@im=fcitx
export GTK_IM_MODULE=fcitx # 或者是xim,取决于你是否编译了对应的输入法模块
export QT_IM_MODULE=fcitx # 或者是xim,取决于你是否编译了对应的输入法模块

.xinitrc

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
  exec startxfce4
# ...or the Window Manager of your choice

 eval `dbus-launch --sh-syntax --exit-with-session`
 export GTK_IM_MODULE=fcitx
 export QT_IM_MODULE=fcitx
 export XMODIFIERS="@im=fcitx"

xfce自动启动的,用的这个systemctl enable slim.service
说真的,我不懂,记得上次按wiki的做,可以,这回就不行了。两台电脑都试了,不行!

最近编辑记录 jiangshen671 (2013-07-05 22:44:23)

离线

#8 2013-07-05 22:56:28

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,391
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

jiangshen671 说:

.xinitrc
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
  exec startxfce4
# ...or the Window Manager of your choice

eval `dbus-launch --sh-syntax --exit-with-session`
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS="@im=fcitx"


xfce自动启动的,用的这个systemctl enable slim.service
说真的,我不懂,记得上次按wiki的做,可以,这回就不行了。两台电脑都试了,不行!

果然和我之前贴的链接里的问题一样。

exec 之后的命令是没有机会被执行的(除非 exec 没成功),所以你调整下命令的顺序吧。

离线

#9 2013-07-05 23:02:34

phoenixlzx
晩ご飯だよー
注册时间: 2011-08-19
帖子: 1,789
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

我的 .xprofile 和你稍有不同

export LANG=zh_CN.UTF-8
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

另外自启动也不需要写在 .xinitrc 里, xfce4 自带自启动程序配置的,在 设置 -> 启动应用程序 里,添加 fcitx 即可。你可以手动敲 fcitx 看看可不可以运行,如果报错再把错误贴上来。

记住,只要贴错误报告、日志和配置,不要把火气也贴上来。

离线

#10 2013-07-05 23:05:13

jiangshen671
会员
注册时间: 2013-07-04
帖子: 4

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

可以了,真的是這個原因!謝謝!
想不到啊!只是一个顺序改下!.xinitrc这个文件改下就好了,把添加的内容放在前面。

最近编辑记录 jiangshen671 (2013-07-05 23:07:57)

离线

#11 2013-07-05 23:53:37

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,391
个人网站

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

jiangshen671 说:

可以了,真的是這個原因!謝謝!
想不到啊!只是一个顺序改下!.xinitrc这个文件改下就好了,把添加的内容放在前面。

顺序可不是小事(它是数学研究的三大基本对象之一(我看某人总结的))。
用类 Unix 系统就得习惯它这种要求精确的特性,在关键的地方连一个空格都不能多写(参见一个空格引发的惨剧)。

离线

#12 2020-05-22 09:54:35

tony
会员
注册时间: 2020-05-22
帖子: 1

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

我是没有配置.xprofile、.xinitrc这两个文件,所有配置项都在~/.vnc/xstartup
```
#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

export GTK_IM_MODULE="fcitx"
export QT_IM_MODULE="fcitx"
export XMODIFIERS="@im=fcitx"

fcitx-autostart &

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
vncconfig -iconic &
xfce4-session &

```
在我的机器是能正常输入中文

最近编辑记录 tony (2020-05-22 09:55:56)

离线

#13 2020-05-22 16:37:53

xtricman
エクス·トリクマン
注册时间: 2012-12-26
帖子: 1,236

Re: [已解决] xfce4安装fcitx不能激活!很简单的一个原因!

管理员那个时候对这种标题可真是宽容啊


反社会,精神极其不稳定,随时可能炸碎身边所有人

离线

页脚