您尚未登录。

#1 2020-10-30 21:44:48

wxmaru
会员
注册时间: 2020-10-30
帖子: 2

kitty终端里无法使用fcitx和fcitx5

kitty终端里无法使用fcitx和fcitx5.  (在terminal终端和其他app里都可用)

kitty终端里可以显示和复制黏贴中文。(在.xinitrc和.xprofile里加过变量了)

在kitty.conf里也用env设置过变量。有哪位大神知道是什么原因么? 谢谢!





附:


m2@m2-aspire4253  ~  cat .xprofile           

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=”@im=fcitx”




m2@m2-aspire4253  ~  neofetch
██████████████████  ████████   m2@m2-aspire4253
██████████████████  ████████   ----------------
██████████████████  ████████   OS: Manjaro Linux x86_64
██████████████████  ████████   Host: Aspire 4253 V1.12
████████            ████████   Kernel: 5.8.16-2-MANJARO
████████  ████████  ████████   Uptime: 51 mins
████████  ████████  ████████   Packages: 1360 (pacman)
████████  ████████  ████████   Shell: zsh 5.8
████████  ████████  ████████   Resolution: 1366x768
████████  ████████  ████████   DE: Xfce 4.14
████████  ████████  ████████   WM: Xfwm4
████████  ████████  ████████   WM Theme: Matcha-sea
████████  ████████  ████████   Theme: Matcha-sea [GTK2], Adwaita [GTK3]
████████  ████████  ████████   Icons: Papirus-Maia [GTK2], Adwaita [GTK3]
                               Terminal: kitty
                               Terminal Font: Iosevka Nerd Font 10.0
                               CPU: AMD E-350 (2) @ 1.600GHz
                               GPU: AMD ATI Radeon HD 6310
                               Memory: 1000MiB / 3662MiB

                                                       
                                                       


kitty.conf:
   # env

#: Specify environment variables to set in all child processes. Note
#: that environment variables are expanded recursively, so if you
#: use::

#:     env MYVAR1=a
#:     env MYVAR2=${MYVAR1}/${HOME}/b

#: The value of MYVAR2 will be a/<path to home directory>/b.


env  GTK_IM_MODULE=fcitx
env  QT_IM_MODULE=fcitx
env  XMODIFIERS=”@im=fcitx”

离线

#2 2020-11-01 11:00:27

HiltonLeftChain
会员
所在地: Earth
注册时间: 2017-11-11
帖子: 9
个人网站

Re: kitty终端里无法使用fcitx和fcitx5

KiTTY 並不支持使用 Fcitx 輸入,參見 https://github.com/kovidgoyal/kitty/issues/469


自由软件爱好者,性格怪。

离线

#3 2020-11-01 16:15:49

wxmaru
会员
注册时间: 2020-10-30
帖子: 2

Re: kitty终端里无法使用fcitx和fcitx5

HiltonLeftChain 说:

KiTTY 並不支持使用 Fcitx 輸入,參見 https://github.com/kovidgoyal/kitty/issues/469


谢谢!

离线

#4 2020-11-05 07:07:31

csslayer
会员
注册时间: 2011-09-06
帖子: 14

Re: kitty终端里无法使用fcitx和fcitx5

Fcitx 5 的话,支持的,

GLFW_IM_MODULE=ibus kitty

离线

页脚