您尚未登录。

#1 2020-12-03 22:16:58

kujou
会员
注册时间: 2020-05-21
帖子: 5

YCM调用的python库和系统更新后的版本不同

今天更新了系统,用vi的时候发现YCM出错了,找不到python的库函数。
看了一下发现YCM调用的和系统更新过后的版本不同。
YCM日志:
ImportError: libpython3.8.so.1.0: cannot open shared object file: No such file or directory
然而系统是3.9版本:
python: /usr/bin/python3.9 /usr/bin/python /usr/bin/python3.9-config /usr/lib/python3.9 /usr/lib/python2.7 /usr/include/python3.9 /usr/share/man/man1/python.1.gz
这是出bug了吗?

离线

#2 2020-12-03 23:44:36

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,041
个人网站

Re: YCM调用的python库和系统更新后的版本不同

不是。Python 更新到 3.9 了,所有相关的包都要重新打包一次。自己从 AUR 安装、或者干脆就没有打包的东西,全部要重新打包或者安装一次。

离线

#3 2020-12-03 23:45:49

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,041
个人网站

Re: YCM调用的python库和系统更新后的版本不同

另外 vim 不是 vi。Arch Linux 有提供原版 vi,非常有年代感的。

离线

#4 2020-12-03 23:55:39

kujou
会员
注册时间: 2020-05-21
帖子: 5

Re: YCM调用的python库和系统更新后的版本不同

依云 说:

另外 vim 不是 vi。Arch Linux 有提供原版 vi,非常有年代感的。

啊,一般都直接用alias换掉了,一直这样就习惯了叫vi了:p

应该是AUR没有更新,但自己下载网速感人,看来只能先这么用着了:(

离线

页脚