您尚未登录。

#1 2020-12-28 18:22:45

wuguo13842
会员
注册时间: 2020-12-28
帖子: 5

ssh 配置无法登录

配置ssh总是显示 Access Denied
/etc/ssh/sshd_config 文件如下
#    $OpenBSD: sshd_config,v 1.103 2018/04/09 20:41:22 tj Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/sbin:/usr/local/bin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
LoginGraceTime 120
#PermitRootLogin prohibit-password
PermitRootLogin yes
AllowUsers root
StrictModes yes
#MaxAuthTries 6
#MaxSessions 10


PubkeyAuthentication yes

# The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
# but this is overridden so installations will only check .ssh/authorized_keys
AuthorizedKeysFile    .ssh/authorized_keys

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
# pam does that
#PrintLastLog yes
#TCPKeepAlive yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# override default of no subsystems
Subsystem    sftp    /usr/lib/ssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#    X11Forwarding no
#    AllowTcpForwarding no
#    PermitTTY no
#    ForceCommand cvs server

最近编辑记录 wuguo13842 (2020-12-28 18:25:11)

离线

#2 2020-12-28 18:34:04

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,041
个人网站

Re: ssh 配置无法登录

请检查你的服务端的日志(比如 journalctl -u sshd -n 100)。

离线

#3 2020-12-28 21:24:32

wuguo13842
会员
注册时间: 2020-12-28
帖子: 5

Re: ssh 配置无法登录

依云 说:

请检查你的服务端的日志(比如 journalctl -u sshd -n 100)。

started OpebSSH Daemon
server listenibg on 0.0.0.0 port 22.
server listening on :: port 22
pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=>
failed password for root from 192.168.*.* port 4061 ssh2

其他还有
connection closed by authenticating user root 192.168.*.* port 12350 [preauth]

离线

#4 2020-12-28 22:13:53

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 6,041
个人网站

Re: ssh 配置无法登录

你的密码不对?

离线

#5 2020-12-29 01:05:57

wuguo13842
会员
注册时间: 2020-12-28
帖子: 5

Re: ssh 配置无法登录

依云 说:

你的密码不对?

对的啊 服务端登录都正常 就ssh不正常

离线

#6 2020-12-29 01:09:53

wuguo13842
会员
注册时间: 2020-12-28
帖子: 5

Re: ssh 配置无法登录

依云 说:

你的密码不对?

解决了 passwd 重新设密码好了
原来小键盘锁没开
导致 "英文+数字" 密码变纯英文

最近编辑记录 wuguo13842 (2020-12-29 03:00:36)

离线

页脚