您尚未登录。

#1 2020-12-27 13:06:54

布丁酱
Arch!Arch!Arch!
所在地: 成都
注册时间: 2020-07-27
帖子: 50
个人网站

deepin.com.qq.office 升级依赖冲突无法解决

:: 2 Packages to upgrade.
2  aur/deepin.com.qq.office  2.0.0_4-2                                              -> 2.0.0_4-3
1  aur/zerotier-one-git      central.controller.1.4.6.202003040912.r344.g9d0b4926-1 -> pkgver-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==>
:: Checking for conflicts...
:: Checking for inner conflicts...
->
Package conflicts found:
-> Installing deepin-wine-helper-modify will remove: deepin-wine-helper
-> Conflicting packages will have to be confirmed manually
[Aur:3]  deepin-wine-helper-modify-5.1.13-1  deepin.com.qq.office-2.0.0_4-3  zerotier-one-git-pkgver-1

  3 deepin-wine-helper-modify        (Build Files Exist)
  2 deepin.com.qq.office             (Installed) (Build Files Exist)
  1 zerotier-one-git                 (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: PKGBUILD up to date, Skipping (1/3): zerotier-one-git
:: PKGBUILD up to date, Skipping (2/3): deepin.com.qq.office
:: PKGBUILD up to date, Skipping (3/3): deepin-wine-helper-modify
  3 deepin-wine-helper-modify        (Build Files Exist)
  2 deepin.com.qq.office             (Installed) (Build Files Exist)
  1 zerotier-one-git                 (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: (1/3) Parsing SRCINFO: deepin-wine-helper-modify
:: (2/3) Parsing SRCINFO: deepin.com.qq.office
:: (3/3) Parsing SRCINFO: zerotier-one-git

......

-> deepin-wine-helper-modify-5.1.13-1 already made -- skipping build
-> deepin-wine-helper-modify not satisfied, flushing install queue
正在加载软件包...
正在解析依赖关系...
正在查找软件包冲突...
:: deepin-wine-helper-modify 与 deepin-wine-helper 有冲突。删除 deepin-wine-helper 吗? [y/N] y
错误:无法准备事务处理 (无法满足依赖关系)
:: 删除 deepin-wine-helper 破坏依赖 'deepin-wine-helper' (com.qq.weixin.spark 需要)
:: 删除 deepin-wine-helper 破坏依赖 'deepin-wine-helper' (deepin-wine 需要)


布丁酱是菜鸡,没毛病,他是菜鸡:)

离线

#2 2020-12-28 10:59:19

bincker
会员
注册时间: 2020-12-02
帖子: 3

Re: deepin.com.qq.office 升级依赖冲突无法解决

我之前无法更新,去aur查了一下果断换上com.qq.tim.spark

离线

#3 2020-12-28 14:22:31

布丁酱
Arch!Arch!Arch!
所在地: 成都
注册时间: 2020-07-27
帖子: 50
个人网站

Re: deepin.com.qq.office 升级依赖冲突无法解决

我试试


布丁酱是菜鸡,没毛病,他是菜鸡:)

离线

#4 2020-12-28 15:14:34

布丁酱
Arch!Arch!Arch!
所在地: 成都
注册时间: 2020-07-27
帖子: 50
个人网站

Re: deepin.com.qq.office 升级依赖冲突无法解决

我换了deepin-wine5的TIM,发现中文字体变成方框,你怎么解决的呢?

最近编辑记录 布丁酱 (2020-12-28 17:00:50)


布丁酱是菜鸡,没毛病,他是菜鸡:)

离线

#5 2021-01-04 18:58:38

bincker
会员
注册时间: 2020-12-02
帖子: 3

Re: deepin.com.qq.office 升级依赖冲突无法解决

/opt/apps/com.qq.tim.spark/files/run.sh
添加

export LANG="zh_CN.utf8"

即可,不过你要先确认

locale -a

中有

最近编辑记录 bincker (2021-01-04 19:12:27)

离线

#6 2021-01-10 11:57:02

primes
会员
注册时间: 2015-07-29
帖子: 43

Re: deepin.com.qq.office 升级依赖冲突无法解决

bincker 说:

我之前无法更新,去aur查了一下果断换上com.qq.tim.spark

非常正确,现在.spark系列是最稳定滴!

离线

页脚