您尚未登录。

#1 2022-11-30 01:20:31

SamLukeYes
会员
所在地: Canton, China
注册时间: 2020-07-19
帖子: 317
个人网站

关于之前请求删除 deepin-udis86 的原因与相关的问题解答

刚刚发现我之前请求删除的 deepin-udis86 重新在 AUR 中出现了,我想我有必要重申一下删除这个包的原因并解答一些问题。

Q1: deepin-udis86 有什么问题?
A1: 这个包的问题主要有以下两个方面。
    1. 命名不规范。这个包是一个 32 位包,且已经存在对应的 64 位包 udis86,却并没有以 lib32- 开头;udis86 是一个开源软件,这个包直接用了 deepin 打包的二进制文件,但没有以 -bin 结尾。这个问题直接导致了 deepin-udis86 不应该作为一个软件包名而存在,正确的包名应该是 lib32-udis86-deepin-bin。
    2. 作为一个 32 位包,它的文件与原生的 udis86 发生了冲突。

Q2: 我维护的软件包依赖 deepin-udis86 怎么办?
A2: 为了不破坏已有的软件包,作为权宜之计,目前我打包的 lib32-udis86-git 提供了 deepin-udis86,但并不一定所有原本依赖 deepin-udis86 的包都能由 lib32-udis86-git 满足依赖。如果你的软件包依赖 udcli 程序或 64 位的 libudis86.so,则需要注明依赖 udis86。

Q3: 目前 AUR 上提供 lib32-udis86 的软件包只有 lib32-udis86-git,但我不希望使用 vcs 包,怎么办?
A3: udis86 在 sourceforge 的上游已经很久没有维护了,我找到的比较活跃维护的 fork 也很久没有新 tag,因而选择了 vcs 包的形式。如果你不喜欢这种形式,可以选择自行从源代码打包 lib32-udis86,或者将 deepin-udis86 重新打包为 lib32-udis86-deepin-bin,但需要注意 A1 中提到的第 2 点问题。

Q4: 我的 AUR 助手找不到依赖 deepin-udis86 或 lib32-udis86,怎么办?
A4: lib32-udis86-git 已经提供了这两者。如果你的 AUR 助手找不到这些依赖,请查找 AUR 助手相关的已知问题,或将问题报告给 AUR 助手的维护者。

Q5: 构建安装 udis86-git/lib32-udis86-git 时,找不到所需的密钥怎么办?
A5: 这两个包的 PKGBUILD 都已经在注释中写了获取这个密钥的链接,自行用 gpg --import 导入即可。

最近编辑记录 SamLukeYes (2022-12-25 19:53:29)

离线

#2 2023-01-12 15:58:09

soul11201
会员
注册时间: 2023-01-12
帖子: 2

Re: 关于之前请求删除 deepin-udis86 的原因与相关的问题解答

Aur (1) lib32-udis86-git-1.7.2.186.g5336633-1

:: Proceed to review? [Y/n]:

:: Downloading PKGBUILDs...
PKGBUILDs up to date
nothing new to review
:: keys need to be imported:
     A5DD905196EF3973280DA13CB965BC5D279F42ED wanted by: lib32-udis86-git-1.7.2.186.g5336633-1
:: import? [Y/n]:
gpg: keyserver receive failed: No data
error: failed to run: gpg --recv-keys A5DD905196EF3973280DA13CB965BC5D279F42ED:
❯ gpg --recv-keys A5DD905196EF3973280DA13CB965BC5D279F42ED
gpg: keyserver receive failed: No data







:: Downloading PKGBUILDs...
PKGBUILDs up to date
nothing new to review
:: keys need to be imported:
     A5DD905196EF3973280DA13CB965BC5D279F42ED wanted by: lib32-udis86-git-1.7.2.186.g5336633-1
:: import? [Y/n]: n
fetching devel info...
==> Making package: lib32-udis86-git 1.7.2.186.g5336633-1 (Thu 12 Jan 2023 04:02:21 PM CST)
==> Retrieving sources...
  -> Cloning udis86 git repo...
Cloning into bare repository '/home/yangzhenzhen/.cache/paru/clone/lib32-udis86-git/udis86'...
remote: Enumerating objects: 2477, done.
remote: Counting objects: 100% (63/63), done.
remote: Compressing objects: 100% (43/43), done.
remote: Total 2477 (delta 34), reused 46 (delta 20), pack-reused 2414
Receiving objects: 100% (2477/2477), 1.81 MiB | 249.00 KiB/s, done.
Resolving deltas: 100% (1503/1503), done.
==> Validating source files with sha512sums...
    udis86 ... Skipped
==> Verifying source file signatures with gpg...
    udis86 git repo ... FAILED (unknown public key B965BC5D279F42ED)
==> ERROR: One or more PGP signatures could not be verified!
error: failed to download sources for 'lib32-udis86-git-1.7.2.186.g5336633-1':
error: packages failed to build: lib32-udis86-git-1.7.2.186.g5336633-1

最近编辑记录 soul11201 (2023-01-12 16:04:05)

离线

#3 2023-01-12 16:06:45

soul11201
会员
注册时间: 2023-01-12
帖子: 2

Re: 关于之前请求删除 deepin-udis86 的原因与相关的问题解答

PKGBUILDS里面答案~~~

curl https://github.com/canihavesomecoffee.gpg | gpg --import

离线

页脚